Find the answer to your Linux question:
Results 1 to 5 of 5
i think i messed up the hostname in the laptop which runs ubuntu, it had a hostname, but i went to System -> Administration -> networking and deleted it and ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2006
    Posts
    28

    i think i messed up the hostname


    i think i messed up the hostname in the laptop which runs ubuntu, it had a hostname, but i went to System -> Administration -> networking and deleted it and now when i type sudo su in the terminal it says

    sudo: unable to lookup (none) via gethostbyname()


    and then i thought of finding out what hostname i have i type "hostname" and
    it says

    (none)

    how do i get the hostname back, since if i type su and then press enter then it asks for the password and the password does not work.

    the other problem is when i try to go back to System -> Administration -> networking then the networking window does not open any more, (it used to open before i deleted the hostname),

    can somebody tell me how to fix this,

  2. #2
    Linux User towy71's Avatar
    Join Date
    May 2006
    Location
    West Wales
    Posts
    322
    sudo hostname <yourhostname> ought to work
    free/libre/open software for the people by the people
    Linux user #185360

  3. #3
    Linux Newbie
    Join Date
    Oct 2006
    Posts
    107
    Are you making any progress with that lappy? Still unable to get into networking?

  4. #4
    Just Joined!
    Join Date
    Jul 2006
    Posts
    28
    well i forgot the old hostname which i deleted so when i type sudo hostname <newhostname> then it shows the same message

    sudo: unable to lookup (none) via gethostbyname()

  5. #5
    Just Joined!
    Join Date
    Sep 2006
    Posts
    1

    Still unresolved Ubuntu bug

    There's still no fix available for this, short of reinstalling the operating system:

    https://bugs.launchpad.net/distros/u...udo/+bug/32906
    http://ubuntuforums.org/showthread.php?t=196607

    google "via getbyhostname" and you'll find a great many people with the problem, and no solution that's worked other than reinstalling the OS.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •