Find the answer to your Linux question:
Results 1 to 8 of 8
I installed the nvidia driver and all is functional exept that the screen res is stuck in 640x480. when i change the driver back to vesa it looks fine again. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2006
    Posts
    38

    NVIDIA xorg.conf


    I installed the nvidia driver and all is functional exept that the screen res is stuck in 640x480. when i change the driver back to vesa it looks fine again. I had previously installed ubuntu 6.06 got rid of it and now i got it back. The first time i installed i coppied and pasted someone elses xorg.conf file and that fixed the problem im having now. If someone can give me a xorg.conf file or tell me whats wrong with the following i would be greatful.

  2. #2
    Just Joined!
    Join Date
    May 2006
    Posts
    38
    forgot to post file

    #xorg.conf starts here

    # /etc/X11/xorg.conf (xorg X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
    # (Type "man /etc/X11/xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    # sudo dpkg-reconfigure -phigh xserver-xorg

    Section "Files"
    FontPath "/usr/share/X11/fonts/misc"
    FontPath "/usr/share/X11/fonts/cyrillic"
    FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
    FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
    FontPath "/usr/share/X11/fonts/Type1"
    FontPath "/usr/share/X11/fonts/100dpi"
    FontPath "/usr/share/X11/fonts/75dpi"
    # path to defoma fonts
    FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    EndSection

    Section "Module"
    Load "i2c"
    Load "bitmap"
    Load "ddc"
    Load "dri"
    Load "extmod"
    Load "freetype"
    Load "glx"
    Load "int10"
    Load "type1"
    Load "vbe"
    EndSection

    Section "InputDevice"
    Identifier "Generic Keyboard"
    Driver "kbd"
    Option "CoreKeyboard"
    Option "XkbRules" "xorg"
    Option "XkbModel" "pc104"
    Option "XkbLayout" "us"
    EndSection

    Section "InputDevice"
    Identifier "Configured Mouse"
    Driver "mouse"
    Option "CorePointer"
    Option "Device" "/dev/input/mice"
    Option "Protocol" "ExplorerPS/2"
    Option "ZAxisMapping" "4 5"
    Option "Emulate3Buttons" "true"
    EndSection

    Section "InputDevice"
    Driver "wacom"
    Identifier "stylus"
    Option "Device" "/dev/wacom" # Change to
    # /dev/input/event
    # for USB
    Option "Type" "stylus"
    Option "ForceDevice" "ISDV4" # Tablet PC ONLY
    EndSection

    Section "InputDevice"
    Driver "wacom"
    Identifier "eraser"
    Option "Device" "/dev/wacom" # Change to
    # /dev/input/event
    # for USB
    Option "Type" "eraser"
    Option "ForceDevice" "ISDV4" # Tablet PC ONLY
    EndSection

    Section "InputDevice"
    Driver "wacom"
    Identifier "cursor"
    Option "Device" "/dev/wacom" # Change to
    # /dev/input/event
    # for USB
    Option "Type" "cursor"
    Option "ForceDevice" "ISDV4" # Tablet PC ONLY
    EndSection

    Section "Device"
    Identifier "NVIDIA Corporation NV18 [GeForce4 MX - nForce GPU]"
    Driver "nv"
    BusID "PCI:1:0:0"
    EndSection

    Section "Monitor"
    Identifier "ULTRASCANP99"
    Option "DPMS"
    EndSection

    Section "Screen"
    Identifier "Default Screen"
    Device "NVIDIA Corporation NV18 [GeForce4 MX - nForce GPU]"
    Monitor "ULTRASCANP99"
    DefaultDepth 24
    SubSection "Display"
    Depth 1
    Modes "1280x1024" "1024x768" "800x600" "720x400" "720x350" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 4
    Modes "1280x1024" "1024x768" "800x600" "720x400" "720x350" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 8
    Modes "1280x1024" "1024x768" "800x600" "720x400" "720x350" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 15
    Modes "1280x1024" "1024x768" "800x600" "720x400" "720x350" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 16
    Modes "1280x1024" "1024x768" "800x600" "720x400" "720x350" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "1280x1024" "1024x768" "800x600" "720x400" "720x350" "640x480"
    EndSubSection
    EndSection

    Section "ServerLayout"
    Identifier "Default Layout"
    Screen "Default Screen"
    InputDevice "Generic Keyboard"
    InputDevice "Configured Mouse"
    InputDevice "stylus" "SendCoreEvents"
    InputDevice "cursor" "SendCoreEvents"
    InputDevice "eraser" "SendCoreEvents"
    EndSection

    Section "DRI"
    Mode 0666
    EndSection

  3. #3
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    How did you install the drivers ?

    Did you do it like that ?
    https://help.ubuntu.com/community/Bi...erHowto/Nvidia

    If so, just make sure you use the "nvidia" driver in your /etc/X11/xorg.conf and not the "nv" one.
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  4. #4
    Just Joined!
    Join Date
    May 2006
    Posts
    38
    Ive tried changing the driver to nvidia and it acts exactly the same. I have tried that way to install it and others and it didnt work. It all ends up stuck in 640x480

  5. #5
    Just Joined!
    Join Date
    Oct 2006
    Location
    Turkey
    Posts
    45
    remove the line Load "dri" from the Section "Module" and change the driver "nv" to "nvidia". it should work

  6. #6
    Just Joined!
    Join Date
    Oct 2006
    Location
    Turkey
    Posts
    45
    you can also change lines;
    Modes "1280x1024" "1024x768" "800x600" "720x400" "720x350" "640x480"

    as

    Modes "1024x768" "800x600"


    if it doesn't work at 1280x1024(frequence over range may be).

  7. #7
    Just Joined!
    Join Date
    May 2006
    Posts
    38
    ive solved my problem. I just did sudo dpkg-reconfigure xserver-xorg and followed the steps

  8. #8
    Just Joined!
    Join Date
    May 2004
    Posts
    23
    You can also go to www.automatix.com and follow the instructions there for this utility... a great one by the way, made my nvidia install absolutley flawless and easy

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •