Find the answer to your Linux question:
Results 1 to 8 of 8
Recently, I switched over from SUSE 10.1 to Kubuntu 6.10 Edgy Eft. With SUSE, I had gotten my GeForce 2 working perfectly, but my experience is rougher with Kubuntu. I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2006
    Location
    Minnesota, USA
    Posts
    39

    Unhappy Kubuntu 6.10, GeForce 2 MX woes


    Recently, I switched over from SUSE 10.1 to Kubuntu 6.10 Edgy Eft. With SUSE, I had gotten my GeForce 2 working perfectly, but my experience is rougher with Kubuntu.

    I downloaded the nVidia linux legacy driver, and after installing my xorg-dev package, I finally got the nVidia installer to finish with no errors. I also changed my xorg.conf file to use the nvidia driver instead of nv. I also removed Load "dri", and made sure that Load "glx" is in my xorg.conf file.

    Everything works ok, the nVidia logo comes up when starting X, until I try to run something that needs 3D. Running tuxkart tells me the GLX extension is not availible on display ':0.0'. PlanetPenguin Racer reports "error: Couldn't initialize video: Couldn't fine matching GLX visual (success) Segmentation fault"

    Starting the NVIDIA X Server Settings and going to "OpenGL/GLX information" tells me "The OpenGL extension 'GLX' is not supported by the X server or there was a problem retrieving GLX information from the X server".

    I am running Kubuntu 6.10 (xorg7.1.1) with the latest version of the NVIDIA binary driver. My kernal was recompiled for nvidia's driver.

    Can anyone help? I can get more info if needed.

  2. #2
    Just Joined!
    Join Date
    Jun 2006
    Posts
    2

    geforce mx 2

    Quote Originally Posted by i80and
    Recently, I switched over from SUSE 10.1 to Kubuntu 6.10 Edgy Eft. With SUSE, I had gotten my GeForce 2 working perfectly, but my experience is rougher with Kubuntu.

    I downloaded the nVidia linux legacy driver, and after installing my xorg-dev package, I finally got the nVidia installer to finish with no errors. I also changed my xorg.conf file to use the nvidia driver instead of nv. I also removed Load "dri", and made sure that Load "glx" is in my xorg.conf file.

    Everything works ok, the nVidia logo comes up when starting X, until I try to run something that needs 3D. Running tuxkart tells me the GLX extension is not availible on display ':0.0'. PlanetPenguin Racer reports "error: Couldn't initialize video: Couldn't fine matching GLX visual (success) Segmentation fault"

    Starting the NVIDIA X Server Settings and going to "OpenGL/GLX information" tells me "The OpenGL extension 'GLX' is not supported by the X server or there was a problem retrieving GLX information from the X server".

    I am running Kubuntu 6.10 (xorg7.1.1) with the latest version of the NVIDIA binary driver. My kernal was recompiled for nvidia's driver.

    Can anyone help? I can get more info if needed.
    It would help if you told us how much memory you have on the card and how old is it and is it a plain mx, mx 200 or mx 400. It also might help if you told us what mobo you are using including mem

  3. #3
    Just Joined!
    Join Date
    Nov 2006
    Location
    Minnesota, USA
    Posts
    39
    I fear that I have no idea what my mobo is. I have 512mb RAM, my video card has 32mb video memory, and if I have to make a guess, I'd say it's an MX400. (Not sure though).

    It's quite old; if I can find the box then I can be more precise. Sorry I don't know more.

  4. #4
    Just Joined!
    Join Date
    Nov 2006
    Location
    Minnesota, USA
    Posts
    39
    Ok, what I can find out from the NVIDIA X Server Settings is that it's a
    GeForce2 MX/MX 400
    VBIOS Version 03.11.01.30.63
    32MB video memory
    IRQ 11
    driver version 1.0-7184.

  5. #5
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Quote Originally Posted by i80and
    Everything works ok, the nVidia logo comes up when starting X, until I try to run something that needs 3D. Running tuxkart tells me the GLX extension is not availible on display ':0.0'. PlanetPenguin Racer reports "error: Couldn't initialize video: Couldn't fine matching GLX visual (success) Segmentation fault"
    So you used the latest NVIDIA legacy installer ?

    Perhaps it doesn't support xorg 7.1...

    Here is what you can try. First check out if X doesn't give you any more specific errors :
    Code:
    cat /var/log/Xorg.0.log | grep -i glx
    or
    Code:
    cat /var/log/Xorg.0.log | grep EE
    I'm guessing here that the NVIDIA installer installed the GLX module in the wrong place, so the old GLX gets loaded, and doesn't match with the NVIDIA driver.

    So, 3 possibilities here, 3 different ways of fixing this :

    1) Add the NVIDIA GLX module path to xorg.conf (your exact path may differ) :
    Code:
    Section "Files"
            ModulePath "/usr/lib/xorg/modules/extensions/nvidia,/usr/lib/xorg/modules"
    EndSection
    2) you can make a symlink from the new GLX module to the old one. As X loads the GLX module present in /usr/lib/xorg/modules/extensions/libglx.so, make sure this is the one from NVIDIA.

    3) Reinstall the NVIDIA driver using this command :
    Code:
    sudo sh NVIDIA-Linux-x86-1.0-7184-pkg1.run --x-module-path=/usr/lib/xorg/modules
    so that GLX will be put in the right place.
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  6. #6
    Just Joined!
    Join Date
    Nov 2006
    Location
    Minnesota, USA
    Posts
    39
    I ran the first suggestion and that didn't work. The command
    Code:
    cat /var/log/Xorg.0.log | grep -i glx
    returned "(EE) GLX is not supported with the Composite extension".
    I checked xorg.conf for option composite, but it wasn't there.

  7. #7
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Quote Originally Posted by i80and
    I ran the first suggestion and that didn't work. The command
    Code:
    cat /var/log/Xorg.0.log | grep -i glx
    returned "(EE) GLX is not supported with the Composite extension".
    I checked xorg.conf for option composite, but it wasn't there.
    Then you must add :
    Code:
    Option          "AllowGLXWithComposite" "true"
    to Section "Device".

    Still, make sure that the right GLX gets loaded, the one from NVIDIA.
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  8. #8
    Just Joined!
    Join Date
    Nov 2006
    Location
    Minnesota, USA
    Posts
    39

    Talking Thanks!

    Thanks! It's working now!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •