Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
Alright, I am a complete noob to Linux, so please be patient with me I installed Xubuntu on an old PC, and I am trying to install ndiswrapper to set ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2006
    Posts
    10

    Problems Attempting to Install "make" Command


    Alright, I am a complete noob to Linux, so please be patient with me

    I installed Xubuntu on an old PC, and I am trying to install ndiswrapper to set up a wireless connection. I don't have the "make" command, so I am trying to use my install CD to install it.

    First I entered
    Code:
    sudo apt-cdrom add
    and got
    Code:
    Using CD-ROM mount point /cdrom/
    Unmounting CD-ROM
    Waiting for disc...
    Please insert a Disc in the drive and press enter
    I already had the install disk in the CD-ROM, so I just pressed enter. Then I got
    Code:
    Mounting CD-ROM...
    Identifying.. [2dbbea54bdd03123a59a8705a45b9d57-2]
    Scanning disc for index files..
    Found 2 package indexes, 0 source indexes and 1 signatures
    This disc is called:
    'Xubuntu 6.10 _Edgy Eft_ - Release i386 (20061025)'
    Copying package lists...gpgv: Signature made Wed 25 Oct 2006 11:49:05 AM CDT using DSA key ID FBB75451
    gpgv: Good signature from "Ubuntu CD Image Automatic Signing Key <cdimage@ubuntu.com>"
    Reading Package Inxdexes... Done
    Writing new source list
    Source list entries for this disc are:
    deb cdrom:[Xubuntu 6.10 _Edgy Eft_ - Release i386 (20061025)]/ edgy main restricted
    Unmounting CD-ROM...Repeat this process for the rest of the CDs in your set.
    Now does "edgy main restricted" mean something is wrong, and that it why I cannot install the "make" command?

    After I got that message, I continued with the command
    Code:
    sudo aptitude update
    and I got
    Code:
    Reading package lists... Done
    Building dependency tree... Done
    Reading extended state information
    Initializing package states... Done
    Building tag database... Done
    Err http://security.ubuntu.com dapper-security Release.gpg
      Temporary failure resolving 'security.ubuntu.com'
    Err http://us.archive.ubuntu.com dapper Release.gpg
      Temporary failure resolving 'us.archive.ubuntu.com'
    Err http://us.archive.ubuntu.com dapper-updates Release.gpg
      Temporary failure resolving 'us.archive.ubuntu.com'
    Reading package lists... Done
    Then I entered the command
    Code:
    sudo aptitude install build-essential
    and got
    Code:
    Reading package lists... Done
    Building dependency tree... Done
    Reading extended state information
    Initializing package states... Done
    Building tag database... Done
    The following packages are BROKEN:
      build-essential dpkg-dev g++ g++-4.1 libc6-dev libstdc++6-4.1-dev
    The following NEW packages will be automatically installed:
      binutils cpp cpp-4.0 gcc gcc-4.0 linux-libc-dev make
    The following NEW packages will be installed:
      binutils cpp cpp-4.0 gcc gcc-4.0 linux-libc-dev make
    0 packages upgraded, 13 newly installed, 0 to remove and 0 not upgraded.
    Need to get 0B/12.2MB of archives. After unpacking 44.9MB will be used.
    The following packages have unmet dependencies:
      g++-4.1: Depends: gcc-4.1-base (= 4.1.1-13ubuntu5) which is a virtual package.           Depends: gcc-4.1 (= 4.1.1-13ubuntu5) which is a virtual package.
               Depends: libc6 (>= 2.4-1) but 2.3.6-0ubuntu20 is installed.
      g++: Depends: cpp (>= 4:4.1.1-6ubuntu3) but 4:4.0.3-1 is to be installed.
           Depends: gcc (>= 4:4.1.1-6ubuntu3) but 4:4.0.3-1 is to be installed.
           Depends: gcc-4.1 (>= 4.1.1-2) which is a virtual package.
      libstdc++6-4.1-dev: Depends: gcc-4.1-base (= 4.1.1-13ubuntu5) which is a virtual package.
                          Depends: libstdc++6 (>= 4.1.1-13ubuntu5) but 4.0.3-1ubuntu5 is installed.
      dpkg-dev: Depends: dpkg (>= 1.13.20) but 1.13.11ubuntu6 is installed.
      libc6-dev: Depends: libc6 (= 2.4-1ubuntu12) but 2.3.6-0ubuntu20 is installed.
      build-essential: Depends: gcc (>= 4:4.1.1) but 4:4.0.3-1 is to be installed.
    Resolving dependencies...
    The following actions will resolve these deapendencies:
    
    Install the following packages:
    libc6-dev [2.3.6-0ubuntu20 (dapper)]
    linux-kernel-headers [2.6.11.2-0ubuntu18 (dapper)]
    
    Keep the following packages at their current version:
    build-essential [Not Installed]
    dpkg-dev [Not Installed]
    g++ [Not Installed]
    g++-4.1 [Not Installed]
    gcc [Not Installed]
    gcc-4.0 [Not Installed]
    libstdc++6-4.1-dev [Not Installed]
    linux-libc-dev [Not Installed]
    
    Leave the following dependencies unresolved:
    libc6-dev recommends gcc | c-compiler
    Score is -237
    Then it asked me if the changes were OK, and I entered Y for yes, and got
    Code:
    No packages will be installed, upgraded, or removed.
    0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Need to get 0B of archives. After unpacking 0B will be used.
    Any ideas on what I'm doing wrong and what/how it can be fixed?

  2. #2
    Linux Guru Vergil83's Avatar
    Join Date
    Mar 2004
    Posts
    2,407
    can you post your /etc/apt/sources.list ?
    Brilliant Mediocrity - Making Failure Look Good

  3. #3
    Linux Guru bryansmith's Avatar
    Join Date
    Nov 2004
    Location
    /Ontario/Canada
    Posts
    2,619
    Do what Vergil83 asked. The problem is that there are online sources in your sources.list so when you do an update, it is trying to contact the online repos as well.

    Bryan
    Looking for a distro? Look here.
    "There can be no doubt that all our knowledge begins with experience." - Immanuel Kant (Critique of Pure Reason)
    Queen's University - Arts and Science 2008 (Sociology)
    Registered Linux User #386147.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Nov 2006
    Posts
    10
    Heres my sources.list
    Code:
    #
    deb cdrom:[Xubuntu 6.10 _Edgy Eft_ - Release i386 (20061025)]/ edgy main restricted
    deb cdrom:[Xubuntu 6.06.1 _Dapper Drake_ - Release i386 (20060807)]/ dapper main restricted
    
    
    deb cdrom:[Xubuntu 6.06.1 _Dapper Drake_ - Release i386 (20060807)]/ dapper main restricted
    
    deb http://us.archive.ubuntu.com/ubuntu/ dapper main restricted
    deb-src http://us.archive.ubuntu.com/ubuntu/ dapper main restricted
    
    ## Major bug fix updates produced after the final release of the
    ## distribution.
    deb http://us.archive.ubuntu.com/ubuntu/ dapper-updates main restricted
    deb-src http://us.archive.ubuntu.com/ubuntu/ dapper-updates main restricted
    
    ## Uncomment the following two lines to add software from the 'universe'
    ## repository.
    ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    ## team, and may not be under a free licence. Please satisfy yourself as to
    ## your rights to use the software. Also, please note that software in
    ## universe WILL NOT receive any review or updates from the Ubuntu security
    ## team.
    # deb http://us.archive.ubuntu.com/ubuntu/ dapper universe
    # deb-src http://us.archive.ubuntu.com/ubuntu/ dapper universe
    
    ## Uncomment the following two lines to add software from the 'backports'
    ## repository.
    ## N.B. software from this repository may not have been tested as
    ## extensively as that contained in the main release, although it includes
    ## newer versions of some applications which may provide useful features.
    ## Also, please note that software in backports WILL NOT receive any review
    ## or updates from the Ubuntu security team.
    # deb http://us.archive.ubuntu.com/ubuntu/ dapper-backports main restricted universe multiverse
    # deb-src http://us.archive.ubuntu.com/ubuntu/ dapper-backports main restricted universe multiverse
    
    
    deb http://security.ubuntu.com/ubuntu dapper-security main restricted
    deb-src http://security.ubuntu.com/ubuntu dapper-security main restricted
    # deb http://security.ubuntu.com/ubuntu dapper-security universe
    # deb-src http://security.ubuntu.com/ubuntu dapper-security universe

  6. #5
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    If you don't have an internet connection right now, comment every line of your /etc/apt/sources.list (by adding a # at the begining of the line), except the first one :
    Code:
    deb cdrom:[Xubuntu 6.10 _Edgy Eft_ - Release i386 (20061025)]/ edgy main restricted
    Then run :
    Code:
    sudo aptitude update
    to update the repositories.

    By the way, you don't need to compile anything to install ndiswrapper. Simply :
    Code:
    sudo aptitude install ndiswrapper-utils
    will do it.
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  7. #6
    Just Joined!
    Join Date
    Nov 2006
    Posts
    10
    Alright, I tried adding # to the beginning of each line in sources.list except for the first one, but when I tried to save it, I got "Can't open file to write"

    I also tried
    Code:
    sudo aptitude install ndiswrapper-utils
    and got
    Code:
    Reading package lists... Done
    Building dependency tree... Done
    Reading extended state information
    Initializing package states... Done
    Building tag database... Done
    The following NEW packages will be installed:
      ndiswrapper-utils
    0 packages upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
    Need to get 0B/27.6kB of archives. After unpacking 139kB will be used.
    Writing extended state information... Done
    Media Change: Please insert the disc labeled 'Xubuntu 6.06.1 _Dapper Drake_ - Release i386 (20060807)' in the drive '/cdrom/' and press enter
    The CD was already in the drive, so I hit enter, and then got another line of code that said Aborted. Can't post the line of code because when I click "Sumbit Reply" I get redirected to a page that says "Could not find the page you requested."
    Aborted[/CODE]

  8. #7
    Linux Guru bryansmith's Avatar
    Join Date
    Nov 2004
    Location
    /Ontario/Canada
    Posts
    2,619
    You can not write to the file because it requires root privileges to write to. Open the file like so:
    Code:
    sudo <your editor of choice> /etc/apt/sources.list
    Bryan
    Looking for a distro? Look here.
    "There can be no doubt that all our knowledge begins with experience." - Immanuel Kant (Critique of Pure Reason)
    Queen's University - Arts and Science 2008 (Sociology)
    Registered Linux User #386147.

  9. #8
    Just Joined!
    Join Date
    Nov 2006
    Posts
    10
    Alright, well I tried
    Code:
    sudo mousepad /etc/apt/sources.list
    and made the changes, but nothing has changed as far as getting the make command to work or installing ndiswrapper. Then I also did
    Code:
    sudo aptitude update
    and got
    Code:
    Reading package lists... Done
    Building dependency tree... Done
    Reading extended state information
    Initializing package states... Done
    Building tag database... Done
    Reading package lists... Done
    Still no changes.

    I tried to install ndiswrapper with
    Code:
    sudo aptitude install ndiswrapper-utils
    and then I got
    Code:
    Reading package lists... Done
    Building dependency tree... Done
    Reading extended state information
    Initializing package states... Done
    Building tag database... Done
    The following packages are BROKEN:
      ndiswrapper-utils-1.1
    The following NEW packages will be automatically installed:
      ndiswrapper-common
    The following NEW packages will be installed:
      ndiswrapper-common ndiswrapper-utils
    0 packages upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
    Need to get 0B/47.4kB of archives. After unpacking 250kB will be used.
    The following packages have unmet dependencies:
      ndiswrapper-utils-1.1: Depends: libc6 (>= 2.4-1) but 2.3.6-0ubuntu20 is installed.
    Resolving dependencies...
    The following actions will resolve these dependencies:
    
    Keep the following packages at their current version:
    ndiswrapper-utils [Not Installed]
    ndiswrapper-utils-1.1 [Not Installed]
    
    Score is 8
    Then it asked me to answer yes or no, and after I answer yes it just says the stuff about no packages will be installed, upgraded, or removed. Etc.

  10. #9
    Linux Guru bryansmith's Avatar
    Join Date
    Nov 2004
    Location
    /Ontario/Canada
    Posts
    2,619
    Install each package with dpkg

    http://mirrors.kernel.org/ubuntu/poo...buntu2_all.deb
    http://mirrors.kernel.org/ubuntu/poo..._1.1-5_all.deb
    http://mirrors.kernel.org/ubuntu/poo...ntu12_i386.deb

    Try installing those:
    Code:
    sudo dpkg -i *.deb
    I'm not sure how well that will work but this way should allow you to install the packages apart from apt.

    Bryan
    Looking for a distro? Look here.
    "There can be no doubt that all our knowledge begins with experience." - Immanuel Kant (Critique of Pure Reason)
    Queen's University - Arts and Science 2008 (Sociology)
    Registered Linux User #386147.

  11. #10
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    It seems you have a Dapper system here, trying to install some Edgy packages, without doing an upgrade to Edgy first. You are bound to experience some difficulties. Perhaps you should make up your mind : either you install Dapper packages on Dapper or Edgy packages on Edgy, but not Edgy on Dapper.

    Upgrade your system ? Or use the Dapper CD ?
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •