Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 18 of 18
jeffrey@jeffrey-computer:/usr/lib$ ls | grep -i libgl FGL.renamed.libGL.so.1.2 libglade libglade-2.0.so.0 libglade-2.0.so.0.0.7 libglib-1.2.so.0 libglib-1.2.so.0.0.10 libglib-2.0.so.0 libglib-2.0.so.0.1200.4 libGL.so libGLU.so.1 libGLU.so.1.3.060501 libglut.so.3 libglut.so.3.8.0 jeffrey@jeffrey-computer:/usr/lib$...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Newbie
    Join Date
    Dec 2005
    Posts
    187

    jeffrey@jeffrey-computer:/usr/lib$ ls | grep -i libgl
    FGL.renamed.libGL.so.1.2
    libglade
    libglade-2.0.so.0
    libglade-2.0.so.0.0.7
    libglib-1.2.so.0
    libglib-1.2.so.0.0.10
    libglib-2.0.so.0
    libglib-2.0.so.0.1200.4
    libGL.so
    libGLU.so.1
    libGLU.so.1.3.060501
    libglut.so.3
    libglut.so.3.8.0
    jeffrey@jeffrey-computer:/usr/lib$

  2. #12
    Linux Guru Juan Pablo's Avatar
    Join Date
    Mar 2006
    Location
    /home/south_america/ecuador/quito
    Posts
    2,064
    First: Try a upgrade, if it doesn't fix the problem

    do this

    sudo ln -s /usr/lib/libGL.so /usr/lib/libGL.so.1
    Put your hand in an oven for a minute and it will be like an hour, sit beside a beautiful woman for an hour and it will be like a minute, that is relativity. --Albert Einstein
    Linux User #425940

    Don't PM me with questions, instead post in the forums

  3. #13
    Linux Newbie
    Join Date
    Dec 2005
    Posts
    187
    Now I get this error with stepmania.

    ./stepmania: error while loading shared libraries: libGL.so.1: cannot open shared object file: Error 40

    And this one with xmms

    libGL.so.1: cannot open shared object file: Too many levels of symbolic links
    Message: device: default

  4. #14
    Linux Guru Juan Pablo's Avatar
    Join Date
    Mar 2006
    Location
    /home/south_america/ecuador/quito
    Posts
    2,064
    Did you try the update first?
    Put your hand in an oven for a minute and it will be like an hour, sit beside a beautiful woman for an hour and it will be like a minute, that is relativity. --Albert Einstein
    Linux User #425940

    Don't PM me with questions, instead post in the forums

  5. #15
    Linux Newbie
    Join Date
    Dec 2005
    Posts
    187
    I did sudo apt-get update. Is that what I was supposed to type? In doing that, it said that there was nothing to update.

    Edit: Also sudo apt-get upgrade

    Not sure if that's the right command, but that's what I did.

  6. #16
    Linux Newbie
    Join Date
    Dec 2005
    Posts
    187
    Alright, well I went to my other computer and transferred libGL.so.1 to this computer. I can now run Amarok and XMMS with no errors. But Stepmania now gives this error:

    Initializing OpenGL...
    SetVideoMode failed: Couldn't find matching GLX visual


    How can I set up OpenGL? I thought I got OpenGL for my video card. An ATI All-In-Wonder 2006 Edition AGP

  7. #17
    Linux Guru bryansmith's Avatar
    Join Date
    Nov 2004
    Location
    /Ontario/Canada
    Posts
    2,619
    Did you install the ATI drivers?

    Bryan
    Looking for a distro? Look here.
    "There can be no doubt that all our knowledge begins with experience." - Immanuel Kant (Critique of Pure Reason)
    Queen's University - Arts and Science 2008 (Sociology)
    Registered Linux User #386147.

  8. #18
    Linux Newbie
    Join Date
    Dec 2005
    Posts
    187
    ./ati-installer.sh: 176: Syntax error: Bad substitution
    Removing temporary directory: fglrx-install

    That is the error I always get when trying to run the .run file from the ATI website. So then I got that fglrx driver. And in the Monitor And Display settings under hardware it says Graphics Card: ATI Radeon (fglrx) Driver: ATI. I'm actually running an All-In-Wonder 2006 edition. The problem is when I switch to that card, it messes up like in a previous entry I asked about. Basically, the application would start, everything but the mouse would freeze, I would press CTRL+ALT+F1 to go to the command line and then CTRL+ALT+F7 to get out and it would be fine only to do it again.

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •