Find the answer to your Linux question:
Results 1 to 3 of 3
Hi While trying to install packages on kubuntu using the adept package manager, I have found that it is being opened in read only mode, so I cannot do anything. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2006
    Posts
    7

    Question Adept is in read only mode


    Hi

    While trying to install packages on kubuntu using the adept package manager, I have found that it is being opened in read only mode, so I cannot do anything. It says to close any apt based programs which I thought I had done, but I still cannot do any installations

    Can anyone help?

    Dave

  2. #2
    Just Joined!
    Join Date
    Nov 2006
    Posts
    7
    Hi

    I tried to carry out this task from the command line using apt-get, code shown below:

    Code:
    droseman@droseman-desktop:/var/cache/apt/archives$ cd /etc
    droseman@droseman-desktop:/etc$ sudo apt-get install mozilla-thunderbird
    E: Could not get lock /var/lib/dpkg/lock - open (11 Resource temporarily unavailable)
    E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?
    droseman@droseman-desktop:/etc$ sudo apt-get install mozilla-thunderbird
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following extra packages will be installed:
      j2re1.4
    Suggested packages:
      mozilla-browser mozilla-firefox galeon mozilla-thunderbird-typeaheadfind mozilla-thunderbird-inspector
      mozilla-thunderbird-enigmail
    Recommended packages:
      gsfonts-x11
    The following NEW packages will be installed:
      mozilla-thunderbird
    The following packages will be upgraded:
      j2re1.4
    1 upgraded, 1 newly installed, 0 to remove and 18 not upgraded.
    1 not fully installed or removed.
    Need to get 10.7MB/33.3MB of archives.
    After unpacking 90.6MB of additional disk space will be used.
    Do you want to continue [Y/n]? y
    Get:1 http://security.ubuntu.com edgy-security/main mozilla-thunderbird 1.5.0.8-0ubuntu0.6.10 [10.7MB]
    Fetched 10.7MB in 45s (239kB/s)
    debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process
    (Reading database ...
    dpkg: serious warning: files list file for package `j2re1.4' missing, assuming package has no files currently installed.
    81676 files and directories currently installed.)
    Preparing to replace j2re1.4 1.4.2.02-1ubuntu3 (using .../j2re1.4_1.4.2.02-1ubuntu3_i386.deb) ...
    debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process
    dpkg: error processing /var/cache/apt/archives/j2re1.4_1.4.2.02-1ubuntu3_i386.deb (--unpack):
     subprocess pre-installation script returned error exit status 1
    Selecting previously deselected package mozilla-thunderbird.
    Unpacking mozilla-thunderbird (from .../mozilla-thunderbird_1.5.0.8-0ubuntu0.6.10_i386.deb) ...
    Errors were encountered while processing:
     /var/cache/apt/archives/j2re1.4_1.4.2.02-1ubuntu3_i386.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    tia
    Dave

  3. #3
    Just Joined!
    Join Date
    Nov 2006
    Posts
    7

    Now fixed

    Ok, silly mistake. Once I found the extra processes, it worked fine.

    Cheers

    Dave

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •