Find the answer to your Linux question:
Results 1 to 5 of 5
My Firefox 2 is extremely unstable and constantly crashes. I am running the default Firefox 2 install from Ubuntu 6.10. Anyone else having this problem, or know a fix?...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User ImNeat's Avatar
    Join Date
    Feb 2006
    Location
    N. America
    Posts
    392

    Unstable Firefox 2


    My Firefox 2 is extremely unstable and constantly crashes. I am running the default Firefox 2 install from Ubuntu 6.10. Anyone else having this problem, or know a fix?
    10" Sony Vaio SRX99P 850MHz P3-M 256MB RAM 20GB HD : ArchLinux
    14" Dell Inspiron 1420N 2GHz Core2Duo 2GB RAM 160GB HD : Xubuntu

  2. #2
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Perhaps you could try to delete your preferences and see if it helps :
    Code:
    rm -r ~/.mozilla/firefox
    Of course, backup your bookmarks first, because you'll loose all your settings.
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  3. #3
    Linux Guru bryansmith's Avatar
    Join Date
    Nov 2004
    Location
    /Ontario/Canada
    Posts
    2,619
    There is a problem with the firefox 2 build in edgy and flash. Anytime you visit a webpage with flash installed (version 7 from the repos), the browser will crash. The way to fix this is to change you defaultdepth in xorg.conf to 24 (in your screen section towards the bottom).

    I don't know if this is causing your problem but it affected many, including myself.

    Bryan
    Looking for a distro? Look here.
    "There can be no doubt that all our knowledge begins with experience." - Immanuel Kant (Critique of Pure Reason)
    Queen's University - Arts and Science 2008 (Sociology)
    Registered Linux User #386147.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux User ImNeat's Avatar
    Join Date
    Feb 2006
    Location
    N. America
    Posts
    392
    Yea I've been doing quite a bit of googling and it seems that flash is most likely the problem. Unfortunately disabling flash isn't even fixing it for many. I downgraded my flash to version 6 from 7, we'll see if that does anything.

    My default depth is already 24,
    Code:
    Section "Screen"
            Identifier      "Default Screen"
            Device          "ATI Technologies, Inc. R423 UK [Radeon X800SE (PCIE)]"
            Monitor         "DELL E172FP"
            DefaultDepth    24
    maybe mine needs to be changed to something else?
    10" Sony Vaio SRX99P 850MHz P3-M 256MB RAM 20GB HD : ArchLinux
    14" Dell Inspiron 1420N 2GHz Core2Duo 2GB RAM 160GB HD : Xubuntu

  6. #5
    Just Joined!
    Join Date
    May 2006
    Posts
    20
    Firefox 2.0 was a major disappointment for me. I plan on installing opra or something else because it is SO FREAKING SLOW for me. A google search takes like 30 seconds. I don't pay for my cable connection so I can wait for pages to load at dialup speed. I know its just 2.0 because 1.5.7 on my windows install works just fine.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •