Find the answer to your Linux question:
Results 1 to 9 of 9
Hi, I'm a Linux noob... and I was here a few months back about helping me mount my SATA hard drive because the Windows that was on it messed up. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2006
    Posts
    13

    Need to mount USB Flash Drive


    Hi, I'm a Linux noob... and I was here a few months back about helping me mount my SATA hard drive because the Windows that was on it messed up.
    Well, now it physically messed up (hardware), so I'm going to have to scrap this install of Ubuntu to switch to Windows, because there's some important stuff I have to do.
    But I want to save as many files as I can. For that I'm going to use my flash drive.
    I plug it in, and try to access it, but it gives me the error:
    mount: only root can mount /dev/sda1 on /media/first
    So, using my limited knowledge, I switched over to root with "su". Now I'm stuck. The error message tells me that it's dev/sda1... however, sda1 was the location of the hard drive that broke. It's not connected to the computer anymore, maybe it has nothing to do with it.
    So, I basically need to mount this flash drive..
    thanks for any help.

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    use 'sudo' to gain root privileges.
    Code:
    sudo mount  -t  <filesystem>    /dev/sda1  /media/first
    do you have SATA Harddisk? in that case, usb drive will be sdb and mount sdb1.
    check the output of 'sudo fdisk -l'.






    casper
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Linux User
    Join Date
    Aug 2005
    Posts
    408
    If you use this command, you need to make sure that you already created a directory called /media/first as root, and that you specify the filesystem. If it's a standard usb flash drive, then it's mostly likely vfat, so I would put that in:

    Code:
    sudo mount  -t vfat /dev/sda1  /media/first

  4. #4
    Just Joined!
    Join Date
    Oct 2006
    Posts
    13
    Thanks for that, I mounted it, but now I can't seem to write to it. It's telling me that I do not have permission to write to the folder. However, all the read/write/execute options are greyed out, I can't change them.
    I used eraker's code... First I mounted it as my user, didn't work, so I unmounted it and mounted it as root again, but no success..
    EDIT: @Casper: no, my current drive is IDE. My SATA drive is the one that's kinda broken now and it's unplugged.

  5. #5
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    mount USB as root and execute this
    Code:
    gksu nautilus &






    casper
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  6. #6
    Just Joined!
    Join Date
    Oct 2006
    Posts
    13
    Ok, I go in as root, mount the drive, can see what's inside, then use your code Casper, and I get:
    (nautilus:10231): GnomeUI-WARNING **: While connecting to session manager:
    Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authenticaion failed
    edit: ha, i feel so stupid right now... it's a flash drive, and it's causing me grave problems -_-

  7. #7
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    hmmm ! try this 'sudo nautilus'.







    casper
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  8. #8
    Just Joined!
    Join Date
    Oct 2006
    Posts
    13
    Same error as last time...

  9. #9
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    its a BUG. check here for more details. reboot machine and execute 'sudo nautilus' again.






    casper
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •