Find the answer to your Linux question:
Results 1 to 9 of 9
hi everyone, i am a new linux user, having just swapped from m******** and could not be happier with the change. its all so smooth in comparison! however, i have ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2006
    Posts
    12

    editing sudoers with ubuntu 6.10


    hi everyone,

    i am a new linux user, having just swapped from m******** and could not be happier with the change. its all so smooth in comparison!

    however, i have recently installed firestarter as a firewall and wish for it to load automatically when i log in. the faq on the firestarter website says:

    Q: How can I get Firestarter to load automatically when I log in as a regular user?
    Firestarter running in the system tray

    Normally when you start Firestarter by clicking an icon or manually from a terminal, the system will prompt you for your root user's password. However, this is a bit of a hassle, especially if you want to run Firestarter all the time when logged in. In that case Firestarter can be loaded in the background when you log in with your regular user, without asking a password and minimized to the system tray (pictured right).
    Giving the user permission to launch Firestarter without the root password

    In order for a regular user to be able to launch Firestarter, the user must be given additional privileges. Edit your /etc/sudoers file in your favorite text editor and add the following line at the end:
    username ALL= NOPASSWD: /usr/bin/firestarter

    Note: Debian users should replace /usr/bin/firestarter with /usr/sbin/firestarter in the above line.

    Simply replace username with whatever your login is. The specified user is now able to launch Firestarter without being prompted for a password using the command sudo firestarter.

    A note on the security aspects: This method makes a trade off in local security for convenience. If your user account becomes compromised the attacker will be able to control the firewall. However this method is preferable to having a shared root user password in a multiuser setting. It is also preferable if the alternative is not to run Firestarter at all.
    Launching Firestarter minimized to the tray on login

    Having performed the above configuration of permissions, the system can further be set up to load Firestarter when you log in with your regular user account. Firestarter will in that case load directly into the system tray without user intervention, after which the main interface can be accessed by clicking the tray icon.

    Using GNOME:
    The GNOME sessions manager

    Open up your GNOME menu, select Preferences followed by Sessions. Switch to the Startup programs tab, pictured right.

    Click Add and enter
    sudo firestarter --start-hidden
    as the startup command. Click OK and you're done.

    To stop Firestarter from loading on login, simply remove its entry from the startup programs listing.



    but my problem starts when trying to edit the sudoers file contained in /etc/
    please could someone explain to me how to edit this file.

    thanks!

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Quote Originally Posted by polemarchus
    but my problem starts when trying to edit the sudoers file contained in /etc/
    what error message does it through?

    edit 'sudoer' file with 'visudo'.
    Code:
    sudo visudo -f /etc/sudoers




    casper
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined!
    Join Date
    Dec 2006
    Posts
    12
    yes, got it, thanks!

    was getting confused with the visudo input!

    all groovy now, many thanks again!

    bye

  4. #4
    Just Joined!
    Join Date
    Dec 2006
    Posts
    12
    hey,

    am unfortunately still a little confused...

    i have installed firestarter and it works fine, however, i still cannot get it to start on boot. i have added the line:

    Joe ALL=NOPASSWD: /usr/sbin/firestarter

    to /etc/sudoers

    Joe being my username.

    I have also added the line:

    sudo firestarter –start-hidden

    to the start-up option under system/preferences/sessions

    however it still doesn't appear active when i boot my system. i am running ubuntu 6.10 and all seems fine apart from this minor thing.

    its driving me mad! please help, thanks

  5. #5
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Quote Originally Posted by polemarchus
    i have installed firestarter and it works fine, however, i still cannot get it to start on boot. i have added the line:

    Joe ALL=NOPASSWD: /usr/sbin/firestarter

    to /etc/sudoers

    Joe being my username.
    Post the content of /etc/sudoers to make sure everything is alright in there.

    Quote Originally Posted by polemarchus
    I have also added the line:

    sudo firestarter –start-hidden

    to the start-up option under system/preferences/sessions

    however it still doesn't appear active when i boot my system. i am running ubuntu 6.10 and all seems fine apart from this minor thing.
    Unless I am mystaking, the command should be
    Code:
    sudo firestarter --start-hidden
    so with two - before start.

    Try it from the terminal and see if it works.
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  6. #6
    Just Joined!
    Join Date
    Dec 2006
    Posts
    12
    contents of sudoers:

    # /etc/sudoers
    #
    # This file MUST be edited with the 'visudo' command as root.
    #
    # See the man page for details on how to write a sudoers file.
    # Host alias specification

    # User alias specification

    # Cmnd alias specification

    # Defaults

    Defaults !lecture,tty_tickets,!fqdn

    # User privilege specification
    root ALL=(ALL) ALL

    # Members of the admin group may gain root privileges
    %admin ALL=(ALL) ALL

    Joe ALL=NOPASSWD: /usr/sbin/firestarter

    thanks!

  7. #7
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    To avoid confusion, just replace

    Quote Originally Posted by polemarchus
    Joe ALL=NOPASSWD: /usr/sbin/firestarter
    with
    Code:
    %admin ALL=NOPASSWD: /usr/sbin/firestarter
    Nevertheless it should work with "Joe" if "Joe" is your exact username (case sensitive).

    You must of course log out and log in for the changes to take effect.

    Then try again.

    If it doesn't work, make sure you test
    Code:
    sudo firestarter --start-hidden
    in the terminal.

    More here :
    http://www.fs-security.com/docs/faq.php#trayicon
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  8. #8
    Just Joined!
    Join Date
    Dec 2006
    Posts
    12
    Code:
    sudo firestarter --start-hidden
    works fine in console, just will not boot.

    the above command is in Sessions

    thanks

  9. #9
    Linux Guru Vergil83's Avatar
    Join Date
    Mar 2004
    Posts
    2,407
    just a slight aside. You don't need to have the firestarter gui running for the firewall to be running
    http://www.fs-security.com/docs/persistence.php
    Brilliant Mediocrity - Making Failure Look Good

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •