Find the answer to your Linux question:
Results 1 to 2 of 2
I have this weird issue with pure-ftpd. If I login with already created users, things are fine. If I create new users, that's where it messes up. This is how ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2006
    Posts
    43

    Exclamation pure-ftpd - 530 Login authentication failed - new users failing only


    I have this weird issue with pure-ftpd. If I login with already created users, things are fine. If I create new users, that's where it messes up. This is how I create the new users:

    Code:
    pure-pw useradd backups -u ftpuser -d /data/backups/Personal/
    pure-pw mkdb
    Of course, I make sure the "home directory" is already there. The "ftpuser" is a valid user w/ a valid shell. I have set other users up this way because and have had no issues.

    Here's my syslog output:

    Code:
    Dec 12 04:50:39 tangerine pure-ftpd: (?@192.168.1.2) [INFO] New connection from 192.168.1.2
    Dec 12 04:50:39 tangerine pure-ftpd: (?@192.168.1.2) [INFO] drew is now logged in
    Dec 12 04:50:42 tangerine pure-ftpd: (drew@192.168.1.2) [INFO] Logout.
    Dec 12 04:50:48 tangerine pure-ftpd: (?@192.168.1.2) [INFO] New connection from 192.168.1.2
    Dec 12 04:50:49 tangerine pure-ftpd: (?@192.168.1.2) [WARNING] Authentication failed for user [backups]
    Dec 12 04:50:54 tangerine pure-ftpd: (?@192.168.1.2) [INFO] Logout.
    Any ideas?

  2. #2
    Just Joined!
    Join Date
    Jan 2006
    Posts
    43
    bump - any thoughts?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •