Find the answer to your Linux question:
Results 1 to 2 of 2
Hi, I have been having lots of problems with apt-get recently. Here is the error that I am receiving when I hover over the orange icon: A error occured, please ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2005
    Location
    Californ-i-a
    Posts
    9

    apt-get help!


    Hi,

    I have been having lots of problems with apt-get recently.

    Here is the error that I am receiving when I hover over the orange icon:

    A error occured, please run Package Manager from the right-click menu or apt-get on a terminal to see what is wrong. The error message was: 'Error: BrokenCount > 0'
    When I run 'sudo apt-get install -f' from the terminal, this is what I get:

    derek@ghost:~$ sudo apt-get -f install
    Reading package lists... Done
    Building dependency tree... Done
    Correcting dependencies... Done
    The following extra packages will be installed:
    samba
    Recommended packages:
    smbldap-tools
    The following packages will be upgraded:
    samba
    1 upgraded, 0 newly installed, 0 to remove and 6 not upgraded.
    Need to get 0B/2845kB of archives.
    After unpacking 0B of additional disk space will be used.
    Do you want to continue [Y/n]? Y
    Preconfiguring packages ...
    Selecting previously deselected package samba.
    (Reading database ... 159064 files and directories currently installed.)
    Preparing to replace samba 3.0.22-1ubuntu3.1 (using .../samba_3.0.22-1ubuntu3.2_i386.deb) ...
    invoke-rc.d: dangling symlink: /etc/rc2.d/S91samba
    dpkg: warning - old pre-removal script returned error exit status 102
    dpkg - trying script from the new package instead ...
    invoke-rc.d: dangling symlink: /etc/rc2.d/S91samba
    dpkg: error processing /var/cache/apt/archives/samba_3.0.22-1ubuntu3.2_i386.deb (--unpack):
    subprocess new pre-removal script returned error exit status 102
    Errors were encountered while processing:
    /var/cache/apt/archives/samba_3.0.22-1ubuntu3.2_i386.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    How do I fix this issue?

  2. #2
    Linux Guru bryansmith's Avatar
    Join Date
    Nov 2004
    Location
    /Ontario/Canada
    Posts
    2,619
    Try the solution here. Many people seemed to have had this problem and Sebata_Afrika seemed to have solved it.
    Looking for a distro? Look here.
    "There can be no doubt that all our knowledge begins with experience." - Immanuel Kant (Critique of Pure Reason)
    Queen's University - Arts and Science 2008 (Sociology)
    Registered Linux User #386147.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •