Find the answer to your Linux question:
Results 1 to 6 of 6
Hi ... whenever i startup or reboot my ubuntu system fsck always gets invoked causing my system to take ages to boot. Is there a reason why fsck starts? Is ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! vicagnews's Avatar
    Join Date
    Mar 2007
    Location
    san francisco
    Posts
    21

    Question Disabling fsck on startup


    Hi ... whenever i startup or reboot my ubuntu system fsck always gets invoked causing my system to take ages to boot. Is there a reason why fsck starts? Is there a way of disabling this??

    I have a dual boot system with XP and Ubuntu running on an AMD Turion64.

  2. #2
    Just Joined!
    Join Date
    Jun 2006
    Location
    The next brick house on the right.
    Posts
    63
    To my knowledge none of the *buntu distros (I'm running Kubuntu) run fsck on every boot. I do know that there is a parameter that I simply accepted as a default upon installation - it's like 100 boots or 100 days, something like that.

    The other possibility is that your Ubuntu is not shutting down properly, leaving bunged up journal entries, improperly closed files, thangs of that nature.

    In short, fsck is a good thing to have, but t shouldn't normally run a full check on every boot.

  3. #3
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Quote Originally Posted by vicagnews
    Hi ... whenever i startup or reboot my ubuntu system fsck always gets invoked causing my system to take ages to boot. Is there a reason why fsck starts? Is there a way of disabling this??
    Hi !

    is Ubuntu scanning all partitions or XP partition only?
    you can set fsck option in /etc/fstab file.
    Code:
    gksu gedit /etc/fstab
    last digit of every mouting line controls fsck. set value to 0 if want to disable fsck.

    Code:
    /dev/hda1  /media/window_c   vfat  defaults 0 0
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  4. #4
    Just Joined! vicagnews's Avatar
    Join Date
    Mar 2007
    Location
    san francisco
    Posts
    21

    fstab

    thanks for the reply casper and jglen ...

    to answer your question jglen: my ubuntu system always shuts down normally ... no error messages are displayed to the best of my knowledge.

    casper: here's what my fstab configuration looks like:

    Code:
    # /etc/fstab: static file system information.
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc            /proc           proc    defaults        0       0
    # /dev/hda6
    UUID=d4ab7f9f-e66a-4074-8d78-14e3adead8c7 /               ext3    defaults,errors=remount-ro 0       1
    # /dev/hda1
    UUID=3007-17F2  /media/hda1     vfat    defaults,utf8,umask=007,gid=46 0       1
    # /dev/hda2
    UUID=320D-180E  /media/hda2     vfat    defaults,utf8,umask=007,gid=46 0       1
    # /dev/hda5
    UUID=57e36415-9e7b-4543-bfce-dd69b3bcab74 none            swap    sw              0       0
    /dev/hdc        /media/cdrom0   udf,iso9660 user,noauto     0       0
    i guess it is scanning both the fat32 file-systems that i have on my system each of the time (hence the '1'?)

    ... so if I put '0' there instead ... it should stop doing that??

    thanks again!

  5. #5
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    your /etc/fstab file is a bit messy. it should be like this
    Code:
    proc            /proc           proc    defaults        0       0
    UUID=d4ab7f9f-e66a-4074-8d78-14e3adead8c7 / ext3 defaults,errors=remount-ro 0 1
    # /dev/hda1
    UUID=3007-17F2  /media/hda1     vfat    defaults,umask=0 0 0
    # /dev/hda2
    UUID=320D-180E  /media/hda2     vfat    defaults,umask=0 0 0
    # /dev/hda5
    UUID=57e36415-9e7b-4543-bfce-dd69b3bcab74 none     swap    sw  0  0
    /dev/hdc        /media/cdrom0   udf,iso9660 user,noauto     0       0
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  6. #6
    Just Joined! vicagnews's Avatar
    Join Date
    Mar 2007
    Location
    san francisco
    Posts
    21

    Thumbs up thanks!!

    thanks casper ... i just changed the last '1' to '0' in my fstab file and now there's no more slow booting (I didn't clean it up as you had suggested, though)!!

    thanks a lot for your advice!!!

    - Vic

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •