Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16

Thread: Grub Is Gone!

Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Grub Is Gone!


    I had to reinstall windows because I installed my video card drivers and it made windows crazy anyway, so I reinstalled windows and now GRUB is gone... How do I reinstall it?

  2. #2
    SuperMod (Back again) devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,777
    boot up from Ubuntu Live, open Terminal and execute this
    Code:
    sudo grub-install /dev/hda
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Will that put GRUB on my MBR or on my hard drive. Also I'm using a SATA drive so would I need to do /dev/sda?

  4. $spacer_open
    $spacer_close
  5. #4
    Linux User Oxygen's Avatar
    Join Date
    Jul 2004
    Location
    Hartlepool, England
    Posts
    392
    Yeah sudo grub-install /dev/sda
    Graham - You'd better Use Linux!

    I'm registerd Linux user #397030. What about you?

  6. #5
    SuperMod (Back again) devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,777
    Will that put GRUB on my MBR or on my hard drive
    grub-install /dev/sda command will install GRUB in MBR of harddisk and its best way to setup dual boot imho.
    if you are using Windows Boot Loader, install GRUB in the boot sector of / (root) or /boot partition.
    Code:
    grub-install /dev/sda<partition_number>
    i suggest you to install GRUB in MBR only.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  7. #6
    I tried typing that stuff in and I get this:

    ubuntu@ubuntu:~$ sudo grub-install /dev/sda
    Could not find device for /boot: Not found or not a block device.
    So I tried:

    ubuntu@ubuntu:~$ sudo grub-install /dev/sda1
    Could not find device for /boot: Not found or not a block device.
    And:
    ubuntu@ubuntu:~$ sudo grub-install /dev/sda2
    Could not find device for /boot: Not found or not a block device.
    What can I do to fix this?

    My hard drive is like this:

    /dev/sda1 -> 58.64 GB -> NTFS
    /dev/sda2 -> 124.00 GB -> ext3
    /dev/sda3 -> 2.89 GB -> extended
    /dev/sda5 -> 2.89 GB -> linux-swap

  8. #7
    SuperMod (Back again) devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,777
    thats strange. LiveCD should install GRUB.
    download SuperGRUB CD, burn .iso image to CD, boot from it and re-install GRUB.
    in case, SuperGRUB CD doesn't install GRUB, post the output of 'sudo fdisk -l' command here.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  9. #8
    Now I have GRUB installed but when I try to select Linux it says it cannot mount the selected partition. What do I do?

  10. #9
    SuperMod (Back again) devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,777
    post the exact error message here.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  11. #10
    The exact error is:
    Error 17: Cannot mount selected partition
    Press any key to continue
    So I press a key then it takes me back to GRUB and I have to choose Windows.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •