Find the answer to your Linux question:
Results 1 to 8 of 8
I am trying to get my usb headset to work with applications through wine. (Specifically Team Fortress 2). The headset is recognized, because I can listen to music, but it ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2007
    Posts
    26

    USB Headset problems


    I am trying to get my usb headset to work with applications through wine. (Specifically Team Fortress 2). The headset is recognized, because I can listen to music, but it does not seem to want (for lack of a better word) to work with wine. Also, it does not work with Firefox i.e. when I am watching a video online; the sound comes through my monitor, not the headset.

    Any/all help appreciated as always.

  2. #2
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    Not sure if this will help since I don't know which distro you are running nor which DE but I know when using Skype with USB headsets, I have to configure it through:
    Code:
    gnome-volume-control
    There is a place where you choose "device" and can configure accordingly. I hope this helps you...
    Linux Mint + IceWM Registered: #371367 New Members: click here

  3. #3
    Just Joined!
    Join Date
    Oct 2007
    Posts
    26
    Nope doesn't help; I already picked the USB device, and all the volumes are up.

    I am running Gutsy Gibbon btw.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Oct 2007
    Posts
    26
    Can anyone help me with this problem?


    Please?

  6. #5
    Just Joined!
    Join Date
    Mar 2004
    Posts
    17
    I just encountered the same problem with my new USB headset.

    Here is how you fix it:

    first figure out where your device is in under /dev by typing the following:

    ls /dev/dsp*

    You should see 2 or several. (1 if you only have one sound device)

    Next, if you did not know, you can output garbage directly into one of these dsp files, which will help you determine which file is associated with what audio device. Doing so will lead to distort, possible irritating sounds coming from an audio device. (assuming they are not muted, or turned off in the BIOS)

    Get a fairly large file, (doesn't have to be, but just so the sound is long enough for you to hear) and do the following:

    cat the_said_file >> /dev/dsp

    And if the sound comes out the wrong place, go to the next file

    cat the_said_file >> /dev/dsp1

    Once you managed to figure out what file it is, we do the following:

    AUDIODEV="/dev/the_dsp_you_want" winecfg

    In winecfg, go to the Audio tab, and you should see several drivers to choose from. We only care about ALSA and OSS. In one of the subcategories for both, there may or may not be a 'device' tree. If there is, expand it, and if it shows anything you recognize to be your headset, that may be the driver to use. If you don't see anything like this, don't worry. Just do the following:

    Check to see if ALSA outputs to the headset by checking ALSA's box, __AND__ unchecking the others. There should be a button to the right that says 'test'. If there is, click it and you should hear a beep or something.

    If that doesn't work, do the same for OSS, and click test.

    If there isn't a test (must be an older version of wine), just check off either OSS __OR__ ALSA, and test a windows application. If it doesn't output sound to the right device, go back to winecfg and check off another driver, while unchecking the others, then repeat the process. Like so

    (after checking one or the other driver in winecfg -> audio)
    AUDIODEV="/dev/your_dsp_file" wine some_program.exe

    Hope this isn't vague, if so, write back.

  7. #6
    Just Joined!
    Join Date
    Oct 2007
    Posts
    26
    Actually, I ended up uninstalling all my alsa drivers (if you want to call them that), then reinstalling, along with various tweaks along the way. There was a tutorial that I followed somewhere for an HP pavilion or something..but it worked for me.

    The problem was that my headset always was set to dsp1 instead of dsp (that may not have been the problem, but it is what i observed).

  8. #7
    Linux User Oxygen's Avatar
    Join Date
    Jul 2004
    Location
    Hartlepool, England
    Posts
    392
    You could use OSS drivers for wine, run winecfg and in Audio select OSS. It might work.
    Graham - You'd better Use Linux!

    I'm registerd Linux user #397030. What about you?

  9. #8
    Just Joined!
    Join Date
    Oct 2007
    Posts
    26
    Don't need to. As stated in my earlier post, it is working now.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •