Find the answer to your Linux question:
Results 1 to 9 of 9
currently I am confused! I successfully installed steam onto my gentoo linux box, but when I click on portal, or any of the other games on the orange box I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2005
    Posts
    2

    Exclamation steam runs, portal etc does not


    currently I am confused!

    I successfully installed steam onto my gentoo linux box, but when I click on portal, or any of the other games on the orange box I get the "video driver outdated" message, then nothing. doing a ps -ef shows that it's running...

    confusing.
    any help / suggestions would be helpful.

  2. #2
    Just Joined!
    Join Date
    Jan 2008
    Location
    PA, USA
    Posts
    6
    my games just initialize then close, also gentoo

  3. #3
    Just Joined!
    Join Date
    Jan 2008
    Location
    PA, USA
    Posts
    6
    still no answers?

    what, are linux folks too busy playing TCE?

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru coopstah13's Avatar
    Join Date
    Nov 2007
    Location
    NH, USA
    Posts
    3,149
    you probably haven't properly install the graphics drivers for your graphics card or aren't using them.

    Post output of
    Code:
    cat /etc/X11/xorg.conf | grep Driver
    lspci | grep VGA
    lsmod | grep nv

  6. #5
    Just Joined!
    Join Date
    Jan 2008
    Location
    PA, USA
    Posts
    6
    localhost steven # cat /etc/X11/xorg.conf | grep Driver
    Driver "synaptics"
    Driver "kbd"
    Driver "wacom"
    Driver "wacom"
    Driver "wacom"
    Driver "mouse"
    Driver "mouse"
    Driver "nvidia" # do not remove vesa
    localhost steven # lspci | grep VGA
    05:00.0 VGA compatible controller: nVidia Corporation G71 [GeForce 7900 GS] (rev a1)
    localhost steven # lsmod | grep nv
    nvidia 8896164 34
    i2c_core 28160 2 nvidia,i2c_nforce2

  7. #6
    Linux Guru coopstah13's Avatar
    Join Date
    Nov 2007
    Location
    NH, USA
    Posts
    3,149
    Code:
    glxinfo | grep direct
    post the output of this, or if your x server crashes, then you have a problem with the installation of the driver, what version of the driver are you using from nvidia?

  8. #7
    Just Joined!
    Join Date
    Jan 2008
    Location
    PA, USA
    Posts
    6
    it's the latest nvidia driver, my X doesn't crash

    I'm at work or I'd have posted the command

    rendering is on

    compiz fusion is working, with the rotating cube and other eye candy

    Steam games just crash.

    with or without friends

  9. #8
    Just Joined!
    Join Date
    Aug 2009
    Posts
    2

    Same for me...

    I'm also running Gentoo. All HL2 games will at 90% of Steam-sessions only initialize and close on launch, but in the about 10% of the cases they will run perfectly fine but at exit hl2.exe will end up defunct. When hl2.exe is defunct Steam won't exit before I kill it.

    Printout from Steam when running a bad session:
    lurq@blackship ~ $ env WINEPREFIX="/home/lurq/.wine" wine "C:\Program Files\Steam\Steam.exe"
    CellID: Fetching server list from CSDS. . .
    err:alsa:ALSA_CheckSetVolume Could not find 'PCM Playback Volume' element
    err:ntlm:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path.
    err:ntlm:SECUR32_initNTLMSP Usually, you can find it in the winbind package of your distribution.
    CellID: CSDS returned 168 servers.
    CellID: Connecting to 208.111.156.52:27031. . .
    CellID: Connect to 208.111.156.52:27031 took 152 MS
    CellID: Nothing beat our old best time of 0 MS
    0[1b3b60]: IMM32: InitKeyboardLayout, aKeyboardLayout=041d041d, sCodePage=1252, sIMEProperty=00090000
    0[1b3b60]: NPN Logging Active!
    0[1b3b60]: General Plugin Logging Active! (nsPluginHost::ctor)
    0[1b3b60]: NPP Logging Active!
    0[1b3b60]: nsPluginHost::ctor

    Launching Portal:
    err:ole:CoGetClassObject class {9a5ea990-3034-4d6f-9128-01f3c61022bc} not registered
    err:ole:CoGetClassObject no class object {9a5ea990-3034-4d6f-9128-01f3c61022bc} could be created for context 0x1
    err:seh:raise_exception Exception frame is not in stack limits => unable to dispatch exception.


    I'll save the printout next time I get a good session with Steam.

  10. #9
    Just Joined!
    Join Date
    Aug 2009
    Posts
    2

    Problem already solved, I was here too late :)

    Look at the "26% Bug Workaround" and "Games don't start with message "The registry was in use by another process" at the WineHQ

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •