Find the answer to your Linux question:
Results 1 to 5 of 5
Hi everyone! I am using OpenSuse 10.3 with desktop effect compiz-fusion and wine 0.9.57! I have installed counter strike 1.6 with wine and everything went fine. When i run the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie bobescalin2005's Avatar
    Join Date
    Oct 2005
    Posts
    167

    Unhappy [SOLVED] Conter Strike Problem!!!


    Hi everyone! I am using OpenSuse 10.3 with desktop effect compiz-fusion and wine 0.9.57! I have installed counter strike 1.6 with wine and everything went fine. When i run the game with no desktop effect works fine but when i run with desktop effects it doesn`t start and it tells me:
    Code:
    calin@DarkStar:~/.wine/drive_c/Program Files/Valve> wine hl.exe -game cstrike
    err:wgl:get_render_type_from_fbconfig Unknown render_type: 0
    err:wgl:get_render_type_from_fbconfig Unknown render_type: 0
    err:d3d:WineD3D_CreateFakeGLContext Can't find a suitable iPixelFormat
    err:d3d:InitAdapters Failed to get a gl context for default adapter
    fixme:dbghelp:dump_system_info fill in CPU vendorID and feature set
    calin@DarkStar:~/.wine/drive_c/Program Files/Valve>
    Have any one any ideea why it doesn`t work with desktop effect? sorry for my english!
    Cheers!
    Registered Linux user #471256
    http://counter.li.org
    Don`t give up so easy...
    calin

  2. #2
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    Are you running XGL or AIGLX? That is are you using an ATI card?

  3. #3
    Linux Newbie bobescalin2005's Avatar
    Join Date
    Oct 2005
    Posts
    167
    i am using xgl! And my video card is nvidia 7600GT! Thanks for the reply! Cheers!
    Registered Linux user #471256
    http://counter.li.org
    Don`t give up so easy...
    calin

  4. #4
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    Yeah by default SUSE uses (or did use) XGL. This is a nested X server and prevents direct rendering of 3D applications within it. There are ways to force your 3D application to run outside of it with some success but really it's better to disable XGL while running. If you can switch to AIGLX or the native nVidia method you should be able to run CS without any trouble.


    Check out this link and see how it works out for you.

    SuSE Linux Forums > Compiz-fusion On Suse 10.3 Nvidia Cards No Xgl

  5. #5
    Linux Newbie bobescalin2005's Avatar
    Join Date
    Oct 2005
    Posts
    167
    Thank you verry much!!! Now it works fine! That was the problem! It`s a bug from XGL!
    Cheers!
    Registered Linux user #471256
    http://counter.li.org
    Don`t give up so easy...
    calin

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •