Find the answer to your Linux question:
Results 1 to 4 of 4
hi all , I've prob here . when I try to install visual c++ (vcsetup.exe)in my opensuse 10.2 with wine It works and extract files and after a second it ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2008
    Location
    karnatak ,india
    Posts
    16

    cannot install apps


    hi all ,

    I've prob here .
    when I try to install visual c++ (vcsetup.exe)in my opensuse 10.2 with wine
    It works and extract files and after a second it says unable to extract or something (dont remember this line) please check your permissions .
    and sometimes for other apps it says:
    could not load "C:/windows/system32/<filename>/

    what is the prob ?
    pls help !!!!!
    I'm new to linux (reallllllly new) and cannot understand most of the terms used.

    THANKS

  2. #2
    Linux Newbie bobescalin2005's Avatar
    Join Date
    Oct 2005
    Posts
    167
    could not load "C:/windows/system32/<filename>/
    Try to install it on windows and copy that file to linux in wine...maybe will work
    Cheers!
    Registered Linux user #471256
    http://counter.li.org
    Don`t give up so easy...
    calin

  3. #3
    Linux Enthusiast KenJackson's Avatar
    Join Date
    Jun 2006
    Location
    Maryland, USA
    Posts
    510
    I'm probably getting the same error, so let me amplify.

    I downloaded Microsoft's free version of Visual C++, file vcsetup.exe.

    I ran wine vcsetup.exe. It started execution and popped up this box:

    Extracting Files
    Verifying File: vcsetup


    Almost immediately, it popped up this box, obscuring the first. All I could do was click OK and exit.

    Extraction Failed
    Unable to find a volume for file extraction.
    Please verify that you have proper permissions.


    I ran the Linux strace command (captured with script) and this line:
    open("/dev/hda", O_RDONLY|O_NONBLOCK|O_LARGEFILE) = -1 EACCES (Permission denied)

    Now why oh why would wine be trying to open /dev/hda??? I don't know. But that's the only line I could see that looked like a permission problem.

    This looks like a wine bug. I'll try to search the wine bugzilla database.

  4. #4
    Linux Enthusiast KenJackson's Avatar
    Join Date
    Jun 2006
    Location
    Maryland, USA
    Posts
    510
    Ah! This is bug 5351, which is caused by Microsoft's assumptions. It can be solved with the volnum command in the winetricks script. But I just used these equivalent commands:
    Code:
    cd ~/.wine
    ln -s drive_c harddiskvolume0
    cd dosdevices
    rm c:
    ln -s ../harddiskvolume0 c:
    That got me past the first problem. But then I ran into the next:
    Setup has encountered a problem while trying to copy: ...

    I haven't scoped that one yet.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •