Find the answer to your Linux question:
Results 1 to 4 of 4
Hi Today I tried to run some games with wine on my Asus Eee PC 900. Just really old games because the Eee is not made for gaming :P Started ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2008
    Posts
    24

    Wine has massive memory leaks?


    Hi
    Today I tried to run some games with wine on my Asus Eee PC 900. Just really old games because the Eee is not made for gaming :P
    Started some, most didn't work at all, I didn't even get a message "Wine has exited with status x - Done/Show Log/...".
    Some gave me this message, and 2 even worked (Battle Painter and Armagetron Advanced).

    Then the whole laptop was lagging, I started task manager and saw: 990Mb of 1000Mb used... Although nothing was running. Checked the task list, antivirus took 20Mb, this X11 250Mb, and all the other processes were below 1Mb, so nothing which should fill my whole giga byte...

    Is Window's Garbage Collector missing or what is the problem? I think it just didn't dispose all the textures and stuff...

  2. #2
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    Memopry management in Linux and indeed Unix in general is different to Windows. Windows struggles to free memory as if this improved performance whereas Unix-like systems use the resources available to them for running and caching information that may be useful later. Whether you have 128MB or 3GB of RAM, the target is ~95% usage. Why have something and not use it? RAM is a lot faster than paging, so don't worry about that.

    I'd imagine the reason you're choking is because you are weighing down X on a really light machine. It's most likely the X server that's having trouble as opposed to the whole system.

    Oh and for what it's worth, Armagetron is an open source OpenGL game and is available for Linux natively. That should save the messing with Wine.

  3. #3
    Just Joined!
    Join Date
    May 2008
    Posts
    24
    Ok, thank you for the information, I always want to learn more about linux. And thanks for the tip with the Linux version of Armagetron...

    So I don't have to worry when all my memory is used, when I start a new application, it will get memory somehow?

  4. #4
    Just Joined!
    Join Date
    May 2008
    Posts
    24
    And I can't run the Linux version of Armagetron =(

    Downloaded the Ubuntu one for my Xandros, this is what I get:

    Code:
    asus-1884754377:/home/user/My Documents/My Downloads> dpkg -i armagetron.deb
    Selecting previously deselected package armagetronad.
    (Reading database ... 72389 files and directories currently installed.)
    Unpacking armagetronad (from armagetron.deb) ...
    dpkg: dependency problems prevent configuration of armagetronad:
     armagetronad depends on libc6 (>= 2.5-0ubuntu1); however:
      Version of libc6 on system is 2.3.6.ds1-13etch5.
     armagetronad depends on libgcc1 (>= 1:4.1.2); however:
      Version of libgcc1 on system is 1:4.1.1-21.
     armagetronad depends on libstdc++6 (>= 4.1.2); however:
      Version of libstdc++6 on system is 4.1.1-21.
    dpkg: error processing armagetronad (--install):
     dependency problems - leaving unconfigured
    Errors were encountered while processing:
     armagetronad
    When I tried to update my libraries:

    Code:
    asus-1884754377:/home/user/My Documents/My Downloads> apt-get install libgcc1
    Reading package lists... Done
    Building dependency tree... Done
    libgcc1 is already the newest version.
    0 upgraded, 0 newly installed, 0 to remove and 187 not upgraded.
    What can I do?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •