Find the answer to your Linux question:
Results 1 to 6 of 6
Hello, i have installed Wine 1.0 on Ubuntu 8.04 using an onboard video card that came with my Asus motherboard and after installing a game called Carom3d which you can ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2008
    Posts
    6

    Unhappy Geforce 8600 GT 512MB + Wine 1.0 + Carom3d 5.01


    Hello, i have installed Wine 1.0 on Ubuntu 8.04 using an onboard video card that came with my Asus motherboard and after installing a game called Carom3d which you can find here Welcome to Carom3D. The best online billiards game ever! (FREE) it worked perfectly but a little slow! So i bought a new video card for playing better games and chose this Geforce! After installing the nvidea drivers and running glxgears i got these results:

    Code:
    neverstop@neverstop-desktop:~$ glxgears
    22986 frames in 5.0 seconds = 4597.163 FPS
    23063 frames in 5.0 seconds = 4612.461 FPS
    23125 frames in 5.0 seconds = 4624.843 FPS
    23148 frames in 5.0 seconds = 4629.441 FPS
    23121 frames in 5.0 seconds = 4624.019 FPS
    
    neverstop@neverstop-desktop:~$
    Is it right? I don't know if these FPS's are good for this video card.

    After installing all drivers i finally installed the game and for my surprise it didn't work!! I don't understand why it didn't work with this video card, i didn't do anything different at installation! I only copied one dll needed to run the game called mfc42.dll from my old Windows system to the system32 folder of wine and that's all. When i run the game from the linux shell it gives me no error =/ nothing happens...i am really lost...how can fix an issue if i don't know what to do? Please someone help me...i need a gods hand ...

    Here is my xorg.conf file if necessary:

    Code:
    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings:  version 1.0  (buildd@vernadsky)  Tue Mar  4 20:24:34 UTC 2008
    
    # xorg.conf (X.Org X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    
    Section "ServerLayout"
        Identifier     "Videocard0"
        Screen         0  "Screen0" 0 0
    EndSection
    
    Section "Module"
        Load           "dbe"
        SubSection "extmod"
        	Option     "omit xfree86-dga"
        EndSubSection
        Load           "extmod"
        Load           "glx"
        Load 	   "type1"
        Load	   "freetype"
        Load	   "speedo"
        Load	   "xtt"
        Load           "dri"
    EndSection
    
    Section "ServerFlags"
        Option         "Xinerama" "0"
    EndSection
    
    Section "InputDevice"
        Identifier     "Generic Keyboard"
        Driver         "kbd"
        Option         "XkbRules" "xorg"
        Option         "XkbModel" "abnt2"
        Option         "XkbLayout" "br"
    EndSection
    
    Section "InputDevice"
        Identifier     "Configured Mouse"
        Driver         "mouse"
        Option         "CorePointer"
    EndSection
    
    Section "Monitor"
        Identifier     "Configured Monitor"
    EndSection
    
    Section "Monitor"
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "LG L192WS"
        HorizSync       30.0 - 83.0
        VertRefresh     56.0 - 75.0
    EndSection
    
    Section "Device"
        Identifier     "Configured Video Device"
        Driver         "nvidia"
        Option         "NoLogo" "True"
    EndSection
    
    Section "Device"
        Identifier     "Videocard0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce 8600 GT"
    EndSection
    
    Section "Screen"
        Identifier     "Default Screen"
        Device         "Configured Video Device"
        Monitor        "Configured Monitor"
        DefaultDepth    24
    EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Videocard0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "TwinView" "0"
        Option         "TwinViewXineramaInfoOrder" "CRT-0"
        Option         "metamodes" "1440x900 +0+0; nvidia-auto-select +0+0"
    EndSection
    
    Section "dri"
      Mode 0666
    EndSection

  2. #2
    Linux Guru
    Join Date
    Nov 2007
    Location
    Córdoba (Spain)
    Posts
    1,513
    Quote Originally Posted by _neverstop View Post

    Is it right? I don't know if these FPS's are good for this video card.
    Yes. Glxgears is not really a benchmark, it's way too bound to the cpu, so, anything above some hundreds of fps means that the nvidia DRI is being used, which means the driver is working, which is the only real and interesting information that glxgears can give you.

    After installing all drivers i finally installed the game and for my surprise it didn't work!! I don't understand why it didn't work with this video card, i didn't do anything different at installation! I only copied one dll needed to run the game called mfc42.dll from my old Windows system to the system32 folder of wine and that's all. When i run the game from the linux shell it gives me no error =/ nothing happens...i am really lost...how can fix an issue if i don't know what to do? Please someone help me...i need a gods hand ...
    It's hard to tell if we don't even have an error to look at. If it crashes with no output something nasty must be happening.

    Here is my xorg.conf file if necessary:
    I will comment some bits, maybe something can help, I don't really know:

    Code:
    Section "Module"
    ...
        Load           "dri"
    ...
    This is not needed with nvidia, it has its own dri interface. However, it shouldn't be a problem either, but disable it just in case.

    Code:
    Section "Device"
        Identifier     "Configured Video Device"
        Driver         "nvidia"
        Option         "NoLogo" "True"
    
    EndSection
    If you are using a compositing manager (compiz, kwin with effects enabled, e16 or any other) you need to add one option, otherwise you can't use GLX while the composite manager is on:

    Code:
    Option "AllowGLXWithComposite" "true"
    The rest seems ok. However, if you can, post the output of this command, just to check that dri is effectively in place:

    Code:
    $ glxinfo | grep -n3 direct
    Luck

  3. #3
    Just Joined!
    Join Date
    Jul 2008
    Posts
    6
    Thanks for replying my question! Well i have already done what you asked me for...but still not working, i think nothing has changed...everything seems to be as before, here is my new xorg.conf file:

    Code:
    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings:  version 1.0  (buildd@vernadsky)  Tue Mar  4 20:24:34 UTC 2008
    
    # xorg.conf (X.Org X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    
    Section "ServerLayout"
        Identifier     "Videocard0"
        Screen         0  "Screen0" 0 0
    EndSection
    
    Section "Module"
        Load           "dri"
    EndSection
    
    Section "ServerFlags"
        Option         "Xinerama" "0"
    EndSection
    
    Section "InputDevice"
        Identifier     "Generic Keyboard"
        Driver         "kbd"
        Option         "XkbRules" "xorg"
        Option         "XkbModel" "abnt2"
        Option         "XkbLayout" "br"
    EndSection
    
    Section "InputDevice"
        Identifier     "Configured Mouse"
        Driver         "mouse"
        Option         "CorePointer"
    EndSection
    
    Section "Monitor"
        Identifier     "Configured Monitor"
    EndSection
    
    Section "Monitor"
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "LG L192WS"
        HorizSync       30.0 - 83.0
        VertRefresh     56.0 - 75.0
    EndSection
    
    Section "Device"
        Identifier     "Videocard0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce 8600 GT"
    EndSection
    
    Section "Screen"
        Identifier     "Default Screen"
        Device         "Configured Video Device"
        Monitor        "Configured Monitor"
        DefaultDepth    24
    EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Videocard0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "TwinView" "0"
        Option         "TwinViewXineramaInfoOrder" "CRT-0"
        Option         "metamodes" "1440x900 +0+0; nvidia-auto-select +0+0"
        Option         "AllowGLXWithComposite" "true"
    EndSection
    
    Section "dri"
      Mode 0666
    EndSection
    An here is the output of the glxinfo command:

    Code:
    1-name of display: :0.0
    2-display: :0  screen: 0
    3:direct rendering: Yes
    4-server glx vendor string: NVIDIA Corporation
    5-server glx version string: 1.4
    6-server glx extensions:
    Maybe it is just a problem on Wine? I am playing Quake 3 Arena without problems using a resolution of 1024x768 with 32 bits of color. A funny thing happens when i run wine using the root user, it gives me this output:

    Code:
    root@neverstop-desktop:/home/neverstop/.wine/drive_c/Program Files/Neoact/Carom3D# wine carom.exe
    Application tried to create a window, but no driver could be loaded.
    Make sure that your X server is running and that $DISPLAY is set correctly.
    Application tried to create a window, but no driver could be loaded.
    Make sure that your X server is running and that $DISPLAY is set correctly.
    err:ole:apartment_createwindowifneeded CreateWindow failed with error 0
    fixme:wgl:wglGetProcAddress  :stub
    fixme:wgl:wglGetProcAddress  :stub
    fixme:wgl:wglGetProcAddress  :stub
    fixme:wgl:wglGetProcAddress  :stub
    fixme:wgl:wglGetProcAddress  :stub
    fixme:wgl:wglGetProcAddress  :stub
    fixme:wgl:wglGetProcAddress  :stub
    err:d3d:WineD3D_CreateFakeGLContext HWND creation failed!
    err:d3d:InitAdapters Failed to get a gl context for default adapter
    root@neverstop-desktop:/home/neverstop/.wine/drive_c/Program Files/Neoact/Carom3D#
    I read on the internet that this is normal when running using root, but i still don't understand why wine hangs running with my user.

  4. #4
    Linux Guru
    Join Date
    Nov 2007
    Location
    Córdoba (Spain)
    Posts
    1,513
    Quote Originally Posted by _neverstop View Post
    Thanks for replying my question! Well i have already done what you asked me for...but still not working, i think nothing has changed...everything seems to be as before,
    Yep. Sad to hear that, but I expected it. We had to try anyway.

    Your configuration seems correct and glxinfo is also right. Wine should work out of the box unless the package maintainer for wine on your distro is doing something strange.

    Maybe it is just a problem on Wine? I am playing Quake 3 Arena without problems using a resolution of 1024x768 with 32 bits of color.
    The strange part is that you say it worked before. And it works with quake3... One thing that just slipped into my brain: I have heard some horror stories about the 8xxx series being a bit fuzzy at times, maybe due to driver issues. I can't tell you personally since I am still on the 6xxx agp era but maybe some additional googleing can give you some insights on specific issues with geforce 8xxx cards and the linux drivers.


    About the issues with the root user, as you say it's something tipical. There are lots of issues when running wine as a different use than the one that owns the X session. Sometimes running "xhost +" helps. But anyway, I never advise to run wine as root. In fact, I always suggest to create a separate user just for wine. That way, if you run into some tipical problem associated to the nature of Windows programs (viruses, trojans, and the like) it will at most affect only the files on the home of the user who's running wine.

    PS: You can always try to use a debug build (you probably have to compile it yourself) and try to get a backtrace on gdb or valgrind, so you can see where it's dying, and hopefully, get an idea of why does it die as well.

  5. #5
    Just Joined!
    Join Date
    Jul 2008
    Posts
    6
    And it works with quake3...
    Just to make sure you understood, Quake 3 runs fine not using Wine, i have installed it using a .run file. So i think nothing is wrong with my video card drivers or its configuration since this game is running...

    Some years ago i tried to run Wine over another nvidia card, a Geforce 2 MX 440 and i had the SAME PROBLEM. Isn't that a coincidence? I remember that i tested wine on an onboard video card (not this intel, another one) and it worked!! That's weird...really...maybe it is the high resolution of my screen? I am running at 1440x900 pixels of resolution as you can see...(widescreen)

    It can be only a stupid configuration...or something like this...should i debug the game using winedbg? I tried to use it but i am not an expert programmer only a learner...so i don't think this will help somehow =/.

    Thanks anyway...i am still trying running carom3d over wine, if i solve the problem i will post the solution here...

  6. #6
    Linux Guru
    Join Date
    Nov 2007
    Location
    Córdoba (Spain)
    Posts
    1,513
    Quote Originally Posted by _neverstop View Post
    Just to make sure you understood, Quake 3 runs fine not using Wine, i have installed it using a .run file. So i think nothing is wrong with my video card drivers or its configuration since this game is running...
    I thought you were using wine on that one as well. We are shooting in the dark here. It's very difficult to know if the problem is about opengl or graphics drivers, or lies somewhere else, as there's no error message nor any other thing. We can only guess.

    Some years ago i tried to run Wine over another nvidia card, a Geforce 2 MX 440 and i had the SAME PROBLEM. Isn't that a coincidence? I remember that i tested wine on an onboard video card (not this intel, another one) and it worked!! That's weird...really...maybe it is the high resolution of my screen? I am running at 1440x900 pixels of resolution as you can see...(widescreen)
    I am using xinerama in 2624x1200 pixels across two screens, wine usually runs into one screen on 1600x1200 without a problem. I don't think that resolution is a problem since most graphics cards nowadays like to ship lots of ram, even if they are never going to use it (that's why a good video card with 256mb is better than a bad one with 512, unlike most people seem to think).

    It can be only a stupid configuration...or something like this...should i debug the game using winedbg? I tried to use it but i am not an expert programmer only a learner...so i don't think this will help somehow =/.
    I have some debugging capabilities but I have never used the wine specific debugger. And I don't know if plain gdm will help with wine stuff. You can always try, but as I said on the other post, maybe the wine mailing lists would be better for such specific kind of support. I am sure that people around there is much more knowledgeable than I am and can surely assist you better on finding a solution. To tell the truth, I have never encountered a case like this, where the output of the command would be absolutely nothing.

    In any case, I hope you can find a working solution, in one or another way.

    Luck on your quest

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •