Find the answer to your Linux question:
Results 1 to 3 of 3
Hi, I am on Debian 4.0 stable. I was originally using wine 1.1.1, which worked reasonably well for me, but decided to update because of one specific issue. 1.1.1 was ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2008
    Posts
    2

    [SOLVED] wine upgrade - missing alsa


    Hi,
    I am on Debian 4.0 stable. I was originally using wine 1.1.1, which worked reasonably well for me, but decided to update because of one specific issue. 1.1.1 was the last version I found built for Debian, so as I wanted to use the latest version available I downloaded 1.1.3 source and compiled it according to instruction in the included readme file.
    It works fine with the exception of ALSA. I normally use ALSA for everything and did so succesfully even with wine 1.1.1, but in this latest version when I click on the Sound tab in winecfg I get the message that ALSA is present in registry, but isn't installed (and that's nonsense). It also asks me whether I want to remove this entry from registry -if I say NO, nothing happens and it asks me again later, if I say YES it cleans the registry entry so I am left with OSS and that doesn't work for me (I have never needed to install/config OSS before). How do I get ALSA back? I think there is some way to rebuild wine registry if that would help...(I suppose this could have something to do with an old registry file left by the previous version of wine that didn't unistall properly, though I naturally removed the 1.1.1 version before installing 1.1.3)
    Of course, if nothing else helps I could probably run it with OSS somehow, but it could prove to be a little difficult as I use fairly rare sound card Terratec 5.1 Sky flashed to Audiotrak Prodigy 7.1...
    Thanks for any suggestions.

  2. #2
    Linux Guru
    Join Date
    Nov 2007
    Location
    Córdoba (Spain)
    Posts
    1,513
    You might be missing alsa-libs, alsa-devel or whatever the sources for alsa are called in debian. When doing the ./configure stage it will tell you if alsa is or not detected.

  3. #3
    Just Joined!
    Join Date
    Aug 2008
    Posts
    2
    thanks, I thought about it too, but according to the readme the newer Wine versions have all the libs and plugins intergrated into the main program.

    It seems that I didn't purge the config files when unistalling the 1.1.1. I did a complete reinstall half an hour ago, including purge, and everything works properly now.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •