Find the answer to your Linux question:
Results 1 to 5 of 5
Hello, I am new here and hope that you would help me if there is another thread about my problem, I am sorry that I opened it twice. my english ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2008
    Posts
    3

    Problem with OpenGL in Wine with WOW


    Hello,
    I am new here and hope that you would help me if there is another thread about my problem, I am sorry that I opened it twice. my english is not the best but i will try to explain my problem

    so

    I have managed it to bring WoW going on my Linux Ubuntu (the newest version).

    But I have a problem.. The Direct X .. my WoW is verrry sloow... laags..
    I tried to change the config.wtf to start WoW in OpenGL mode

    SET gxApi "opengl"
    SET gxColorBits "24"
    SET gxDepthBits "24"
    SET gxResolution "1280x1024"

    but now I see only BLACK SCREEN with input boxes.

    I already tried to add
    SET M2UseShaders "0"
    to config.wtf but nothing happens


    so.. here some informations about my pc and the config.wtf of wow

    Athlon 2x 4000+
    512 DDRAM
    ATI X1650 PRO 256mb

    Config.wtf ---
    __________________________-
    SET hwDetect "0"
    SET gxColorBits "24"
    SET gxDepthBits "24"
    SET gxResolution "1280x1024"
    SET gxMultisampleQuality "0.000000"
    SET fullAlpha "1"
    SET lodDist "100.000000"
    SET SmallCull "0.040000"
    SET DistCull "500.000000"
    SET trilinear "1"
    SET frillDensity "32"
    SET farclip "477"
    SET specular "1"
    SET pixelShaders "1"
    SET particleDensity "1.000000"
    SET unitDrawDist "300.000000"
    SET movie "0"
    SET readTOS "1"
    SET readEULA "1"
    SET realmList "wow.bigfammily.de"
    SET Gamma "0.700000"
    SET MusicVolume "0.40000000596046"
    SET SoundVolume "1"
    SET MasterVolume "1"
    SET cameraPitchMoveSpeed "90"
    SET cameraYawMoveSpeed "180"
    SET cameraPitchSmoothSpeed "45"
    SET cameraYawSmoothSpeed "180"
    SET cameraSmoothStyle "0"
    SET cameraSmoothTrackingStyle "0"
    SET cameraDistanceMaxFactor "1.5"
    SET AmbienceVolume "0.60000002384186"
    SET minimapInsideZoom "0"
    SET UnitNameNPC "1"
    SET scriptMemory "102400"
    SET gameTip "14"
    SET profanityFilter "0"
    SET uiScale "0.63999998569489"
    SET readScanning "1"
    SET anisotropic "4"
    SET useUiScale "1"
    SET minimapZoom "0"
    SET alphaLevel "0"
    SET cameraBobbing "1"
    SET DesktopGamma "1"
    SET checkAddonVersion "0"
    SET mouseSpeed "1.5"
    SET weatherDensity "3"
    SET locale "deDE"
    SET spamFilter "0"
    SET assistAttack "1"
    SET deselectOnClick "0"
    SET stopAutoAttackOnTargetChange "1"
    SET ShowTargetCastbar "1"
    SET ShowVKeyCastbar "1"
    SET UnitNamePlayer "0"
    SET autoSelfCast "1"
    SET guildMemberNotify "1"
    SET ChatBubbles "0"
    SET coresDetected "2"
    SET videoOptionsVersion "1"
    SET expansionMovie "0"
    SET showToolsUI "1"
    SET Sound_OutputDriverName "System Default"
    SET spellEffectLevel "6"
    SET gxRefresh "60"
    SET gxFixLag "0"
    SET groundEffectDensity "24"
    SET readTerminationWithoutNotice "1"
    SET Sound_VoiceChatInputDriverName "System Default"
    SET Sound_VoiceChatOutputDriverName "System Default"
    SET showPartyDebuffs "0"
    SET realmName "BigFammily"
    SET autoLootCorpse "1"
    SET questFadingDisable "1"
    SET groundEffectDist "70"
    SET accountName "X"
    __________________________________________________

    thank you for your help

  2. #2
    Linux Enthusiast L4Linux's Avatar
    Join Date
    Sep 2008
    Location
    Greece
    Posts
    583
    Sometimes, 3D applications and games have problems if you have Compiz-Fusion enabled.
    Try running WoW with Compiz disabled. Go to System->Preferences->Appearance. Then go to visual effects tab and select none.
    If this works you can install compiz-fusion icon that makes an icon appear on the top right of the screen and lets you turn compiz on/off.
    To install it, type in terminal:
    Code:
    sudo apt-get install fusion-icon

  3. #3
    Just Joined!
    Join Date
    Oct 2008
    Posts
    3
    hey
    thanks for so quick answer..
    but i know this problem this compiz..
    it is disabled.. sorry that i didnt say it..

    i hope you will find my problem

  4. #4
    Linux Guru coopstah13's Avatar
    Join Date
    Nov 2007
    Location
    NH, USA
    Posts
    3,149
    do you have the proprietary ati drivers installed?

  5. #5
    Just Joined!
    Join Date
    Oct 2008
    Posts
    3
    hey
    i ve installed the driver, that was installed from linux..
    i also have catalyst center....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •