Find the answer to your Linux question:
Results 1 to 3 of 3
Hello everybody, i'm running archlinux with kernel 2.6.27 on my machine using a Ati X1800GTO graphicscard and latest fglrx drivers. If i want to start a game, like Starcraft for ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! flux_wildly's Avatar
    Join Date
    Oct 2008
    Location
    Freiburg, Germany
    Posts
    2

    Enormous graphic problems using Wine 1.1.6


    Hello everybody,
    i'm running archlinux with kernel 2.6.27 on my machine using a Ati X1800GTO graphicscard and latest fglrx drivers.
    If i want to start a game, like Starcraft for example, the picture seems to be crimped to half of the screen (the other half stays black) and as a result weird, tiny squares appear, containing that, what is meant to be the game...
    i can't tell, whether this is really an issue with wine or not. it also might be a configuration problem in my xorg.conf or a "simple" compatibility-failure with my graphicscard. i just don't know !
    but i was wondering, if anybody has/had the same problem and/or can maybe help me fixing it
    wine prompts the following by starting the game from console:
    Code:
    [jay@cogitoergosum Starcraft]$ wine Starcraft.exe
    fixme:advapi:SetSecurityInfo stub
    fixme:win:EnumDisplayDevicesW ((null),0,0x32f420,0x00000000), stub!
    fixme:d3d:test_pbo_functionality >>>>>>>>>>>>>>>>> GL_INVALID_OPERATION (0x502) from Loading the PBO test texture
     @ directx.c / 3794
    fixme:xrandr:X11DRV_XRandR_SetCurrentMode Cannot change screen BPP from 32 to 8
    fixme:dsalsa:IDsDriverBufferImpl_SetVolumePan (0x13bc20,0x13cac0): stub
    My xorg.conf can be found at
    xorg.conf - nopaste.com (beta)

    Here's some more information:
    It's the same with SuSE 11.0 32/64bit and latest wine/ati-drivers, self-compiled wine-version 1.1.6 and other games like UnrealTournament '99. I also tried different driver versions...
    The game looks quite normal, when i'm starting X with vesa.
    Ah, and i forgot to mention, that native 3D-apliccations run smoothly and without the described picture-error - i'm not an expert, but it might have something to do with DirectX..??

    Greetings!

  2. #2
    Linux Newbie sdimhoff's Avatar
    Join Date
    Jan 2007
    Posts
    191
    I'm not positive about this one, but as an option you could try using an emulated desktop. Starcraft should have a set of resolutions for which it works well. Your desktop however may be at a better resolution (or I've run into problems like that with wide screens).

    1024x768 should be a reasonable resolution, so go into winecfg (graphics tab) and start it with an emulated desktop.

    The other thing you should check out is the color depth. Sometimes there can be big graphics differences when you switch between 24bpp to 16. I've found that some games would only run if my whole X was in 16. (You would change it in your xorg.conf file under the screen settings)

    Good luck.
    Linux since: 2001
    Gentoo since: 2004
    - - - - - - - -
    Translation:
    I fix things until they break.

  3. #3
    Just Joined! flux_wildly's Avatar
    Join Date
    Oct 2008
    Location
    Freiburg, Germany
    Posts
    2
    First of all: Thanks for your reply

    I already tried starting the games via emulated desktop before - only to see the strange picture popping up twice (side-by-side)
    Now i added the colordepths and modes to my xorg.conf and set the default to "16".

    Code:
    Section "Screen"
    	Identifier "fujitsu+fglrx"
    	Device     "Ati X1800 GTO"
    	Monitor    "fujitsu"
    	DefaultDepth     16
    
    	Subsection "Display" 
            	Depth     8 
            	Modes     "1280x1024" "1024x768" "800x600" "640x480"
            	ViewPort  0 0 
        	EndSubsection 
        	
    	Subsection "Display" 
            	Depth     16 
            	Modes     "1280x1024" "1024x768" "800x600" "640x480"
            	ViewPort  0 0 
        	EndSubsection 
    	
    	SubSection "Display"
    		Depth     24
    		Modes     "1280x1024" "1024x768" "800x600" "640x480"
    		Viewport  0 0
    	EndSubSection
    EndSection
    And now look what happens:
    xorg.log - nopaste.com (beta)

    "Given depth (16) is not supported by fglrx driver"

    What the hell is that supposed to mean ???
    The driver cannot deal with a LOWER colordepth...

    Any other ideas ?

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •