Find the answer to your Linux question:
Results 1 to 8 of 8
I'm running a new install of SuSe 10 and downloaded wine from winehq.org It's installed but the app I am trying to install with wine requires the VC++2k5sp1 runtime (vcredist_x86.exe). ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2009
    Posts
    5

    New to linux and wine...having problems with winetricks


    I'm running a new install of SuSe 10 and downloaded wine from winehq.org

    It's installed but the app I am trying to install with wine requires the VC++2k5sp1 runtime (vcredist_x86.exe). Of course the installer for the runtime doesn't work in wine either. After searching a bit, I came across winetricks. unfortunately when trying to installe the vcrun2005sp1 (or anything else) using winetricks, I was getting a 'cannot find cmd.exe' error from wine.

    So, I copied over cmd.exe from my XP machine and ran it again. Now I'm getting...

    fixme:msvcrt:MSVCRT_setlocale :Codepage only locale not implemented returned empty string Files

    I get this whenever I try installing anything using winetricks

    I've been searching for quite a while and it seems every bit of documentation makes it sound like up to this point everything should "just work" which leads me to believe I've done something fundamentally wrong in my linux and/or wine setup.

    Can anyone help me get turned into the right direction? Unfortunately, I don't know enough about linux to know what questions I should be asking or what configurations to be verifying.

    TIA

  2. #2
    Linux Guru coopstah13's Avatar
    Join Date
    Nov 2007
    Location
    NH, USA
    Posts
    3,149
    What application are you trying to run? Look on the wine app database site and see if anyone else has tried to run it and what luck they've had. Your best option is to find a linux alternative to the application or use windows to run it in a dual-boot.

  3. #3
    Just Joined!
    Join Date
    Jan 2009
    Posts
    5
    Perhaps I didn't explain myself well enough.

    The app isn't going to be one found in the database but I know others have had success in the past. Unfortunately I have no information about how they did it (no info about what distro of linux or what version of wine or what they had to do to get it running. all I know is that they claim it was pretty easy to setup). I'm trying to get it working so I can create step by step instructions for others. I happen to be the developer of the app I'm trying to run.

    However at this point the app isn't important because it doesn't even come into play. I can't get winetricks to work at all.

    Ultimately, I need to get the visual c++ 2005 sp1 runtimes installed in wine. If you can offer an alternative to winetricks (I've also tried using the MS installer directly but it errored out as well) for that, I'm all ears.

  4. #4
    Just Joined! Loy Glenn's Avatar
    Join Date
    Sep 2008
    Location
    Houston,TX
    Posts
    89
    See if you can install Wine Doors. This may or may not help. I use Mandriva '08.1 and w/ Wine Doors have the ability to cleanly install "M.S. Visual C++ Runtime Libraries 6". Hope this helps - Loy.

  5. #5
    Just Joined!
    Join Date
    Jan 2009
    Posts
    5
    Update -

    I switched out to openSuse 11.1 which has wine 1.1.9 packaged with it (openSuse 10 only had wine 0.9).

    Under this setup, wine seems to run much better and I can use winetricks to install many of the tools it is made for. However, vcrun2005 and vcrun2005sp1 still do not install properly.

    So, here are the steps I used to recreate this:
    1) Install openSuse 11.1 (standard install, no extra configuration)
    2) Open Yast and install wine (default version included in openSuse 11.1 package)
    3) open a terminal and type "wget http://www.kegel.com/wine/winetricks"
    4) type "sh winetricks vcrun2005sp1"


    I get the following results (errors in red, my comments in blue):

    username@linux-xnh5:~> sh winetricks vcrun2005sp1
    Executing wine /home/username/.winetrickscache/vcrun2005sp1/vcredist_x86.exe
    fixme:advapi:DecryptFileA "C:\\windows\\temp\IXP000.TMP\\" 00000000
    ALSA lib seq_hw.c:457:(snd_seq_hw_open) open /dev/snd/seq failed: No suck file or directory

    This first error pops up before a "Licence agreement" box. when you click ok, you get the next error
    fixme:advapi:DecryptFileA "C:\\windows\\temp\IXP001.TMP\\" 00000000
    ALSA lib seq_hw.c:457:(snd_seq_hw_open) open /dev/snd/seq failed: No suck file or directory

    and then the first installation box pops up (doesn't require user interaction from this point). After that, you get another error
    fixme:advapi:LookupAccountNameW (null) L"username" (nil) 0x33f81c (nil) 0x33f820 0x33f814 - stub
    and then another installation box comes up. After that last install box goes away, you get the following errors:
    fixme:advapi:LookupAccountNameW (null) L"username" 0x1536b0 0x33f81c 0x130148 0x33f820 0x33f814 - stub
    fixme:msi:ACTION_HandleStandardAction unhandled standard action L"SetODBCFolders"
    fixme:msi:msi_unimplemented_action_stub RemoveExistingProducts -> 1 ignored L"Upgrade" table values
    fixme:msi:msi_unimplemented_action_stub MsiUnpublishAssemblies -> 10 ignored L"MsiAssembly" table values
    fixme:mscoree:LoadLibraryShim (0x7ee204ac L"fusion.dll", (nil), (nil), 0x33f934): semi-stub

    Install of vcrun2005sp1 done
    winetricks done.


    Of course, my initial reaction was to simply ignore the errors and just try executing an app that depends upon the runtime.


    username@linux-xnh5:~> wine diagnostics.exe
    fixme:actctx:parse_depend_manifests Could not find dependent assembly L"Microsoft.VC80.CRT"
    err:module:import_dll Library MFC80.DLL (which is needed by L"C:\\Program Files\AppName\\diagnostics.exe") not found
    err:module:import_dll Library MSVCR80.dll (which is needed by L"C:\\Program Files\AppName\\diagnostics.exe") not found
    err:module:import_dll Library MSVCP80.dll (which is needed by L"C:\\Program Files\AppName\\diagnostics.exe") not found
    err:module:LdrInitializeThunk Main exe initialization for L"C:\Program Files\\AppName\\diagnostics.exe" fialed, status c0000135


    So basicly, the app couldn't find the VC++2005sp1 runtimes (indicating they failed to install properly)

    So here I am, back almost at the same issue again. However, this time I'm more confident in my setup than before (since stuff that is supposed to "just work" actually does). I just need to get this figured out so I can move on.

    Any ideas on where to procede from here in getting these runtimes installed?

    BTW (I'll take a look at winedoors but I have a feeling I will get the same results since the vc6 runtimes install fine with winetricks as well).

  6. #6
    Just Joined!
    Join Date
    Jan 2009
    Posts
    5
    another update -

    I tried simply copying the files over from a windows box but it didn't help (I wasn't expecting it to) because of the way the VCRT does versioning now (the new dll hell).

    Also, I'm not finding a way to install wine-doors on openSuse 11
    The wine-doors site doesn't have an rpm for openSuse (I didn't try the ones for other distros) and the openSuse wine wiki indicates it should be in the standard wine repository but it isn't listed when I add the repository to Yast

  7. #7
    Just Joined! Loy Glenn's Avatar
    Join Date
    Sep 2008
    Location
    Houston,TX
    Posts
    89
    Go here
    Wine-doors Downloads
    to get the compressed src. Check the dependencies (listed further down the page). If you still have trouble, the only thing I can suggest is the following two links -

    WineHQ - Winelib

    WineHQ - Getting Help

    wish I could help more, Loy.

  8. #8
    Just Joined!
    Join Date
    Jan 2009
    Posts
    5
    Thanks for your help.

    I searched through that but was unable to find a download location for several of the dependancies (like python for example, I thought for sure there would be something for python)...

    I went back to coopstah's suggestion (now that I have an "app" that doesn't work) and looked up the redist in the wine appdb. Unfortunately not much help there but someone reported getting it to work in fedora.

    so, rather than mess with this for now, I'm gonna see if it works better in fedora and I'll come back to suse later if necessary...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •