Mmmm I will try a later version. I downloaded this version via Ubuntu the other day. Must be well out of date.