Find the answer to your Linux question:
Page 1 of 4 1 2 3 4 LastLast
Results 1 to 10 of 36
Hi Ever since the new patch, I've been having strange graphic problems. This happens usually when I fly around, it'll start small and soon it covers the whole screen. The ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2009
    Posts
    29

    WoW gfx problems


    Hi

    Ever since the new patch, I've been having strange graphic problems. This happens usually when I fly around, it'll start small and soon it covers the whole screen. The problem is the screen fills up with unicolor polygons. Here is a screenshot.

    h t t p://img219.imageshack.us/img219/214/glitch.jpg (take off the spaces off http, couldn't post the link since I'm a new user....)

    Any help would be greatly appreciated.

    Thanks

  2. #2
    Linux Engineer b2bwild's Avatar
    Join Date
    Jul 2008
    Location
    Behind You!
    Posts
    1,108
    Are you running compiz in background?
    You are using OpenGL or DirectX
    Do you have any library overrirdes?
    Never make any misteaks.

    Read my Blog at --> Penguin Inside Subscribe Feed

  3. #3
    Just Joined!
    Join Date
    Apr 2009
    Posts
    29
    I am using Compiz in the background. Do you think that could be it?

    I am using OpenGL.

    I am not sure what you mean by library overrides.


    Thanks for the help, I will try to disable Compiz, see if that does anything.

  4. $spacer_open
    $spacer_close
  5. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Have you installed correct Graphics Driver?
    Which Driver are you using for Graphics Card in xorg.conf file?
    Code:
    sudo lspci | grep -i vga
    grep -i driver /etc/X11/xorg.conf
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  6. #5
    Just Joined!
    Join Date
    Apr 2009
    Posts
    29
    joelcormier@ubuntu:~$ sudo lspci | grep -i vga
    01:00.0 VGA compatible controller: nVidia Corporation GeForce 8800 GT (rev a2)

    joelcormier@ubuntu:~$ grep -i driver /etc/X11/xorg.conf
    Driver "nvidia"


    The driver installed, I installed it automatically though ubuntu. In the driver window, says:

    NVIDIA Accelerated graphics driver (version 180)
    Licence: proprietary

  7. #6
    Just Joined!
    Join Date
    Apr 2009
    Posts
    29
    ok so it's not compiz, uninstalled it, and problem is still there

  8. #7
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Re-install Nvidia driver.
    Execute this
    Code:
    sudo apt-get install envyng
    sudo envyng
    Remove and re-install Nvidia driver through envyng.
    Code:
    sudo envyng
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  9. #8
    Linux Engineer b2bwild's Avatar
    Join Date
    Jul 2008
    Location
    Behind You!
    Posts
    1,108
    in your Wine registry.
    check for
    HKEY_CURRENT_USER > Software > Wine > Direct3D > set String OffscreenRenderingMode = backbuffer
    UseGLSL = enabled

    for more reference check here UsefulRegistryKeys - The Official Wine Wiki
    Never make any misteaks.

    Read my Blog at --> Penguin Inside Subscribe Feed

  10. #9
    Just Joined!
    Join Date
    Apr 2009
    Posts
    29
    Thanks again for the responses. I am having problems with both solutions.

    Here's the error that I'm getting by the way. Usually the screen goes into those polygons then crashes.


    The instruction at "0x7E126AE0" referenced memory at "0x765096B0".
    The memory could not be "read".



    Quote Originally Posted by devils casper View Post
    Re-install Nvidia driver.
    Execute this
    Code:
    sudo apt-get install envyng
    sudo envyng
    Remove and re-install Nvidia driver through envyng.
    Code:
    sudo envyng
    joelcormier@ubuntu:~$ sudo apt-get install envyng
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Couldn't find package envyngurl=

    I'm confused by the line E: Couldn't find package envyng. My E: drive is not a drive that I use a lot. It is not my main drive.


    I also tried downloading envyng from their website. The file that I downloaded opens Package installer but the "install package" button is greyed out, and I can't click it. Can I open the file that I downloaded in a terminal? If so what would be the command to run it? I tried just going to the download folder (in a terminal) and typing envyng-core_1.1.1ubuntu10_all.deb, but it's obviously not working.



    Quote Originally Posted by b2bwild View Post
    in your Wine registry.
    check for
    HKEY_CURRENT_USER > Software > Wine > Direct3D > set String OffscreenRenderingMode = backbuffer
    UseGLSL = enabled
    ]

    This did not do anything different, I still crashed after trying this.

  11. #10
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    Location
    Texas
    Posts
    9,496
    Quote Originally Posted by leojreimroc View Post
    joelcormier@ubuntu:~$ sudo apt-get install envyng
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Couldn't find package envyngurl=

    I'm confused by the line E: Couldn't find package envyng. My E: drive is not a drive that I use a lot. It is not my main drive.
    The E: you see there isn't actually a drive letter. Linux doesn't use drive letters like Microsoft Windows. The E stands for "error." Drives in Linux are given designations like /dev/sda, /dev/hdb, and /dev/cdrom.


    I also tried downloading envyng from their website. The file that I downloaded opens Package installer but the "install package" button is greyed out, and I can't click it. Can I open the file that I downloaded in a terminal? If so what would be the command to run it? I tried just going to the download folder (in a terminal) and typing envyng-core_1.1.1ubuntu10_all.deb, but it's obviously not working.
    I would respectfully disagree with casper and recommend that you NOT install the Envy driver. It has caused myself and others a number of problems in the past. However, for future reference you can install .DEB files using this command in Ubuntu or other Debian-based distributions (replacing "nameOfYourDebPackage" with the actual file name):

    Code:
    sudo dpkg -i nameOfYourDebPackage.deb
    Registered Linux user #270181
    TechieMoe's Tech Rants

Page 1 of 4 1 2 3 4 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •