Find the answer to your Linux question:
Results 1 to 6 of 6
Okay, I'm completely new to this site and forum. First of all, I'd like to thank any and everyone who has some good advice to offer. Without community support like ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2009
    Posts
    1

    Exclamation WINE sound is fine, Linux-based prog has no sound when WINE uses audio


    Okay, I'm completely new to this site and forum. First of all, I'd like to thank any and everyone who has some good advice to offer. Without community support like this, we'd all be trapped under the thumbs of MicroSloth and MacInTrash.

    First, my issue (as briefly as I can make it):

    In Ubuntu 9.04, I'm running WINE (latest version, though I'm booted into XP right now so I can't just look for sure) for the sole purpose of running Ventrilo's client for gaming. I play Wolfenstein Enemy Territory religiously, and am getting started learning Linux so as to (obviously) get rid of Windows completely. Once I'm comfortable enough, that'll happen. Right now, though, I have what is, for me, a BIG sound issue. While running Ventrilo on Ubuntu via WINE, everything seems to work fine. But when I minimize (or not) and fire up Enemy Territory, I have no sound in ET. When I close ET, close Ventrilo, and reload ET, THEN I have sound. I'm clueless, because all I know about troubleshooting this is based on Windows. With this wonderful new world of Linux, I'm kinda lost. I've found threads all over the net about "no sound in ET", but none of them seem to deal with the variable of running a program under WINE which requires the audio drivers. I'm left to assume at this point that WINE is bogarting the audio resources and somehow my Linux-based ET game can't use them. I'm starting to think that I should just install the Windows version of ET and run it under WINE as well, but that seems like a spiteful way to get what I want. I'd really like to understand the conflict here and learn something about how to legitimately resolve it. Anyone ever run into this before?

    System specs:

    AthlonXP 2600+ running at 2300MHz
    Asus A7N-8X-E (rev. 2) mainboard with nForce2 chipset
    1.5gB PC3200 DDR in dual-channel running at 200MHz
    40gig master/160gig slave HDs
    384k down/1meg up VerizonDSL connection (via cat5)
    old PNY geForce FX 5200 (128mb, 8X AGP) but does what I need just fine

    WinXPsp3/Ubuntu 9.04 dual boot


    I'm drawing blanks trying to think of what other pertinent info I can post, but I think that'll do it. Once again, thanks in advance for any help on this.


  2. #2
    Linux Guru coopstah13's Avatar
    Join Date
    Nov 2007
    Location
    NH, USA
    Posts
    3,149
    I've seen something like this before, back when I used to play wow, I could only have sound in either wow or ventrilo but not both at the same time. Its because the application using alsa basically blocks all the other output. What you should try is enabling the virtual desktop, that might share it better, I've never tried it.

  3. #3
    Linux Newbie sarlacii's Avatar
    Join Date
    May 2005
    Location
    South Africa
    Posts
    110
    Hi all. Yip, I've had a similar issue with Quake way back. The application that uses the sound card basically takes control of it. Sharing doesn't work, so if you fire up something else, it will complain of not being able to access the sound device.
    (BTW, the solution for Quake was to give everyone access to the sound device via chmod 666 /dev/dsp or similar... but in your case it is a wine resource sharing issue).
    Respectfully... Sarlac II
    ~~
    The moving clock K' appears to K to run slow by the factor (1-v^2/c^2)^(1/2).
    This is the phenomenon of time dilation.
    The faster you run, the younger you look, to everyone but yourself.

  4. #4
    Just Joined!
    Join Date
    Jan 2010
    Posts
    5
    yes, i think that's normally like this in linux, at least on my system. if one program uses the sound output it is blocked for others. so for example if you pause your music player to watch some video online then it won't have sound because the music player still occupies the output. you have to stop your music player or even close it. the other way around the same, if you have watched something online you have to close your browser or at least leave the video page to be able to listen to some music.
    this can get quite annoying and i didn't find a simple solution yet. but it is possible as i remember from windows.
    maybe it would be possible with jack. i play around with it these days. it could be possible to choose jack as your output device in your system and in wine but i'm not sure...

  5. #5
    Linux Enthusiast scathefire's Avatar
    Join Date
    Jan 2010
    Location
    Western Kentucky
    Posts
    626
    I used to play WoW through wine and stream music via Firefox. It sounds like something is not quite set up correctly for you in wine. You might want to tweak the Audio portion in wine (from running winecfg).

    On my Suse box I had something ignorant like plasma running and it was killing the sound sharing between applications. I uninstalled it and magically everything started working.

  6. #6
    Linux User benjamin20's Avatar
    Join Date
    Oct 2004
    Location
    jacksonville beach FL
    Posts
    317
    sound in linux has changed dramatically over the last 5 or so years.

    basically, for a long time all unix's used oss, then oss became retarded and so linux switched to alsa

    alsa was cool but still didnt fix this problem of the sound driver simply being just that, a sound driver, it just allows a program to send data to a peice of ahrdware, some hardware supports hardware sound mixing for a set number of inputs. most dont, so if a program uses alsa(or oss even) directly it blocks all otehr imput assuming its your standard run of the mill one input hardware.

    gnome and enlightenment came up with ESD and kde came up with arts, both are sound dameons. in summary, a program sends data to arts oe esd, they mix it with other sound, then send it to hardware. this requires software to recognize arts or esd though.

    a lot of people looked at these desktop environment based solutions and thought "uh, dumb" since it requires those specific desktops, people using another desktop environment or not using a de at all had no options, so alsa came up with dmix, which became a standard part of alsa.

    dmix is alsa's sound mixer, the way it works is usualy with alsa you have this configuration file and it has all the sound devices listed with some properties, then you have a default device that points to the main sound hardware an software would look at the default part and send sound to it(well, alsa sets up devices in /dev according to the configuration file and thats what software talks too). now with dmix, you have the default device point to dmix and that will output to a sound device (all according to the configuration file)

    well, technically dmix is kinda the wrong way to do it. software shouldn't talk directly to the hardware, it should use an intermediate library thats common across all unix's, it shouldn't be the drivers responsibility to do sound mixing. so now we got PulseAudio. really nice little soundmixing setup, it allows a lot more than sound mixing too.(it has a lot of plugins to emulate other sound mixers or even the alsa and oss drivers to trick software that doesn't directly support pulseaudio to work with it.

    so as you can see, this problem is intertwined with a whole mess of crap thats basically based on either nobody writing the software to do it or nobody taking the time to do it correctly (well, with dmix it wasnt so bad, we could have accepted it, but pulseaudio said they could stream the sound to other pulseadio servers[basically means send the sound to another computer to be played there] and that was tool cool to pass up, oh, and it made supporting non linux os's easier for software developers too) but hopefully it should all be settled down now since gnome has ported their programs over to pulseaudio and many other programs have added support for pulse as well.

    oh, but now kde as usual decided to go a completely different route than everyone else and made up Phonon in order to replace arts. hopefully that wont make anymore of a mess than it deserves.

    in answer to your problem, ubuntu started supporting pulseaudio i believe with 9.04. unfortunately, conocial kinda sucks at doing things right when it comes to configuring things so they didnt set up pulseaudio right.

    your problem might be related to this misconfiguration. it may just be an issue wine has. if i were you id make shure both et and wine were pointing to the default device in alsa OR to pulseaudio preferably if it is supported. then that default alsa needs to point to pulseaudio, then pulseaudio needs to send it to the alsa hardware device.

    if it were me id try whatever fedora edition is out now, as they probably have pulseaudio setup right. even a straight debian might be better off (i like debian, they are usually pretty good at getting things right)

    otherwise id look at making shure all these things are configured properly.
    nVidia G-Force 6600GT (bfg) pci-e: amd 64 2000+ (939): 1024 corsair ram: 2X 80gb seagate harddisk SATA: plextor cd/dvd-read/write cdrom SATA

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •