Find the answer to your Linux question:
Results 1 to 6 of 6
I've been trying my hardest to migrate from WinXP to a linux distro this week. While getting some distros installed wasn't a real problem (as in not harder than expected ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2006
    Location
    Wilson, NC
    Posts
    4

    Distro of choice for WoW


    I've been trying my hardest to migrate from WinXP to a linux distro this week. While getting some distros installed wasn't a real problem (as in not harder than expected **cough**Gentoo**cough**), I have not been able to get Wine to run World of Warcraft at anything approaching 'playable'.

    Distros tried (issue experienced)
    Gentoo 10 amd64 (wine not displaying login screen for WoW)
    KUbuntu 9.10 64bit (bootup locks on ACPI) -- will try again though
    Fedora 12 64bit (bypassed ACPI, better looking login screen for WoW, but no graphical background, unable to interact with login field or buttons)
    Fedora 12 32bit (same as above. tried switching to NVidia's proprietary driver via EasyLife, but desktop became completely unusable)

    So what I think I'm looking for is:

    • Binary distro - I'm tired of source compiles
    • Proprietary NVidia driver - or at least easy to switch to
    • CVS wine build

    I know this can be done in just about any distro (there are even binary versions of Gentoo), but is there any distro that is aimed at running Windows-based games? I have a long but broken history with Linux use (since Redhat 5.x), and I'm willing to try just about any distro at this point.

  2. #2
    Linux Enthusiast minthaka's Avatar
    Join Date
    May 2006
    Location
    Mol, Vojvodina
    Posts
    556
    Read this:
    World of Warcraft functionality on Wine - WoWWiki - Your guide to the World of Warcraft
    and
    WineHQ - World of Warcraft 3.2.x
    I think you'll need a pretty strong graphical card for playing anything.

    Anyway, moving to the Linux is a good opportunity for you to get rid of this dangerous game.
    If you need a CD/DVD catalogizer, give a try to my program:
    http://www.kde-apps.org/content/show...content=100682
    Linux Usert#430188

  3. #3
    Just Joined!
    Join Date
    May 2006
    Location
    Wilson, NC
    Posts
    4
    Update:
    It works. After a round with Linux Mint 8 which seemed to take ages to run anything in wine, I found ArchLinux. I installed their latest 32 bit system, and after what I am sure is the usual headache of Xorg on this distro (had to get the correct drivers installed), and a slight learning curve, everything started coming together.

    I'm running Wine 1.1.33 on an E17 desktop. WoW framerates are not up to par with what I got in WinXP, but there is some tweaking to do yet.

    Issues:
    1) Launcher.exe changes permissions on the WoW folder.

    • run Launcher.exe as normal. After it starts, but BEFORE pressing "Play", run:
    • sudo chmod 755 path/to/World\ of\ Warcraft
    • now you can play the game normally

    2) Low framerate.

    • I haven't fixed this yet, but:
    • run as few addons as you can
    • Google the registry tweak and apply it
    • ... ???

    We'll see how the rest of this goes over time.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru coopstah13's Avatar
    Join Date
    Nov 2007
    Location
    NH, USA
    Posts
    3,149
    are you using the opengl flag? this should greatly increase your framerate

  6. #5
    Just Joined!
    Join Date
    May 2006
    Location
    Wilson, NC
    Posts
    4
    I tried it in both
    Code:
    wine /path/to/wow/Launcher.exe
    and
    Code:
    wine /path/to/wow/Launcher.exe -opengl
    without much change in framerate. However reducing my addons helped incredibly. 4-5 fps in Dalaran became 24-36 fps (but server population dropped in that time too). More testing will follow in the coming days. Priority #1 is rebuilding my UI with fewer addons.

    The biggest problem and related solution for me has been getting the following sequence down:
    Code:
    $ wine /path/to/wow/Launcher.exe &
    $ chmod 755 /path/to/wow
    and THEN pressing the "Play" button on the Launcher. I haven't tried the registry tweak yet as it seems to be specifically for OpenGL, and I currently run the game almost exclusively in d3d mode.

  7. #6
    Linux Guru coopstah13's Avatar
    Join Date
    Nov 2007
    Location
    NH, USA
    Posts
    3,149
    you have to set opengl in config.wtf file, it is not a command line parameter

    set gxApi opengl, or something, i don't remember its been a long time

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •