Find the answer to your Linux question:
Results 1 to 3 of 3
Hi all! I am new here, and to the linux world. I have always looked upon it with a fond eye, but just now was forced to make the switch ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2010
    Posts
    1

    EVE Online


    Hi all!
    I am new here, and to the linux world. I have always looked upon it with a fond eye, but just now was forced to make the switch (damn you WPA!). So let's cut to the chase and get to my problem.

    I am using Linux Mint 8, and found that it already had Wine Doors as part of the packages I could download. I used this, installation went off without a hitch, started up fine and dandy, even logged in well. But, once I got in game, all the areas needed to be graphically rendered were simply left black. The menus and buttons looked and worked fine (albeit EXTREMELY SLOW), but the play area was just darkness. Oddly enough, icons that represented ships still showed up in this black area.

    I am using and ATI Radeon HD 4350

    Things I have done:
    -Gotten the proprietary drivers through the update system within LM 8. This fixed the speed issues with other linux games, making everything nice and smooth, but left EVE still useless.
    -Downloaded the most recent drivers off ATI's site for linux. Apparently these are for a different distro, because LM 8 had no idea what a ".run" file was.
    -Downloaded the most recent drivers for XP (worth a shot right?). While the installer appeared to work and everything was fine and dandy, EVE still remained black and scary.

    I am convinced this is a driver issue, as their is no problem loading or running the game (ok, maybe it is a little slow), but only graphically. An interesting note, when I open up the graphics options it says "HAL adapter" for my graphics adapter where on XP it used to say my video card (ati radeon hd 4350). Any insight or help is greatly greatly appreciated. Thanks!

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,664
    A lot of these windows games are built with DX9 or later Windows graphics libraries, some of which are not yet available to run under Wine, which is probably why your game isn't rendering some stuff. You might check on the WineHQ - Run Windows applications on Linux, BSD, Solaris and Mac OS X web site for more information, especially about games. They have a lot of work-arounds and/or patches that may help you out.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    Just Joined!
    Join Date
    Jun 2010
    Posts
    3
    As my suggestion, Mint should be able to use .run files, did you "sudo bash installer.run" or simply click it (that wont work on any distro ive tried xD)

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •