Find the answer to your Linux question:
Results 1 to 7 of 7
I have a laptop running Windows 7. I installed Oracle VM VirtualBox. I created a virtual machine and installed Fedora 13 on it. I then installed Wine 1.3.5-1. I saw ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Mar 2009
    Posts
    228

    Trouble installing IE on Wine


    I have a laptop running Windows 7. I installed Oracle VM VirtualBox. I created a virtual machine and installed Fedora 13 on it. I then installed Wine 1.3.5-1. I saw in another tread about installing winetricks but yum didnít find that package. I downloaded and tried to install ies4linux-2.99.0.1. When I ran the ies4linux script it gave the error message:

    IEs4Linux 2 is developed to be used with recent Wine versions (0.9.x). It seems that you are using an old version. It's recommended that you update your wine to the latest version (Go to: winehq.com).
    And the error message:

    Your wine does not have wineprefixcreate installed. Maybe you are running an old Wine version. Try to update it to the latest version.
    It doesnít recognize that the Wine version is 1.3.5.-1. It looks like the wineprefixcreate was removed from Wine. Does anyone know how to fix this or where I can get a version of IE that will install on Fedora. I canít seem to find one.

  2. #2
    Linux Guru coopstah13's Avatar
    Join Date
    Nov 2007
    Location
    NH, USA
    Posts
    3,149
    this seems like an awful lot of work to run IE when you're already running windows as your host OS...

    why do you need IE on fedora?

  3. #3
    Linux Newbie
    Join Date
    Mar 2009
    Posts
    228
    Thanks for the reply. I guess I should explain why Iím doing this. I just started volunteering at a non-profit organization. Iím going to help maintain their PCs that are donated to them. Some of them come with no OS on them so I was going to recommend installing CentOS on them since itís free. Havenít done that yet because I want to make sure I can get IE installed before making the recommendation. I know Mozilla Firefox is installed but some may be reluctant to use it. They definitely are not computer literate and may want to stay with what theyíre familiar with.

    I currently have Fedora installed on my laptop as a virtual machine so thatís why Iím trying to install IE there. I guess I should set up another virtual machine and install CentOS since thatís what Iím going to recommend.

  4. #4
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,459
    Wine has a version of IE (5 or 6 I think) already installed. If you want a newer version, you are SOL. They won't install/run.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  5. #5
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    I'd recommend that you force them to use Firefox or another browser. Using Wine to run anything is just going to cause problems eventually, especially something like IE. Are you going to be available every time something goes wrong with Wine or IE in Wine? Try and keep it simple, to make it easier on yourself.
    I don't think Browser are all that much different any way, sure you have some things that are handled differently but it's all pretty much the same thing as far as being on the Internet.
    Just an opinion.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  6. #6
    Linux Newbie
    Join Date
    Mar 2009
    Posts
    228
    Quote Originally Posted by Rubberman View Post
    Wine has a version of IE (5 or 6 I think) already installed. If you want a newer version, you are SOL. They won't install/run.
    It is? I don't see it in the Wine drop down menu. Do you know where it is?

    When I start something like Notepad SELinux complains with the error:

    SELinux has prevented wine from performing an unsafe memory operation.
    The application still starts but it's not looking good.

  7. #7
    Linux Newbie
    Join Date
    Mar 2009
    Posts
    228
    Quote Originally Posted by MikeTbob View Post
    Try and keep it simple, to make it easier on yourself.
    I'm definitely a fan of the KISS principle (Keep it short and simple). It's not looking good but at least it was worth a try.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •