Find the answer to your Linux question:
Results 1 to 10 of 10
I Installed Wine so that I could install Starcraft 1 and play it. It installed fine, but when I go to run it the system crashes as soon as the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2012
    Posts
    25

    Running Starcraft 1 with Wine


    I Installed Wine so that I could install Starcraft 1 and play it. It installed fine, but when I go to run it the system crashes as soon as the game launches. The entire desktop turns to vertical lines (like the vertical adjustment on old TV sets) and the screen turns gray. At this point I can not soft boot the system and must turn it off with the power button. According to the Wine website, this program works just fine with Wine. Please help. Thank you.

  2. #2
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    Hi and welcome to the forum. Are you using a video card with 3D graphics enabled?Also, when configuring winecfg, are you set for Windows XP or something more recent?
    Linux Mint + IceWM Registered: #371367 New Members: click here

  3. #3
    Just Joined!
    Join Date
    May 2012
    Posts
    25
    I assume the 3d graphics are enabled (but not sure how to check), because other games work fine. I configured wine to Windows XP.

  4. #4
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    What distro can what graphics card? If Nvidia, open a terminal and do:
    Code:
    glxgears
    If you use Nvidia and see three gears turning, you are 3d enabled. If not, you aren't.
    Linux Mint + IceWM Registered: #371367 New Members: click here

  5. #5
    Just Joined!
    Join Date
    May 2012
    Posts
    25
    The manufacturers stickers on the laptop say that my computer has "AMD Radeon Graphics". However when I run the above command in the terminal, I do see three gears turning.

    Oh, and my distro is Mint Debian Edition.
    Last edited by Milburnt; 06-19-2012 at 06:16 PM. Reason: forgot info

  6. #6
    Just Joined!
    Join Date
    May 2012
    Posts
    25
    got an email that you replied to the thread, but not showing up here. Anyway, my distro is Mint Debian Edition. Thank you.

  7. #7
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    Replied but then got caught up in business and thought to reply better later so deleted it. Anyway, Have a look at this page for how to enable, or check to make sure 3d graphics are enabled, in Ubuntu with ATI. If so then we'll have to look elsewhere for a solution. Look down where it says "Using the Ubuntu repositories (recommended)" and see if yours are enabled.
    Linux Mint + IceWM Registered: #371367 New Members: click here

  8. #8
    Just Joined!
    Join Date
    May 2012
    Posts
    25
    That is for Ubuntu based mint. Mine is Debian based.

  9. #9
    Just Joined!
    Join Date
    Jun 2012
    Posts
    1
    I ran into this same problem (yesterday) when installing Starcraft on WattOS (Ubuntu Based). I do not know if you are using a laptop or desktop, but my problem seemed to be the integrated video card (on 2002 machine) did not support 3d Graphics. I did want to note that if you have not already, you should check to see if your video card uses any proprietary drivers (under preferences - additional drivers on mine). If you are using a desktop it may be time to look around and see if you have another video card lying around. It won't take much to run Starcraft - just about any AGP card should be fine.

    Random Note: Starcraft is awesome - it is great to see someone else wanting to remissness on some good old games - and doing it on linux just makes it better!

  10. #10
    Just Joined!
    Join Date
    May 2012
    Posts
    25
    Still unable to get it working. I tried looking for additional drivers like you said and couldn't find it. I am fairly new to Linux, so am still learning how to do things. My card should support 3d graphics (the laptop was purchased new at Christmas). I ran an lspci command from the terminal, and the result for the video card is:

    00:01.0 VGA compatible controller: ATI Technologies Inc Device 9641

    any help is welcome as I am getting annoyed that I can't seem to get things working correctly.

    As a side note, would it be better to try running virtualbox, or use wine?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •