Find the answer to your Linux question:
Results 1 to 5 of 5
I'm running linux mint (umbuntu). I recently got apache2 and mysql via the software manager with the hopes of learning PHP. Now I seem to have Wineserver starting up as ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2010
    Posts
    8

    Wineserver is loading on startup. Make it stop?


    I'm running linux mint (umbuntu).

    I recently got apache2 and mysql via the software manager with the hopes of learning PHP. Now I seem to have Wineserver starting up as soon as linux loads. I have to close it manually every time I start my computer up. Nothing bad happens when it closes, but if I leave it open I start to lag.

    Why is wineserver starting on startup? How can I make it stop doing that? I tried looking under services and it wasn't listed.
    Last edited by lamoxlamae; 07-12-2013 at 04:57 AM. Reason: title type

  2. #2
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    If you don't need wine for anything just uninstall it would work I think...
    Code:
    sudo apt-get remove wine
    If you do use wine, try setting it so it won't run at startup by using the methods listed here. Hope this helps.
    Linux Mint + IceWM Registered: #371367 New Members: click here

  3. #3
    Just Joined!
    Join Date
    Feb 2010
    Posts
    8
    The problem is that I do use Wine. I tried uninstalling apache2 and mysql and still have wineserver popping up when I load the computer. On the bright side, some errors that were being thrown on shutdown have gone away. I know I didn't mention those, but I didn't notice them at first until I started restarting to test to see if the steps to disable programs worked.

    One error mentioned Jetty. Does Jetty invoke wineserver? I can't seem to kill, delete, or get rid of it. I tried terminal (su jetty -k) and Jobs-Admin. Terminal did nothing and it wouldn't let me uncheck it from jobsadmin. In fact, I couldn't uncheck anything with jobsadmin, even with su on. Jetty isn't coming up under System monitor so that's not helpful. I tried getting chconfig like the article suggested, but got an error stating the "package is not available, but is referred to by another package"

  4. #4
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    Sign in as root:
    Code:
    sudo su
    ...and enter pass. You should then get the familiar '#' sign instead of '$.' Try jobsadmin then. You should be able to work it. If you still can't do anything signed in as root, I'd start getting suspicious. Invoke 'top' or 'htop' (which to me is better but you'll have to install it), and check processes and who or what is controlling them. Did you try uninstalling wine? Did that not stop wineserver?
    Linux Mint + IceWM Registered: #371367 New Members: click here

  5. #5
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,517
    The Wineserver should only run if you have a Windows/Wine application running. Were your apache2 or mysql applications Windows versions. No native Linux application should invoke wine infrastructure.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •