Find the answer to your Linux question:
Results 1 to 3 of 3
Hi, I'm new here. I've been trying to install the latest version of SketchUp to run in WINE. If it matters, I'm running Mint 16 Petra Cinnamon AMD64 with lots ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2014
    Location
    Lancashire, NW England, UK
    Posts
    6

    Intall in WINE requires service pack 2 or better.


    Hi, I'm new here.
    I've been trying to install the latest version of SketchUp to run in WINE. If it matters, I'm running Mint 16 Petra Cinnamon AMD64 with lots of memory and drive space.
    When I start the SketchUpMake-en.exe in c: drive, it starts the install and then reports:

    Code:
    Prerequisite check for system component Microsoft Windows failed with the following error message:
    "Installation of SketchUp requires Windows XP Professional x64 Service Pack 2 or later."
    
    See the setup log file located at 'C:\users\ian\Temp\VSD8981.tmp\install.log' for more information.
    The log file follows:

    Code:
    The following properties have been set:
    Property: [AdminUser] = true {boolean}
    Property: [InstallMode] = HomeSite {string}
    Property: [ProcessorArchitecture] = AMD64 {string}
    Property: [VersionNT] = 5.1.3 {version}
    Running checks for package 'Microsoft Windows', phase BuildList
    The following properties have been set for package 'Microsoft Windows':
    Running checks for command 'SketchUpPrerequisites\32-bit'
    Result of running operator 'ValueNotEqualTo' on property 'ProcessorArchitecture' and value 'Intel': true
    Result of checks for command 'SketchUpPrerequisites\32-bit' is 'Bypass'
    Running checks for command 'SketchUpPrerequisites\64-bit'
    Result of running operator 'ValueNotEqualTo' on property 'ProcessorArchitecture' and value 'AMD64': false
    Result of running operator 'VersionGreaterThanOrEqualTo' on property 'VersionNT' and value '5.2.2': false
    Result of running operator 'VersionLessThan' on property 'VersionNT' and value '5.2.2': true
    Result of checks for command 'SketchUpPrerequisites\64-bit' is 'Fail'
    'Microsoft Windows' RunCheck result: Fail
    A prerequisite failed for Package "Microsoft Windows"
    Package failed with message "Installation of SketchUp requires Windows XP Professional x64 Service Pack 2 or later."
    Can anyone tell me what I'm missing please? I had this working for an earlier version of SktchUp on an earlier version of Mint15, but I can't remember now how I got there.

    Thanks.

  2. #2
    Just Joined!
    Join Date
    Apr 2014
    Location
    Lancashire, NW England, UK
    Posts
    6

    Installing Wine for SketchUp in Mint [SOLVED]

    Sorry if I've taken up your time.

    I have found the solution I used back in January:

    SOLUTION: In winecfg, change away from WindowsXP and then BACK TO WindowsXP. Suddenly, the SU installation works as it should.

    Hope this helps someone . . .

  3. #3
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,932
    You might also try installing winetricks. That helps deal with a lot of these sort of incompatibilities in my experience.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •