Find the answer to your Linux question:
Results 1 to 6 of 6
Hi! I checked out a copy of the Cedega source from the CVS on 3/5/2005. I su'ed to the root user and ran ~/winex/tools/wineinstall, as it mentioned in the readme. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2005
    Posts
    2

    Cedega (WineX) wineinstall problem


    Hi!

    I checked out a copy of the Cedega source from the CVS on 3/5/2005. I su'ed to the root user and ran ~/winex/tools/wineinstall, as it mentioned in the readme. Partway through the compile, I ran into this problem.

    make[1]: Entering directory `~/winex/miscemu'
    gcc -MMD -c -I. -I. -I../include -I../include -g -O2 -Wall -mpreferred-stack-boundary=2 -fno-keep-static-consts -D__const=const -fno-strict-aliasing -D__int8=char -D__int16=short -D__int32=int "-D__int64=long long" -D__WINE__ -D_REENTRANT -I/usr/X11R6/include -o preloader.o preloader.c
    preloader.c:199: error: syntax error before string constant
    preloader.c:205: warning: return type defaults to `int'
    preloader.c: In function `__ASM_GLOBAL_FUNC':
    preloader.c:206: error: storage class specified for parameter `wld_exit'
    preloader.c:206: error: syntax error before '{' token
    preloader.c:266: warning: structure defined inside parms
    preloader.c:268: error: syntax error before "args"
    preloader.c:384: error: parameter `s_iter' is initialized
    preloader.c:384: error: `s' undeclared (first use in this function)
    preloader.c:384: error: (Each undeclared identifier is reported only once
    preloader.c:384: error: for each function it appears in.)
    preloader.c:384: confused by earlier errors, bailing out
    make[1]: *** [preloader.o] Error 1
    make[1]: Leaving directory `~/winex/miscemu'
    make: *** [miscemu/wine-preloader] Error 2

    Compilation failed, aborting install.

    Has anyone else encountered this problem before? Does anyone know where I could go to find information to fix it? (BTW, I'm running Fedora Core 3 with the 2.6.10-1.766 version of the kernel.)

    Thanks!

  2. #2
    Just Joined!
    Join Date
    Mar 2005
    Posts
    4
    I have had the same problem with that very file. What GCC version are you using? What Distro? I'm using SuSE 9.2 Professional, and I'll have to check the GCC version later. The reason I ask is that I haven't seen this error anywhere else since I started searching.

    Has anyone else had this problem?

  3. #3
    Just Joined!
    Join Date
    Mar 2005
    Posts
    2
    I'm using gcc 3.4.2 on Fedora Core 3.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    Well, since you're using a CVS version, my guess would be that it's a bug? Contact the developers and see what they have to say.

    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

  6. #5
    Just Joined!
    Join Date
    Mar 2005
    Posts
    4
    I checked out the latest cvs yesterday, and it compiled! Although, I am now running into equally serious problems. I have tried running the incredibly simple Win program Notepad as a test...but it complains not only of unimplemented functions in User32.dll but as well complains that it cannot load lbxdrv.so because of "undefined symbol dllname" (The graphical component apparently). Has anyone else had these problems? I am going to recompile with new X headers to see if that works. Perhaps my X version and header version are mismatched?

  7. #6
    Just Joined!
    Join Date
    Mar 2005
    Posts
    4
    Anyone?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •