Find the answer to your Linux question:
Results 1 to 9 of 9
distro - redhat 9. i downloaded wine-20050310.tar.gz from winehq.org. extracted, then # ./configure, make depend, make , make install, ...............then what next ??? how to go ahead ? studied the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2005
    Location
    india
    Posts
    87

    using wine..... i am new to this


    distro - redhat 9. i downloaded wine-20050310.tar.gz from winehq.org. extracted, then # ./configure, make depend, make , make install, ...............then what next ??? how to go ahead ? studied the documentation at winehq.org. I am not able to understand. can anyone write a brief step-by-step procedure for how to configure wine ??? Thanx

  2. #2
    Linux Newbie
    Join Date
    Mar 2005
    Posts
    205
    Omg, just download the rpm.
    Ma homeboy is Jesus himself.

  3. #3
    Linux Guru bryansmith's Avatar
    Join Date
    Nov 2004
    Location
    /Ontario/Canada
    Posts
    2,619
    Hi jkmartha,

    I searched rpm.pbone.net for you and found wine 20040505 for RH9 (a little older but it should still work well). Just download that file (the link to download is under the google text ad). Then, open a terminal and cd to the directory you downloaded it to. As root, type
    Code:
    rpm -ihv wine[rest of name].rpm
    After that is done, you should just be able to type
    Code:
    wine [program name]
    and have it work, assuming it works with wine.

    Hope that helps,
    Bryan
    Looking for a distro? Look here.
    "There can be no doubt that all our knowledge begins with experience." - Immanuel Kant (Critique of Pure Reason)
    Queen's University - Arts and Science 2008 (Sociology)
    Registered Linux User #386147.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Mar 2005
    Location
    india
    Posts
    87

    wine lib error

    Hi Bryansmith,
    thanx for your reply. Instead of rpm, i opted for source & installed after ./configure,make depend, make,make install. It was all successful except for a message at the end which said.......something related to "library not loaded". Now, when i run # wine, it says ......
    "wine:error while loading shared libraries:libwine.so.1:cannot open shared object file: no such file or directory".
    if i run # wineconsole, it says ......
    "/usr/local/bin/wine: error while loading shared libraries:libwine.so.1:cannot open shared object file: no such file or directory".
    Anyway, how exactly should windows program run ??? just # wine <program name >..........will this do ? In place of <program name >, what exactly should i write for example ?
    After installing wine, no further configuration !!!! just start playing or should i have to configure anything else ???

    thanx

  6. #5
    Just Joined!
    Join Date
    Apr 2005
    Posts
    2
    you must have a working wine cofig file before starting.

    well i am new to it too but here is an easy way of cofiguring wine.
    use the config file that comes along withe original source (search for the file name cofig in the source tree)
    now download winetools from here http://www.winehq.com/site/download
    (there is a section marked 3rd party tools)
    use this program to setup wine for you (including fonts , a fake windows drive etc)

    tell if you get it working, good luck.

  7. #6
    Just Joined!
    Join Date
    Sep 2006
    Posts
    27

    wine on redhat help

    guys i am trying to load win on my machine and this is what i get after running this command ./configure .

    checking for gcc... no
    checking for cc... no
    checking for cc... no
    checking for cl... no
    configure: error: no acceptable C compiler found in $PATH
    See `config.log' for more details.

    what should i do .

  8. #7
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Quote Originally Posted by tawanda
    configure: error: no acceptable C compiler found in $PATH
    Install "gcc" and "make".

    Or directly use the Red Hat binary package :
    http://winehq.org/site/download
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  9. #8
    Just Joined!
    Join Date
    Sep 2006
    Posts
    27

    wine installation

    [B][B][B]i have manage to install wine and ran the make command but what do i do next coz i went on to run my nugg]ets executable file but i am still getting the same error.

    Nautilus has no installed viewer capable of displaying "/lettie/ccna/CBT_NUGGETS (1)/CBTNuggetPlayer.exe".


    what do i do next but i guess i am almost there guys

  10. #9
    Just Joined!
    Join Date
    Sep 2006
    Posts
    27

    wine installation

    i managed to run the make installl cmd and i got this error where could be the problem guys.
    The installed Wine libraries will not be found!

    You can either:

    Add the line '/usr/local/lib' to /etc/ld.so.conf and run /sbin/ldconfig
    export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/lib

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •