Find the answer to your Linux question:
Results 1 to 7 of 7
Hello all! I just recently started using Suse and I think it's great! I got everything working and it didn't take too much effort. However, now I'm at a dead ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2005
    Posts
    4

    No Direct X sound in WINE



    Hello all!
    I just recently started using Suse and I think it's great!
    I got everything working and it didn't take too much effort.
    However, now I'm at a dead end.

    I used the WINE that was available in YAST, had my sound issue and I since then tried 3 other versions of WINE.

    Currently, I'm using version 20050628.

    I have a Nforce AC97 Sound card (well, actually built in the mother board). Everything as far as sound works outside of WINE. Heck, even music in Winamp works great (because it uses Wav out). However, when I try a game that used Direct X sound such as Star Craft, I get this error:

    err:waveSDB_MapBuffer Use: "HardwareAcceleration" = "Emulation" in the [dsound] section of your config file.

    The odd thing is.... I have that line uncommented in the conf file:

    [WinMM]
    ; Uncomment the "Drivers" line matching your sound setting.
    ; Note that currently the OSS driver is the most implemented one and so it is recommended for sound apps

    "Drivers" = "wineoss.drv" ; default for most common configurations
    ;"Drivers" = "winearts.drv" ; for KDE
    ;"Drivers" = "winealsa.drv" ; for ALSA users
    ;"Drivers" = "winejack.drv" ; for Jack sound server
    ;"Drivers" = "winenas.drv" ; for NAS sound system
    ;"Drivers" = "wineaudioio.drv" ; for Solaris machines
    ;"Drivers" = "" ; to disable sound
    "WaveMapper" = "msacm.drv"
    "MidiMapper" = "midimap.drv"

    [dsound]
    ;; HEL only: Number of waveOut fragments ahead to mix in new buffers.
    "HELmargin" = "16"
    ;; HEL only: Number of waveOut fragments ahead to queue to driver.
    "HELqueue" = "16"
    ;; Max number of fragments to prebuffer
    ;"SndQueueMax" = "28"
    ;; Min number of fragments to prebuffer
    ;"SndQueueMin" = "12"
    ;; Forces emulation mode (using wave api)

    "HardwareAcceleration" = "Emulation"

    ;; Sets default playback device (0 - number of devices - 1)
    "DefaultPlayback" = "0" ; use first device (/dev/dsp)
    ;"DefaultPlayback" = "1" ; use second device (/dev/dsp1)
    ;"DefaultPlayback" = "2" ; use third device (/dev/dsp2)
    ;; Sets default capture device (0 - number of devices - 1)
    ;"DefaultCapture" = "0" ; use first device (/dev/dsp)
    ;"DefaultCapture" = "1" ; use second device (/dev/dsp1)
    ;"DefaultCapture" = "2" ; use third device (/dev/dsp2)

    I've tried uncommenting the different drivers in WINE and that didn't work. I tried restarting the system, the sound server and everything else and that didn't work. I tried uninstalling and reinstalling Wine with 3 other versions and that didn't work. I tried using Winetools and that didn't work.

    I honestly don't know what to do. I've been everywhere and tried everything I could and couldn't find a solution to my problem.
    Does anyone out there think they could solve this problem?



  2. #2
    Linux Enthusiast
    Join Date
    Dec 2004
    Posts
    577
    Have you tried installing wine, maybe wine doesen't support that version of DirectX sound

  3. #3
    Just Joined!
    Join Date
    Aug 2005
    Posts
    4
    Quote Originally Posted by Dude500
    Have you tried installing wine, maybe wine doesen't support that version of DirectX sound

    Huh? WINE is already installed :/

    WINE does support Direct X sound for Star Craft, Winamp and every other application that uses Direct X 8 and below.

  4. #4
    Linux Enthusiast
    Join Date
    Dec 2004
    Posts
    577
    Try messing around with the options so see if you can get the sound to work

  5. #5
    Just Joined!
    Join Date
    Aug 2005
    Posts
    4
    Quote Originally Posted by Dude500
    Try messing around with the options so see if you can get the sound to work

    What options? Do you mean the config file? I played around with that so many times it's not even funny.

    I even used winecfg and played with those options... Nothing

  6. #6
    Just Joined!
    Join Date
    Aug 2005
    Posts
    4

    Nevermind everybody! I figured out how to do it.

    Changing the config file did nothing for me.
    If any one of you have the same problem I did, simply do this

    Go into your .wine directory. (cd ~/.wine)

    Open up user.reg.

    Look for "[Software\\Wine\\Fonts\\External Fonts]" (without quotations) and just above it put:

    [Software\\Wine\\DirectSound]
    "HardwareAcceleration"="Emulation"
    Save the file and your sound should be working!

  7. #7
    Just Joined!
    Join Date
    Nov 2005
    Posts
    1

    This might help too. Worked for me.

    I did the above adjustment to the user.reg file, but still no sound until I edited the audio driver right below it. Just had to change it from Alsa to Oss.

    User.reg reads:

    [Software\\Wine\\DirectSound] 1132920457
    "HardwareAcceleration"="Emulation"

    [Software\\Wine\\Drivers] 1132952698
    "Audio"="oss"

    Now I have sound.

    Laterz.

    Running: Suse 9.3

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •