Find the answer to your Linux question:
Results 1 to 6 of 6
Hey everyone! I'm trying to get an "old" (2000) game called Majesty to work on Wine. I've gotten it to install, after some fussing with dlls. But when I try ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2006
    Posts
    2

    Majesty


    Hey everyone!

    I'm trying to get an "old" (2000) game called Majesty to work on Wine. I've gotten it to install, after some fussing with dlls. But when I try to run it, it doesn't work.



    Information about the crash that may be useful:

    Wine was set (through winecfg) to mimic windows 98, since that's what I installed it under. Program requirements for Majesty are listed as Windows 95/98. Trying others doesn't help.

    The command I ran was:

    ~/.wine$ wine drive_c/Program\ Files/MicroProse/Majesty/Majesty.exe

    fixme:vxd:VXD_Open Unknown/unsupported VxD L"sice.vxd". Try setting Windows version to 'nt40' or 'win31'.
    fixme:vxd:VXD_Open Unknown/unsupported VxD L"siwvid.vxd". Try setting Windows version to 'nt40' or 'win31'.
    fixme:vxd:VXD_Open Unknown/unsupported VxD L"ntice.vxd". Try setting Windows version to 'nt40' or 'win31'.
    wine: Unhandled page fault on read access to 0x00000000 at address 0x4262a2 (thread 0009), starting debugger...
    WineDbg starting on pid 0x8
    Unhandled exception: page fault on read access to 0x00000000 in 32-bit code (0x004262a2).
    Register dump:
    CS:0073 SS:007b DS:007b ES:007b FS:1007 GS:0033
    EIP:004262a2 ESP:7fa5da8c EBP:7fa5dad8 EFLAGS:00010246( - 00 -RIZP1)
    EAX:c0317000 EBX:00000001 ECX:7fa5db00 EDX:7fa5dbcd
    ESI:00000000 EDI:00400000
    Stack dump:
    0x7fa5da8c: 00400000 7fce5d10 7fa5dad8 7fa5daac
    0x7fa5da9c: 00000001 7fa5dbcd 7fa5db00 00001010
    0x7fa5daac: 00400000 7fce5d10 00000001 00001010
    0x7fa5dabc: 00000073 fa23a9f5 700007ff 7fa5c031
    0x7fa5dacc: 00000000 fa23a9f5 00000002 7fa5db9c
    0x7fa5dadc: 0042641f 00001010 7fa5db00 00400000
    0200: sel=1007 base=7fec4000 limit=00001fff 32-bit rw-
    Backtrace:
    =>1 0x004262a2 in majesty (+0x262a2) (0x004262a2)
    2 0x0042641f in majesty (+0x2641f) (0x0042641f)
    3 0x00422d9c in majesty (+0x22d9c) (0x00422d9c)
    4 0x00421e56 in majesty (+0x21e56) (0x00421e56)
    5 0x0042111e in majesty (+0x2111e) (0x0042111e)
    6 0x00420bea in majesty (+0x20bea) (0x00420bea)
    7 0x0042087e in majesty (+0x2087e) (0x0042087e)
    8 0x00422506 in majesty (+0x22506) (0x00422506)
    9 0x0040e279 in majesty (+0xe279) (0x0040e279)
    10 0x004169b2 in majesty (+0x169b2) (0x004169b2)
    11 0x7fcddc9f in kernel32 (+0x4dc9f) (0x7fcddc9f)
    12 0xb7ee3107 wine_switch_to_stack+0x17 in libwine.so.1 (0xb7ee3107)
    0x004262a2: movl 0x0(%esi),%edi
    Wine-dbg>


    I would guess that the useful information is in the first couple of lines of that...

    It gives the same error when I run the Majesty.exe that is still on the cdrom.

    So, could somebody help me out here? Is this something that can be fixed or worked around by giving it the right dlls, or maybe changing some settings or something? I've looked around for some help on google, and haven't gotten any useful suggetions.

    [edit] Okay, found some stuff about how VxD really isn't supported under wine, and am going to try uninstalling, reinstalling with wine pretending to be a later version of windows, and will hope that helps - it might, based on what I've read. Still welcome any other suggestions... [/edit]

    [edit] Okay, after changing I-don't-know-what, I now get the error of
    "wine: Unhandled privileged instruction at address 0x40986f"


    Looking around, this and the previous error seem to be deliberate breaks from compatibility, for some reasons or another... I really don't know what to do now. [/edit]

  2. #2
    Linux Newbie
    Join Date
    Sep 2005
    Posts
    140
    Is that the same game as shown here? If not disregard the rest of this.
    http://tuxgames.com/details.cgi?refe...son&gameref=58

    This link is probably old. If this is the same game it's probably the best way to run it in linux. A quick google did not come up with any (legal) way of getting the linux binaries without paying $38.

    If you want to see how well it runs the demo still seems to be available.

    The vxd errors can likely be ignored. I've seen that in other games that run fine. The unhandled page fault will be the problem.
    WARNING: I may be telling you more than I know !

  3. #3
    Just Joined!
    Join Date
    Mar 2006
    Posts
    2
    Yes, it's that game.

    I was just hoping that there was some way to get my copy of it to run - I'd had it for a while, it ran fine on my windows box that I used to have, and it feels a little bit silly to repurchase the same game twice...

    Ah well, maybe I'll either buy it, or just get Cedega, they claim to have it working... or maybe neither.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Newbie
    Join Date
    Sep 2005
    Posts
    140
    Unfortunately this isn't one of those games where you can just download the linux binaries and use cd key you already have. The linux version isn't likely to show up at the local used game store either.
    If you want to take a chance on $2 that link has some disks from insurance salvage. Personally I wouldn't muck around with wine/cedega if a linux version is available.
    WARNING: I may be telling you more than I know !

  6. #5
    Just Joined!
    Join Date
    Jan 2008
    Posts
    1

    I've gotten a bit farther than you

    I JUST figured it out

    Here's how to play Majesty in Wine:

    You have to have the most up-to-date version of Wine.

    Use it to install as usual. Then, when you make the launcher, or use terminal, use this:

    wine "blahblahblah.exe" -opengl

    I couldn't get it to work with -nointro also, so you have to sit through the stupid movie. But the game works. There should be a Majesty game file to modify with SET gxApi “OpenGL” so you don't have to include -opengl in the launcher, but I don't know which one that is just yet.

    (Sorry if the subject sounds snippy I'd originally gotten just to the table before things went south again and was going to ask for help before figuring it out and forgot to change it. And I just realized this thread's a bit old, haha. But I got excited

  7. #6
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Hi and Welcome !

    Well Done and thanx for sharing solution with us.
    Have fun with Linux !
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •