Find the answer to your Linux question:
Results 1 to 8 of 8
I wanna say hello before i start.This is my first post. My gear; P4 3.0 1024DDR 6600GT i865 MBoard Here is the thing. I tried lots of wine and cvswine ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2006
    Posts
    3

    Which Distro,wine version,updates to be able to run WoW in Linux?Need advise..


    I wanna say hello before i start.This is my first post.
    My gear; P4 3.0 1024DDR 6600GT i865 MBoard
    Here is the thing.
    I tried lots of wine and cvswine versions and those 'WoW.Wine.Pathces' with Ubuntu and Fedore Core 4.
    All i got is Fatal Error Failed to Open model.mpq. But that file is not corrupted because i can play with windows with that wow files.
    I tried a new install from cds on linux that ill try it again in a few minutes later.Omg same error.
    The thing that i want from you guys;

    Can you tell me if you know about this error?

    Or if you can run the wow under linux, what is your distro, wine version, did you install any updates to run it and did you get help from any "how-to" can you link it to me?

    I am really tired of googleing the errors.I spent many nights through google in that week.

    Directions of your answers ill install a new distro and try to run the game.If i cant, bye linux hello windows :'(.

    The exact errors;
    At Console;

    [root@enes World of Warcraft]# wine wow.exe -opengl
    fixme:advapi:SetSecurityInfo stub
    fixme:dbghelp:sffip_cb NIY on 'C:\build\buildWoW\WoW\bin\Wow.pdb'
    [root@enes World of Warcraft]#

    At wine window;

    This application has encountered a critical error:

    ERROR #134 (0x85100086) Fatal Condition
    Program: Z:\root\World of Warcraft\wow.exe

    Failed to open archive model.MPQ: File not found

    Press OK to terminate the application.

    And things inside wowerror.exe window;

    ================================================== ============================
    World of WarCraft (build 5086)

    Exe: Z:\root\World of Warcraft\wow.exe
    Time: Mar 18, 2006 1:36:10.850 AM
    User: root
    Computer: enes
    ------------------------------------------------------------------------------

    This application has encountered a critical error:

    ERROR #134 (0x85100086) Fatal Condition
    Program: Z:\root\World of Warcraft\wow.exe

    Failed to open archive model.MPQ: File not found



    WoWBuild: 5086
    ------------------------------------------------------------------------------

    ----------------------------------------
    Stack Trace (Manual)
    ----------------------------------------

    Address Frame Logical addr Module

    0062B92A 7B8CFBAC 0001:0022A92A Z:\root\World of Warcraft\wow.exe
    0062B863 7B8CFBD8 0001:0022A863 Z:\root\World of Warcraft\wow.exe
    0062B954 7B8CFBE4 0001:0022A954 Z:\root\World of Warcraft\wow.exe
    0040367F 7B8CFD20 0001:0000267F Z:\root\World of Warcraft\wow.exe
    004022AB 7B8CFE70 0001:000012AB Z:\root\World of Warcraft\wow.exe
    00402130 7B8CFE80 0001:00001130 Z:\root\World of Warcraft\wow.exe
    00403EA0 7B8CFF20 0001:00002EA0 Z:\root\World of Warcraft\wow.exe
    7BB59733 7B8CFFF4 0001:00048733 c:\windows\system32\kernel32.dll

    ----------------------------------------
    Stack Trace (Using DBGHELP.DLL)
    ----------------------------------------

    0062B92A wow.exe <unknown symbol>+0 (0x00000000,0x007E17D0,0x7B8CFBF0,0x00000000)
    0062B863 wow.exe <unknown symbol>+0 (0x7B8CFBF0,0x7B8CFD20,0x0040367F,0x007E17D0)
    0062B954 wow.exe <unknown symbol>+0 (0x007E17D0,0x007E0D14,0x7B8CFC04,0x7BEFFC80)
    0040367F wow.exe <unknown symbol>+0 (0x7BEFFC80,0x7BC006F8,0x00000000,0x0000013
    004022AB wow.exe <unknown symbol>+0 (0x00000001,0x00000001,0x7B8CFF20,0x00403EA0)
    00402130 wow.exe <unknown symbol>+0 (0x00409704,0x00400000,0x00000000,0x7BC006F
    00403EA0 wow.exe <unknown symbol>+0 (0x7BEFFC80,0x00000000,0x00000000,0x00000000)
    7BB59733 kernel32.dll <unknown symbol>+0 (0x7BEFFC80,0x00000000,0x00000000,0x00000000)
    F6FB2D1D wine_switch_to_stack+17 (0x00000000,0x00000000,0x00000000,0x00000000)


    ----------------------------------------
    Loaded Modules
    ----------------------------------------

    0x00400000 - 0x00C87000 Z:\root\World of Warcraft\wow.exe
    0x10000000 - 0x10069000 Z:\root\World of Warcraft\DivxDecoder.dll
    0x786C0000 - 0x786D0000 c:\windows\system32\psapi.dll
    0x786E0000 - 0x78710000 c:\windows\system32\dbghelp.dll
    0x79B40000 - 0x79B55000 c:\windows\system32\mpr.dll
    0x79B60000 - 0x79B9C000 c:\windows\system32\wininet.dll
    0x79BA0000 - 0x79BC0000 c:\windows\system32\msacm32.dll
    0x79BC0000 - 0x79C50000 Z:\root\World of Warcraft\fmod.dll
    0x79C70000 - 0x79CE1000 c:\windows\system32\winmm.dll
    0x7A700000 - 0x7A71A000 c:\windows\system32\imm32.dll
    0x7A750000 - 0x7A7C3000 c:\windows\system32\opengl32.dll
    0x7A7D0000 - 0x7A7F0000 c:\windows\system32\ws2_32.dll
    0x7A800000 - 0x7A80B000 c:\windows\system32\wsock32.dll
    0x7A810000 - 0x7A82A000 c:\windows\system32\iphlpapi.dll
    0x7A840000 - 0x7A871000 c:\windows\system32\rpcrt4.dll
    0x7A890000 - 0x7A906000 c:\windows\system32\ole32.dll
    0x7A920000 - 0x7A966000 c:\windows\system32\shlwapi.dll
    0x7A980000 - 0x7AA37000 c:\windows\system32\shell32.dll
    0x7AA40000 - 0x7AA78000 c:\windows\system32\advapi32.dll
    0x7AB80000 - 0x7B56A000 c:\windows\system32\gdi32.dll
    0x7B590000 - 0x7B6A2000 c:\windows\system32\user32.dll
    0x7B6B0000 - 0x7B76B000 c:\windows\system32\comctl32.dll
    0x7B780000 - 0x7B7D0000 c:\windows\system32\msvcrt.dll
    0x7BB10000 - 0x7BC00000 c:\windows\system32\kernel32.dll
    0x7BEA0000 - 0x7BF00000 c:\windows\system32\ntdll.dll
    0x7CD30000 - 0x7CD3B000 c:\windows\system32\sensapi.dll
    0x7CD40000 - 0x7CD5B000 c:\windows\system32\secur32.dll
    0x7CD60000 - 0x7CD74000 c:\windows\system32\rasapi32.dll
    0x7CD80000 - 0x7CDA0000 c:\windows\system32\winspool.drv
    0x7CDB0000 - 0x7CE3B000 c:\windows\system32\comdlg32.dll
    0x7CE40000 - 0x7CE55000 c:\windows\system32\oledlg.dll
    0x7CE60000 - 0x7CE69000 c:\windows\system32\lz32.dll
    0x7CE70000 - 0x7CE82000 c:\windows\system32\version.dll
    0x7CE90000 - 0x7CEA8000 c:\windows\system32\msvfw32.dll
    0x7CEB0000 - 0x7CEBC000 c:\windows\system32\avicap32.dll
    0x7CEC0000 - 0x7CEDB000 c:\windows\system32\unicows.dll
    0x7CEE0000 - 0x7CEF0000 c:\windows\system32\midimap.dll
    0x7D0C0000 - 0x7D0D6000 c:\windows\system32\msacm.drv
    0x7D0E0000 - 0x7D100000 c:\windows\system32\winealsa.drv
    0x7F690000 - 0x7F6C0000 c:\windows\system32\uxtheme.dll
    0x7FEB0000 - 0x7FF23000 c:\windows\system32\winex11.drv
    Thanks for reading...

  2. #2
    Linux User
    Join Date
    May 2005
    Posts
    473
    I found that game to emulate the best in vanila wine, you need to compile it yourself because it needs some patches though, oh and it crashes quite a bit as well, quite obnoxous in battlegrounds. But at all high settings i was getting 80+ fps (my rig is simular to yours)

  3. #3
    Linux User
    Join Date
    May 2005
    Posts
    473
    For some reason i cant edit, im using 0.9.7

    heres a good walk-through http://ubuntuforums.org/showthread.php?t=120615

    when running the game make sure to do

    cedega ~/wine/c_drive/wow/wow.exe -opengl

  4. $spacer_open
    $spacer_close
  5. #4
    Linux User
    Join Date
    May 2005
    Posts
    473
    ... sorry for 3 posts....
    heres some screenshots (ubuntu 5.10)



  6. #5
    Just Joined!
    Join Date
    Mar 2006
    Posts
    3
    Thanks for the answer.
    And what is vanila wine?

  7. #6
    Linux User
    Join Date
    May 2005
    Posts
    473
    just the normal version...

    http://easynews.dl.sourceforge.net/s...-0.9.7.tar.bz2

    you need to compile it yourself so read the instructions and before you compile add the patches menchioned in http://ubuntuforums.org/showthread.php?t=120615

  8. #7
    Just Joined!
    Join Date
    Mar 2006
    Posts
    3
    I am a bit messed up with wine now i cant uninstall or reinstall it.
    I will reinstall ubuntu then try what you said aout 0.9.7.
    Thank you so much mate.

  9. #8
    Linux User
    Join Date
    May 2005
    Posts
    473
    sudo apt-get remove wine

    Then compile it yourself with the link that i sent you and the patches menchioned in that other page

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •