Find the answer to your Linux question:
Results 1 to 4 of 4
i am new to linux and have recently installed wine on my laptop (with ubuntu 6.06 installed). when i go to run wine through the terminal it tells me that ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2006
    Posts
    4

    Help with wine


    i am new to linux and have recently installed wine on my laptop (with ubuntu 6.06 installed). when i go to run wine through the terminal it tells me that the x11 drivers are missing and to check my build. how do i fix this problem???

  2. #2
    Linux Enthusiast KenJackson's Avatar
    Join Date
    Jun 2006
    Location
    Maryland, USA
    Posts
    510
    How did you install it? The advice at WineHQ recommends not using the regular APT repositories, but use theirs like this:

    To install Wine from the WineHQ APT repository, you need to configure APT to look in the right place for the Wine packages. On Ubuntu systems, and those using the Synaptic Package Manager, this can be done easily by opening up Synaptic (System->Administration->Synaptic Package Manager) and selecting Settings->Repositories. Then click add, select custom, and enter one of the following:

    For Ubuntu Dapper (6.06):
    deb http://wine.budgetdedicated.com/apt dapper main

    Then, simply click reload and search for the package 'wine' for installation. If you already have a 'wine' package installed, selecting mark all upgrades should update Wine to the newest version.
    Also, you said, "when i go to run wine through the terminal". Does that mean you are running Wine with X not running--just text console terminals? If so, I've never run Wine without X, so I don't know if it will work.

  3. #3
    Just Joined!
    Join Date
    Jul 2006
    Posts
    4
    I installed wine through the repositories like it said on the WineHQ website.
    When I said I ran it through the terminal I meant when you type wine then the location of the program. Using the Terminal emulator it tells me the program can't make a window or something. When I try to run Wine through X, using the GNOME interface, by double-clicking it has a message telling me it can't open the file because it is a Windows/DOS executable and may be a threat to the system. I changed the "open with" to Wine Windows emulator and changed the extension as suggested by the message and yet nothing happens at all.

  4. #4
    Linux Enthusiast KenJackson's Avatar
    Join Date
    Jun 2006
    Location
    Maryland, USA
    Posts
    510
    It's difficult to give a general answer, so let me give a specific example--the Windows Freecell game.

    Wine has a "fake C drive" which is usually the directory ~/.wine/drive_c. I created a subdirectory under that drive named 'bin', into which I put miscellaneous Windows executables that I run with Wine.

    I edited ~/.wine/system.reg to add "c:\\bin;" to the front of
    [System\\CurrentControlSet\\Control\\Session Manager\\Environment] "PATH"

    I copied the executable file freecell.exe from its place on the Windows partition to my ~/.wine/drive_c/bin directory.

    I verified my ~/.wine/dosdevices directory contains a symbolic link named "c:" that points to my drive_c directory. If your executable is somewhere else, there must be some symbolic link in this directory that can get to it. Usually there is a "z:" which points to "/".

    Now, in any bash window (which I always have open anyway), I can type the command
    $ wine freecell
    and up pops a freecell game, just like I was running Windows, only better.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •