Find the answer to your Linux question:
Results 1 to 2 of 2
I have an odd permission problem running NSIS under wine. The circumstance is an ant task being run by apache via a web form. The ant task runs NSIS using ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2006
    Posts
    1

    Strange permissions problem executing NSIS under wine


    I have an odd permission problem running NSIS under wine.

    The circumstance is an ant task being run by apache via a web form. The ant task runs NSIS using wine.

    Apache is running as the "cmbuild" user, and the files it is working with are under the "cmbuild" user.

    When I run the ant task as "cmbuild" manually, all is hunky-dory.

    When I run it using the web form, NSIS pukes because it cannot open the install file (setup.nsi - the definition of the installer being built).

    I have run myself completely ragged making sure permissions are wide open and everything that needs permission (NSIS, wine, apache) are OK, but the problem stubbornly persists.

    I'm somewhat new to wine, and I'm stumped as to what to do next. Any ideas? We are running Fedora Core 5, Wine 0.9.2.2, and NSIS v2.14.

    Thanks,
    Rich Stephens

  2. #2
    Just Joined!
    Join Date
    Oct 2006
    Posts
    5
    First get the latest version of Wine.(0.9.24)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •