Find the answer to your Linux question:
Results 1 to 2 of 2
Hello, I have a problem I believe is a wine problem and not a game problem when I tried to get wine to work with poker stars. I am having ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2006
    Posts
    2

    No Fonts with wine


    Hello,

    I have a problem I believe is a wine problem and not a game problem when I tried to get wine to work with poker stars. I am having the same issues with any wine .exe command. Any gui with the spaces to fill in have absolutely no text on the gui.

    I have CentOS4 and used yum to get and install wine*. That gave me all the wine rpms, but not winetools. I could start over with winetools but don't know which to use for my distro or where to install it.

    And I got this error on the install:

    err:menubuilder:extract_icon32 LoadLibraryExW (L"c:\\Program
    Files\\PokerStars\\Uninstall.EXE
    err:menubuilder:InvokeShellLinker failed to fork and exec wineshelllink

    And when I try to run a program on wine (pokerstars for example) through the command line and not the icon, I get:

    fixme:resource:GetGuiResources (0xffffffff,1): stub
    fixme:resource:GetGuiResources (0xffffffff,0): stub
    fixme:toolhelp:CreateToolhelp32Snapshot Unimplemented: heap list snapshot
    fixme:toolhelp:Heap32ListFirst : stub

    I read I might need some fonts (which makes sense sinse I have no text in
    any gui) so got tahoma32.exe from a link somewhere searching for info and then found, downloaded and did wine fontname.exe for some fonts like arial.exe that I found here:

    http://superb-east.dl.sourceforge.ne...rge/corefonts/

    and used yum to install guichan

    I read a very similar problem that was fixed by copying the files
    from .wine/dosdevices/c\:/windows/fonts/
    to .wine/drive_c/windows/fonts/

    But that did not help either.

    Lots of wineboot

    Thanks for any help, and I am a pretty basic Linux user

  2. #2
    Just Joined!
    Join Date
    Oct 2006
    Posts
    2

    Finally!!!

    After several days I finally got Poker Stars to work. My biggest problem was missing text in GUI's and a blank list of tables there.

    Yum install gave me an older version which did not work with Poker Stars, so I found the latest rpm for Centos4 at sourceforge.net. Then the latest version of winetools. Centos4 does not include xdialog which is needed by winetools and I got an rpm through yum of xdialog that worked.

    Then when installing the base programs with winetools, the one for "Microsoft Foundation Classes 4x" just hangs and does not download anything. It does put empty mfx40.dll and 42.dll files in c/windows/system32/, but they are blank files. I downloaded them at http://www.dll-files.com/ and replaced the empty ones.

    I found tahoma32.exe (somewhere) for the tahoma fonts just downloaded it to my home directory. Then the command wine tahoma32.exe, which put them where they belonged. Then installed all the fonts available through winetools

    IE gave me an error that I needed itinpki.dll (small letters) and cryptdlg.dll. Those were also at www.dll-files.com, and I put them in c/windows/system32/

    Then IE wanted gecko, which it took care of itself. Bringing up IE still gives me a totally blank window but Poker Stars finally works well.

    GEESH!!!!!!!!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •