Find the answer to your Linux question:
Results 1 to 6 of 6
[Bug reported as #6735 on winehq bugzilla] I've been using wine on fedora for quite a while on successive incarnations of Fedora Core OSes on my home machine but last ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2006
    Posts
    1

    [FC6/Athlon-XP]Wine mysteriously failing (Unhandled page fault on read access to 0x00


    [Bug reported as #6735 on winehq bugzilla]

    I've been using wine on fedora for quite a while on successive incarnations
    of Fedora Core OSes on my home machine but last week Wine sunddenly started crashing on my Fedora Core 6 install with the following message :

    wine: Unhandled page fault on read access to 0x00000000 at address (nil)
    (thread 0009), starting debugger...

    Anything using wine binary will fail the sameway, even wine utilities like
    winecfg et al. won't run anymore.

    What I tried already :

    - remove/reinstall rpm
    - recompile from source
    - install crossover office 6 beta
    - disabling SELinux

    Hints : my home machine has an Athlon-XP mobo ; my intel P4 based work machine works seamlessly with the same FC6 installment.

    $ cat /proc/cpuinfo

    processor : 0
    vendor_id : AuthenticAMD
    cpu family : 6
    model : 8
    model name : AMD Athlon(tm) XP 2000+
    stepping : 1
    cpu MHz : 1662.837
    cache size : 256 KB
    fdiv_bug : no
    hlt_bug : no
    f00f_bug : no
    coma_bug : no
    fpu : yes
    fpu_exception : yes
    cpuid level : 1
    wp : yes
    flags : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov
    pat pse36 mmx fxsr sse syscall mmxext 3dnowext 3dnow up ts
    bogomips : 3328.20

    $ winecfg

    wine: Unhandled page fault on read access to 0x00000000 at address (nil)
    (thread 0009), starting debugger...
    wine: Unhandled page fault on read access to 0x00000000 at address (nil)
    (thread 000b), starting debugger...
    fixme:dbghelp:SymLoadModule Should have successfully loaded debug information
    for image c:\windows\system32\winecfg.exe
    couldn't load main module (7b)
    fixme:dbghelp:SymLoadModule Should have successfully loaded debug information
    for image c:\windows\system32\imm32.dll
    fixme:dbghelp:SymLoadModule Should have successfully loaded debug information
    for image c:\windows\system32\winex11.drv
    fixme:dbghelp:SymLoadModule Should have successfully loaded debug information
    for image c:\windows\system32\uxtheme.dll
    fixme:dbghelp:SymLoadModule Should have successfully loaded debug information
    for image c:\windows\system32\winmm.dll
    fixme:dbghelp:SymLoadModule Should have successfully loaded debug information
    for image c:\windows\system32\comdlg32.dll
    fixme:dbghelp:SymLoadModule Should have successfully loaded debug information
    for image c:\windows\system32\winspool.drv
    fixme:dbghelp:SymLoadModule Should have successfully loaded debug information
    for image c:\windows\system32\shell32.dll
    fixme:dbghelp:SymLoadModule Should have successfully loaded debug information
    for image c:\windows\system32\comctl32.dll
    fixme:dbghelp:SymLoadModule Should have successfully loaded debug information
    for image c:\windows\system32\shlwapi.dll
    fixme:dbghelp:SymLoadModule Should have successfully loaded debug information
    for image c:\windows\system32\ole32.dll
    fixme:dbghelp:SymLoadModule Should have successfully loaded debug information
    for image c:\windows\system32\rpcrt4.dll
    fixme:dbghelp:SymLoadModule Should have successfully loaded debug information
    for image c:\windows\system32\iphlpapi.dll
    fixme:dbghelp:SymLoadModule Should have successfully loaded debug information
    for image c:\windows\system32\user32.dll
    fixme:dbghelp:SymLoadModule Should have successfully loaded debug information
    for image c:\windows\system32\gdi32.dll
    fixme:dbghelp:SymLoadModule Should have successfully loaded debug information
    for image c:\windows\system32\advapi32.dll
    fixme:dbghelp:SymLoadModule Should have successfully loaded debug information
    for image c:\windows\system32\kernel32.dll
    fixme:dbghelp:SymLoadModule Should have successfully loaded debug information
    for image c:\windows\system32\ntdll.dll
    fixme:dbghelp:SymLoadModule Should have successfully loaded debug information
    for image c:\windows\system32\winecfg.exe
    Unhandled exception: page fault on read access to 0x00000000 in 32-bit code
    (0x00000000).
    Register dump:
    CS:0073 SS:007b DS:007b ES:007b FS:0033 GS:003b
    EIP:00000000 ESP:0033e978 EBP:0033ea9c EFLAGS:00210216( - 00 -RIAP1)
    EAX:00000000 EBX:00000000 ECX:00000000 EDX:000000c8
    ESI:7d622ac0 EDI:00000000
    Stack dump:
    0x0033e978: 60db1ffc 7d622ac0 7d5dca80 7d5dca80
    0x0033e988: 7d622ac0 7d624354 00000000 0033ea9c
    0x0033e998: 00000000 60f897d4 7d622ac0 0000005c
    0x0033e9a8: 00000000 60db178f 7d622ac0 60db1700
    0x0033e9b8: 00000001 60d94235 7d622ac0 7d622ac0
    0x0033e9c8: 7d622ac0 7d5dc800 7ed37008 7ed58000
    fixme:ntdll:RtlNtStatusToDosErrorNoTeb no mapping for c0000119
    Backtrace:
    =>1 0x00000000 (0x0033ea9c)
    2 0x00000040 (0x00000002)
    3 0x00000000 (0x00000000)
    0x00000000: addb %al,0x0(%eax)
    Modules:
    Module Address Debug info Name (0 modules)
    Threads:
    process tid prio (all id:s are in hex)
    0000000c
    0000000d 0
    0000000a
    0000000b 0
    00000008 (D) c:\windows\system32\winecfg.exe
    00000009 0 <==
    [alexis at localhost ~]$ wine: Unhandled page fault on read access to
    0x00000000 at address (nil) (thread 000d), starting debugger...
    fixme:dbghelp:SymLoadModule Should have successfully loaded debug information
    for image c:\windows\system32\explorer.exe
    couldn't load main module (7b)
    fixme:dbghelp:SymLoadModule Should have successfully loaded debug information
    for image c:\windows\system32\imm32.dll
    fixme:dbghelp:SymLoadModule Should have successfully loaded debug information
    for image c:\windows\system32\winex11.drv
    fixme:dbghelp:SymLoadModule Should have successfully loaded debug information
    for image c:\windows\system32\user32.dll
    fixme:dbghelp:SymLoadModule Should have successfully loaded debug information
    for image c:\windows\system32\gdi32.dll
    fixme:dbghelp:SymLoadModule Should have successfully loaded debug information
    for image c:\windows\system32\advapi32.dll
    fixme:dbghelp:SymLoadModule Should have successfully loaded debug information
    for image c:\windows\system32\kernel32.dll
    fixme:dbghelp:SymLoadModule Should have successfully loaded debug information
    for image c:\windows\system32\ntdll.dll
    fixme:dbghelp:SymLoadModule Should have successfully loaded debug information
    for image c:\windows\system32\explorer.exe
    Unhandled exception: page fault on read access to 0x00000000 in 32-bit code
    (0x00000000).
    Register dump:
    CS:0073 SS:007b DS:007b ES:007b FS:0033 GS:003b
    EIP:00000000 ESP:0034ea78 EBP:0034eb9c EFLAGS:00210216( - 00 -RIAP1)
    EAX:00000000 EBX:00000000 ECX:00000000 EDX:000000c8
    ESI:7d870d00 EDI:00000000
    Stack dump:
    0x0034ea78: 60aa0ffc 7d870d00 7d836060 7d836060
    0x0034ea88: 7d870d00 7d872594 00000000 0034eb9c
    0x0034ea98: 00000000 60c787d4 7d870d00 0000005c
    0x0034eaa8: 00000000 60aa078f 7d870d00 60aa0700
    0x0034eab8: 00000001 60a83235 7d870d00 7d870d00
    0x0034eac8: 7d870d00 7d836fd8 7ed37008 7ed58000
    fixme:ntdll:RtlNtStatusToDosErrorNoTeb no mapping for c0000119
    Backtrace:
    =>1 0x00000000 (0x0034eb9c)
    2 0x00000040 (0x00000002)
    3 0x00000000 (0x00000000)
    0x00000000: addb %al,0x0(%eax)
    Modules:
    Module Address Debug info Name (0 modules)
    Threads:
    process tid prio (all id:s are in hex)
    0000000c (D) c:\windows\system32\explorer.exe
    0000000d 0 <==
    0000000a
    0000000b 0
    fixme:dbghelp:SymLoadModule Should have successfully loaded debug information
    for image c:\windows\system32\explorer.exe
    couldn't load main module (7b)
    fixme:dbghelp:SymLoadModule Should have successfully loaded debug information
    for image c:\windows\system32\imm32.dll
    fixme:dbghelp:SymLoadModule Should have successfully loaded debug information
    for image c:\windows\system32\winex11.drv
    fixme:dbghelp:SymLoadModule Should have successfully loaded debug information
    for image c:\windows\system32\user32.dll
    fixme:dbghelp:SymLoadModule Should have successfully loaded debug information
    for image c:\windows\system32\gdi32.dll
    fixme:dbghelp:SymLoadModule Should have successfully loaded debug information
    for image c:\windows\system32\advapi32.dll
    fixme:dbghelp:SymLoadModule Should have successfully loaded debug information
    for image c:\windows\system32\kernel32.dll
    fixme:dbghelp:SymLoadModule Should have successfully loaded debug information
    for image c:\windows\system32\ntdll.dll
    fixme:dbghelp:SymLoadModule Should have successfully loaded debug information
    for image c:\windows\system32\explorer.exe
    Unhandled exception: page fault on read access to 0x00000000 in 32-bit code
    (0x00000000).
    Register dump:
    CS:0073 SS:007b DS:007b ES:007b FS:0033 GS:003b
    EIP:00000000 ESP:0034ea78 EBP:0034eb9c EFLAGS:00210216( - 00 -RIAP1)
    EAX:00000000 EBX:00000000 ECX:00000000 EDX:000000c8
    ESI:7d640d00 EDI:00000000
    Stack dump:
    0x0034ea78: 60988ffc 7d640d00 7d606060 7d606060
    0x0034ea88: 7d640d00 7d642594 00000000 0034eb9c
    0x0034ea98: 00000000 60b607d4 7d640d00 0000005c
    0x0034eaa8: 00000000 6098878f 7d640d00 60988700
    0x0034eab8: 00000001 6096b235 7d640d00 7d640d00
    0x0034eac8: 7d640d00 7d606fd8 7ed37008 7ed58000
    fixme:ntdll:RtlNtStatusToDosErrorNoTeb no mapping for c0000119
    Backtrace:
    =>1 0x00000000 (0x0034eb9c)
    2 0x00000040 (0x00000002)
    3 0x00000000 (0x00000000)
    0x00000000: addb %al,0x0(%eax)
    Modules:
    Module Address Debug info Name (0 modules)
    Threads:
    process tid prio (all id:s are in hex)
    0000000a (D) c:\windows\system32\explorer.exe
    0000000b 0 <==

  2. #2
    Just Joined!
    Join Date
    Aug 2002
    Location
    Salt Lake City, UT
    Posts
    4
    potorange,

    I have the exact same problem. Worked under Fedora Core 5 but not 6. I'm not on AMD, though, this is an Intel Pentium M, ThinkPad T41p. I get the same error messages and can't get wine to run anything.

    Has no one else seen this?! Or have any ideas?

    Thanks
    Devin

  3. #3
    Just Joined!
    Join Date
    Aug 2007
    Posts
    2

    Weird

    Allo,

    Did you guys manage to find a solution to your problem? I was running FC7 and wine to be able to use a wordpro viewer. It worked perfectly. After a harddrive failure and a new harddrive. I installed FC7, everything excactly as before, but now wine doesn't... Anything!

    Would really appreciate any info.

    The only difference between the previous install and this one, was that while I installed the first time with LVM, this time I used the "older" style configuring my harddrive. But I can't see how that would have any effect.

    Regards,

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Aug 2007
    Posts
    2

    Wine solved

    I seem to have found the problem...

    While it worked to do a "wine Kview32.exe", it now crashes with the error mentioned above. What I did to get it working again is to copy the file (and all my other apps to my "drive_c" and then ran:

    wine c:\\Kview32.exe (same for all my other apps)

    Now it works. Don't know what changed, but I hope it works for you

    Nev

  6. #5
    Just Joined!
    Join Date
    Aug 2002
    Location
    Salt Lake City, UT
    Posts
    4
    For me this error was caused by the ATI proprietary driver (fglrx). I was able to fix it by adding this line to my xorg.conf file, in the video card section under 'Driver "fglrx"':

    Option "UseFastTLS" "2"

    Hope this helps.

    Devin

  7. #6
    hqt
    hqt is offline
    Just Joined!
    Join Date
    Oct 2008
    Posts
    1
    Nevionix's workaround works for me - I can now run Irfanview 4.2 via Wine 1.1.6 in Ubuntu 8.04. After installing Irfanview via Wine, I copy i_view32.exe to
    .wine/drive_c directory (folder). Now you can test run IrfanView via the command line in that folder (drive_c):

    ~/.wine/drive_c$ wine i_view32.exe

    If that works you can also double-click on i_view32.exe (via the file browser). You should also have an IrfanView icon on the desktop, in which case you need to change its "Launcher" property accordingly. Mine is set to:
    env WINEPREFIX="/home/myLogin/.wine" wine "C:\\i_view32.exe"

    Good luck. It appears that Wine is having problems with command path or environment variables. In any case it's only a work around until Wine is fixed or broken again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •