Find the answer to your Linux question:
Results 1 to 3 of 3
My wine version is: wine-0.9.27, and I'm using a Radeon Mobility M300 on my laptop. I'm using a fully updated version of kubuntu 6.10. I had no problem installing WC3 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2006
    Posts
    3

    Warcraft III: The Frozen Throne and Wine


    My wine version is: wine-0.9.27, and I'm using a Radeon Mobility M300 on my laptop.

    I'm using a fully updated version of kubuntu 6.10.

    I had no problem installing WC3 in wine, but when I try:

    Code:
    $ wine "Frozen Throne.exe" >& ~/error.log
    It hangs, and I have to reboot the whole system. The log shows:

    Code:
    $ cat ~/error.log
    libGL warning: 3D driver claims to not support visual 0x4b
    libGL warning: 3D driver claims to not support visual 0x4b
    libGL warning: 3D driver claims to not support visual 0x4b
    err:ole:CoCreateInstance apartment not initialised
    fixme:advapi:SetSecurityInfo stub
    fixme:d3d:IWineD3DDeviceImpl_GetAvailableTextureMem (0x19e880) : stub, simulating 64MB for now, returning 64MB left
    fixme:d3d:state_blend Unrecognized dst blend value 0
    fixme:d3d:IWineD3DDeviceImpl_SetRenderState WINED3DRS_POINTSIZE_MIN not supported on this opengl
    fixme:d3d:IWineD3DDeviceImpl_SetRenderState WINED3DRS_POINTSIZE_MAX not supported on this opengl
    Try R300_SPAN_DISABLE_LOCKING env var if this hangs.
    err:seh:setup_exception nested exception on signal stack in thread 000f eip 7bc56a63 esp 7ffddbf0 stack 0x241000-0x350000
    Any ideas? If you need any more hardware information or whatever, let me know. TIA!

  2. #2
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    There is a (very simple) how-to here :
    http://frankscorner.org/index.php?p=wcfrozenthrone

    It appears that :
    Code:
    wine warcraft.exe -opengl
    should work.

    Given you have installed the proper drivers for your video card. Did you ? More here :
    https://help.ubuntu.com/community/BinaryDriverHowto/ATI
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  3. #3
    Just Joined!
    Join Date
    Dec 2006
    Posts
    3
    Thanks a lot! It turns out I didn't have my video drivers configured correctly. All of the other stuff I run on wine didn't have any 3d rendering needs, so I hadn't realized it until now.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •