Find the answer to your Linux question:
Results 1 to 2 of 2
Hi, I've reicently bought a dedicated linux server with root acess. Im using SSH to connecto to the server. So far I've installed wine using the "yum install" command. But ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2007
    Posts
    1

    Using Wine?


    Hi, I've reicently bought a dedicated linux server with root acess. Im using SSH to connecto to the server. So far I've installed wine using the "yum install" command. But when it comes to running I browse to the correct folder and try to execute "wine evo.exe engine 0" command and this is the output that I get.

    [root@localhost evo]# wine evo.exe
    err:ntdll:RtlpWaitForCriticalSection section 0x602eed24 "loader.c: loader_section" wait timed out in thread 000a, blocked by 0009, retrying (60 sec)
    Application tried to create a window, but no driver could be loaded.
    Make sure that your X server is running and that $DISPLAY is set correctly.
    [root@localhost evo]# Application tried to create a window, but no driver could be loaded.
    Make sure that your X server is running and that $DISPLAY is set correctly.

    I saw somewhere on the forum that you cannot run with root user so i tried wit ha different user and I get the same result. I've also put in the
    "export DISPLAY=:0.0" inside .bash_profile and "xhost +local:" in the .bash_profile under the username folder. Why isnt it working?

  2. #2
    Just Joined!
    Join Date
    Aug 2006
    Posts
    63
    Quote Originally Posted by jeremic
    Hi, I've reicently bought a dedicated linux server with root acess. Im using SSH to connecto to the server. [But:]

    [root@localhost evo]# wine evo.exe
    Application tried to create a window, but no driver could be loaded.
    Make sure that your X server is running and that $DISPLAY is set correctly.

    I've also put in the "export DISPLAY=:0.0" inside .bash_profile and
    "xhost +local:" in the .bash_profile under the username folder. Why isnt it working?
    If you're ssh'ing into a server, ssh will tunnel X for you and set DISPLAY
    to point to the tunnel. This requires you to be running X on your local
    computer, too, and to use the ssh option to enable tunnelling.

    What's your local computer? Is it running X? What ssh client and options
    are you using?
    - Dan

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •