Find the answer to your Linux question:
Results 1 to 4 of 4
I recently installed World of Warcraft with wine, but when I start it, after the introduction video it crashes. I think I followed all the directions on how to install ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2007
    Posts
    2

    Question WoW problems


    I recently installed World of Warcraft with wine, but when I start it, after the introduction video it crashes. I think I followed all the directions on how to install it, and I cannot figure out why it isn't working. If anyone has any suggestions, that would be great. I'm very new to Linux, so please be easy on me

  2. #2
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    Just moved this to the Wine section. What instructions did you follow (Do you have a link)?

    Usually I find you need to get a base Wine setup running first and get the usual Internet Explorer and DCOM bits out of the way. The best resource I've used has been Frank's Corner though admittedly it's a while since I was properly bothered using Wine for anything.

  3. #3
    Just Joined!
    Join Date
    May 2007
    Posts
    2
    I am having a quite similar problem to this.

    I originally had WoW installed via cedega, however after a blundered attempt to install Burning Crusades, I had to reinstall the whole thing, and had the issue of exiting after the opening video whether I used cedega or installed it with wine directly. The installations went smoothly and there didn't seem to be any more error messages than there should be.

    My last installation of WoW (without BC) successfully booted and patched the first time, then after restarting exited after the opening video.
    Installing BC when this happens doesn't seem to fix the problem.

    Additionally, at some point cedega stopped being able to install WoW--that is, when I go to install it, detect the disc and hit continue, it does nothing (and doesn't even start any processes--if I do a ps before hitting continue and another afterwards, the PIDs of the ps processes are consecutive (i.e. 6330 and 6331)
    I've heard that this problem has been solved but I can't find it in the transgaming forums or the ubuntu forums.

    Any help with either of these issues would be great--or if, Gibsonep, you have resolved your original issue could you please tell me how?

  4. #4
    Just Joined!
    Join Date
    May 2007
    Posts
    2
    UPDATE

    I tried reinstalling wine on a whim, and it seemed to get rid of a few of the problems. WoW successfully starts and gives me a login page, and allows me to log in and select a realm and a character, however none of the graphics show up, only the text fields and buttons.

    adding
    Code:
    SET gxApi "opengl"
    to Config.wtf changes the problem--causing the background graphics to render (very poorly, although I suspect that this may be my graphics card being bad) but taking away the text boxes and buttons and preventing me from logging in.

    I am using Intel 915 integrated graphics, I don't remember the more detailed spec but I do remember hearing that they pretend to be able to render directx 9 textures when they can't, which I believed caused some graphics problems for me when playing without BC, so I'm wondering if the program is just trying to tell me that I don't meet the system requirements. This would be a little weird, though, as on the official page it doesn't list the BC sys reqs as at all different from those for the original.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •