Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
Yesterday I tried the latest wine 0.9.38 and it locked up my computer HARD. Nothing to save it, so I just reset it. Since around 0.9.24 I have had this ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! SpEcIeS's Avatar
    Join Date
    Jul 2006
    Posts
    7

    Unhappy Wine HARD System Freeze


    Yesterday I tried the latest wine 0.9.38 and it locked up my computer HARD. Nothing to save it, so I just reset it.

    Since around 0.9.24 I have had this problem and stopped using wine altogether. Whether using Ubuntu or Debian, wine locks up hard. Tried with NVIDIA and ATI, which is currently my video card, and had the same results.

    What has happened with wine? Does anyone have an answer to this mysterious issue?

  2. #2
    Linux Enthusiast KenJackson's Avatar
    Join Date
    Jun 2006
    Location
    Maryland, USA
    Posts
    510
    Did you install a precompiled package from a repository or compile it from source?

    If precompiled, maybe that build is bad. Try downloading the source and compiling it. There is a script, tools/wineinstall, in the source distribution that builds and installs it. It prompts you for the root password when it's ready to install.

  3. #3
    Just Joined! SpEcIeS's Avatar
    Join Date
    Jul 2006
    Posts
    7
    Thanks, but I have been down that path in the past with no success. I am pretty sure that the deb packages that are supplied from winehq are good, however, I will do a tarball install just to see if this time it works.

    I have noticed when googling this problem that there are lots of people with this issue, but no, or few solutions. The solutions that were presented did not pan out for my system.

    Off to compile.. yet again ...

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined! SpEcIeS's Avatar
    Join Date
    Jul 2006
    Posts
    7

    Question

    Did a complete build of 0.9.38 and met with failure. This time the system HARD locked during the installation. First time for that one.

    What has happened to wine?

  6. #5
    Just Joined!
    Join Date
    Aug 2006
    Posts
    63

    Nothing -- but your computer seems to have a problem...

    If installing or running Wine causes your system to lock up,
    you have a system problem. It is extremely unlikely that it's
    Wine's fault. In normal operation, Wine is unable to lock up
    your computer because of Linux's normal process protection
    and time sharing. It's much more likely that you have either
    bad video drivers or some other problem that is causing your
    system to be unstable.

    A few obvious questions:
    does glxgears work?
    does switching to open source x.org drivers help?
    are you overclocking?

  7. #6
    Just Joined! SpEcIeS's Avatar
    Join Date
    Jul 2006
    Posts
    7
    On my system I am using the ATI 8.37.6 drivers, however I had the same problem running Ubuntu a couple of versions back using an NVIDIA card. This is when the problem first presented itself.

    This problem manifested itself around 0.9.24. Prior to that I had no problem and was impressed with the project.

    When I say "What has happened to wine?" I am referring to the changes that have been made which cause such a disasterous result. Perhaps I should have been clearer on that.

    As for overclocking.. not in my world.

    I will try it using vesa drivers. That "should" work, but I cringe at the possiblity of system lockups.

    Edit
    After looking around I found that this problem started at 0.9.22. The problem is noted on the Ubuntu forum: wine causes total system freeze - Page 2 - Ubuntu Forums

  8. #7
    Linux Enthusiast KenJackson's Avatar
    Join Date
    Jun 2006
    Location
    Maryland, USA
    Posts
    510
    Quote Originally Posted by dankegel View Post
    In normal operation, Wine is unable to lock up your computer because of Linux's normal process protection and time sharing.
    This is a very good point.

    SpEcles, do you do normally do anything with your PC that causes it to do intense disk access? I used to have an ASUS that would freeze solid with the disk drive light on when I was doing a lot of independent things that each accessed the disk. I finally replaced that motherboard because the very same OS and software ran fine on other PCs.

    Maybe you could do something like this as a test. It should cause lots and lots of disk activity. Do it simultaneously with web surfing or something else. If it causes a crash, then Wine is innocent. (But if it doesn't cause a crash, Wine might still be innocent.)
    Code:
    for f in $(find / -type f); do cp -f "$f" /dev/null; done

  9. #8
    Just Joined!
    Join Date
    Aug 2006
    Posts
    63

    No, you were clear...

    Linux is a real OS. It doesn't let a single app like Wine take
    down the system. The only way Wine can trigger a system
    lockup like that is if you have a hardware or driver problem.

    So something might have changed in Wine, but that just
    means Wine turned into a better testcase for the problem
    your system has.

    One guy in the thread you mention said that
    the problem went away when he rebuilt his system.
    Another guy in the thread said that the graphics driver
    in question was known to be unstable.
    Yet another guy (maybe the first one) said that
    the problem went away if he didn't load his sound drivers.

    The graphics or sound drivers seem like the most likely culprits offhand.

    Please visit the wine-users mailing list and post your question
    there, and be sure to include the name of your graphics and
    sound cards, along with the version of Linux you're using.
    wine-users Info Page
    Maybe they can help you step through debugging your system.
    - Dan

  10. #9
    Just Joined! SpEcIeS's Avatar
    Join Date
    Jul 2006
    Posts
    7
    These are very valid reasonings and I agree with them. However, one issue comes to mind, which is a kernel one.

    It has been a while since I used Ubuntu, but I believe when the wine problems started, using 0.9.22, the kernel version was 2.6.18, I think. Now, when I tested out Fedora Core 6 0.9.22 worked without problems, or so my messages indicate. One thing to question is, did I have the NVIDIA drivers installed? I am pretty sure I did, however that presents a possibility. Nevertheless, the kernel version with Fedora Core 6 I believe was 2.6.19.

    Currently I am now rebuilding the Debian 2.6.18 kernel with the bootsplash patch, but later I am going to try 2.6.21 to test my theory.

    I agree with this:
    Originally Posted by dankegel
    In normal operation, Wine is unable to lock up your computer because of Linux's normal process protection and time sharing.

    ... and that it is most likely associated with video or sound drivers.

    I have not tried the VESA driver on my computer yet nor the for f in $(find / -type f); do cp -f "$f" /dev/null; done work load line, but I will after my kernel compiling.

    Thanks for your insights into this matter.

  11. #10
    Just Joined! SpEcIeS's Avatar
    Join Date
    Jul 2006
    Posts
    7

    Unhappy No Luck

    Well, tried both ideas, VESA and kernel 2.6.21, and both still lock up. I agree that is must be a driver issue, so I looked into my logs.

    Here are a couple of Xorg.0.log Errors that I found. Perhaps these are associated to this issue:
    dlopen: /usr/lib/xorg/modules/extensions/libGLcore.so: undefined symbol: _glapi_Dispatch

    (EE) AIGLX error: dlsym for __driCreateNewScreen_20050727 failed (/usr/lib/dri/fglrx_dri.so: undefined symbol: __driCreateNewScreen_20050727)
    (EE) AIGLX: reverting to software rendering



    Could someone direct me to an xorg.conf example for and ATI Radeon 1300 pro so that I can compare?

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •