Find the answer to your Linux question:
Results 1 to 3 of 3
I was routed here from the Ubuntu beginners forum, so I hope somebody can help me. I'm reposting that message here hoping for help! I've searched all over in the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2007
    Posts
    3

    Question WINE and Family Tree Maker?


    I was routed here from the Ubuntu beginners forum, so I hope somebody can help me. I'm reposting that message here hoping for help!

    I've searched all over in the Ubuntu forums and via Yahoo, and have found one place that says Family Tree Maker can be made to successfully run in Ubuntu using WINE, however I have found no how-to for it anywhere. Please understand I'm basically an idiot when it comes to a lot of this stuff! The site I found was this:

    http://appdb.winehq.org/appview.php?...iTestingId=636

    So, I installed WINE via Synapics and then installed Family Tree Maker by using Wine file and double-clicking the executable on the CD to install it. When I eventually got it in, it will start, but it gives this error right away:

    "Cannot obtain version information for OLE2NLS.DLL. You may need to put the file OLE2NLS.DLL in the SYSTEM directory within you Windows directory".

    So, I found OLE2NLS.DLL in my Windows installation in Windows/system32, so I put it in the system32 folder under WINE in my home directory. Same problem. So, I copied it from there and put it in the system folder - same result.

    When I click "OK" Family Tree Maker continues to start, but pieces of the Window get "lost" even I open a pop-up in it or something like that, as wherever the pop-up window was, WINE is not redrawing the FTM stuff after I exit the pop-up.

    I would REALLY like to get this work as it is the only thing keeping a VM for Windows under Ubuntu. I just put in ie6 via ies4linux so now even thought it is REALLY screwy video on somethings, but at least I can play the shockwave daily jigsaw now (stupid, huh??).

    I really don't know what to do - does WINE expect info on dll's in the registry some how? Also - the sight I found that said it would work said there were 4 dll's you had to copy - I only have 4 of them. Perhaps it's because they say to use the Windows 98 dll's and my Windows installation is XP?

    Thanks in advance for helping an old guy out!

    EDIT: I ran Family Tree Maker from the command line to see if WINE would output any additional errors, but this is all I got:

    dave@dave-ubuntu:~$ wine c:\\ftw\\ftw.exe
    fixme:winspool:OpenPrinterW PRINTER_DEFAULTS ignored => (null),(nil),0x000f000c
    err11drv:X11DRV_CreateWindow invalid window height -23
    fixme:storage:StorageImpl_Commit (0x1c1500 1): stub
    fixme:storage:StorageImpl_Commit (0x1c1500 1): stub
    fixme:storage:StorageImpl_Commit (0x1c1500 3): stub
    dave@dave-ubuntu:~$

    Any help would be so gratefully appreciated!!

  2. #2
    Just Joined!
    Join Date
    Aug 2006
    Posts
    63

    Don't bother

    Family Tree Maker just doesn't work well in Wine yet.
    We would like it to, but it doesn't.

  3. #3
    Just Joined!
    Join Date
    Jul 2007
    Posts
    3

    Wink Re: Family Tree Maker in WINE

    Thanks for the info. I suppose you have others willing to help, also, but if you'd like I'd be happy to be some sort of test subject for anything that might be needed. I'm no computer genius, but I can follow directions pretty well!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •