Find the answer to your Linux question:
Results 1 to 2 of 2
Hello all-knowing linux experts, I am brand new to linux, and I couldn't love it more (actually, I could-- but only if my wireless card was working). I have a ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2007
    Posts
    3

    Another wireless posting... :( Suse 10.1, BCM4306 wireless card, Netgear router


    Hello all-knowing linux experts,

    I am brand new to linux, and I couldn't love it more (actually, I could-- but only if my wireless card was working). I have a Broadcom BCM4306 wireless card in my Compaq Presario 2570US laptop. I recently installed Suse linux 10.1, and the wireless card did not seem to be present (I was unfamiliar with the interface, so I did not know if it was not being detected, or there was no driver, etc.) Anyways, I spent a good deal of time reading up online and I went through the procedure of installing ndiswrapper and the graphical interface for it to use a windows driver. I got the instructions off of e.opensuse.org. This was somewhat successful because the card was recognized, and I was even able to use it to connect to the internet on my wireless router when the security options were all disabled. I have two problems-- (1) For some reason, when the security is off, sometimes it works, and other times my computer does not establish a connection with the router. (2) When I try to enable security features such as WEP, etc., my computer is unable to connect. I have been through every possible combination of different setting on before ends (the router and computer), but I still can't get the security working. I would use it without security, but security is important to me, and the connection sometimes works and sometimes doesn't, as mentioned before. I am near the router, so distance shouldn't be an issue. I have tried two different drivers,: bcmwl5.inf and bcmwl5a.inf-- is it possible that I need a different driver? If so where would I get it? I got these in a link from the opensuse page.

    Please help! I am very excited about becoming a full linux user, but I wish these little kinks would just go away, and I have been trying so hard to fix it!

    Thanks in advance for your help!
    Tbear

  2. #2
    Just Joined!
    Join Date
    Aug 2007
    Posts
    3

    Thumbs up Problem resolved

    I don't want to waste anyone's time, so I came back to say that the problem was resolved.

    Essentially, ndiswrapper does a good job with the Broadcom BCM4306 chipset. If anyone cares, there were two things that I learned. (1) double clicking on the network symbol in the task bar shows the available wireless networks. For some stupid reason I went days without doing this and it wasn't immediately obviously to me. Intuitively, I only wanted to right click. This made it much easier. (2) Special attention should be paid to the type of passphrase (length and encoding) on both linux's end and the router's end. My connection worked without security enabled, but this is all that was needed to get it working.

    I recommend the book Beginning SUSE Linux, 2nd Ed. by Keir Thomas.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •