Find the answer to your Linux question:
Results 1 to 8 of 8
Hi everyone, I installed the module ndiswrapper to use my wireless network USB on Linux. After installing the Windows native driver and activating ndiswrapper my internet connection worked properly as ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2007
    Posts
    6

    Question Problems with NetworkManager when using Ndiswrapper


    Hi everyone,

    I installed the module ndiswrapper to use my wireless network USB on Linux. After installing the Windows native driver and activating ndiswrapper my internet connection worked properly as well as NetworkManager, in which I was able to select the wired network. However, once I rebooted the system my network manager reports "No network connection", even though the internet still works perfectly. I can't enable the Wired Network option that shows up with the mouse left-button either.
    I have another device in my computer, an Ethernet interface. I don't use it, so it is disabled.
    I heard about a bug that NetworkManager has, but I don't know how to solve my problem. Any help, please?

    Thank you !!!

  2. #2
    Linux Engineer valemon's Avatar
    Join Date
    Oct 2006
    Location
    Volos
    Posts
    934
    networkmanager supports only one interface at the time. So when using wireless you cannot use wired network. Which distro are you using?
    Post the output of "lsmod" and "iwconfig". Run as root
    Linux is like a Teepee, No Windows, No Gates, Only Apache Inside!
    Arch Linux
    Linux user #442041

  3. #3
    Just Joined!
    Join Date
    Sep 2007
    Posts
    6

    Question

    I use Debian.
    Here is lsmod:

    Module Size Used by
    radeon 99744 2
    drm 61332 3 radeon
    ppdev 8676 0
    lp 11012 0
    button 6672 0
    ac 5188 0
    battery 9636 0
    ipv6 226272 8
    dm_snapshot 15552 0
    dm_mirror 19152 0
    dm_mod 50232 2 dm_snapshot,dm_mirror
    ndiswrapper 157652 0
    loop 15048 0
    tsdev 7520 0
    snd_usb_audio 69024 0
    snd_usb_lib 14976 1 snd_usb_audio
    snd_seq_dummy 3844 0
    snd_seq_oss 28768 0
    snd_seq_midi 8192 0
    snd_intel8x0 30332 1
    snd_seq_midi_event 7008 2 snd_seq_oss,snd_seq_midi
    snd_ac97_codec 83104 1 snd_intel8x0
    snd_ac97_bus 2400 1 snd_ac97_codec
    snd_seq 45680 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_mid i_event
    psmouse 35016 0
    snd_pcm_oss 38368 0
    snd_mixer_oss 15200 1 snd_pcm_oss
    serio_raw 6660 0
    snd_rawmidi 22560 2 snd_usb_lib,snd_seq_midi
    snd_seq_device 7820 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq,snd _rawmidi
    snd_pcm 68676 4 snd_usb_audio,snd_intel8x0,snd_ac97_codec,snd_pcm_ oss
    snd_timer 20996 2 snd_seq,snd_pcm
    parport_pc 32132 1
    parport 33256 3 ppdev,lp,parport_pc
    snd_hwdep 8836 1 snd_usb_audio
    usblp 12768 0
    i2c_i801 7468 0
    floppy 53156 0
    nd_timer,snd_hwdep
    rtc 12372 0
    i2c_core 19680 1 i2c_i801
    pcspkr 3072 0
    soundcore 9248 1 snd
    snd_page_alloc 9640 2 snd_intel8x0,snd_pcm
    intel_rng 5088 0
    shpchp 33024 0
    pci_hotplug 28704 1 shpchp
    intel_agp 22140 1
    agpgart 29896 2 drm,intel_agp
    evdev 9088 1
    ext3 119240 2
    jbd 52456 1 ext3
    mbcache 8356 1 ext3
    ide_cd 36064 0
    cdrom 32544 1 ide_cd
    ide_disk 14848 4
    ata_piix 13576 0
    libata 89396 1 ata_piix
    scsi_mod 124168 1 libata
    via_rhine 22664 0
    mii 5344 1 via_rhine
    generic 4868 0 [permanent]
    piix 9444 0 [permanent]
    ide_core 110504 4 ide_cd,ide_disk,generic,piix
    ehci_hcd 28136 0
    uhci_hcd 21164 0
    usbcore 112644 7 ndiswrapper,snd_usb_audio,snd_usb_lib,usblp,ehci_h cd,uhci_hcd
    thermal 13608 0
    processor 28840 1 thermal
    fan 4804 0



    and... iwconfig:


    lo no wireless extensions.

    eth0 no wireless extensions.

    wlan0 IEEE 802.11g ESSID:"SMC"
    Mode:Managed Frequency:2.462 GHz Access Point: 00:13:F7:4D:F7:83
    Bit Rate:54 Mb/s Tx-Power:0 dBm Sensitivity=0/3
    RTS thr:2347 B Fragment thr:2346 B
    Encryption key:7175-6963-75 Security mode:restricted
    Power Management:off
    Link Quality:31/100 Signal level:-76 dBm Noise level:-96 dBm
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0

    sit0 no wireless extensions.



    and ifconfig

    eth0 Link encap:Ethernet HWaddr 00:50:FC:97:05:16
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
    Interrupt:177 Base address:0xb800

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:8 errors:0 dropped:0 overruns:0 frame:0
    TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:560 (560.0 b) TX bytes:560 (560.0 b)

    wlan0 Link encap:Ethernet HWaddr 00:13:F7:4D4:F8
    inet addr:192.168.2.4 Bcast:192.168.2.255 Mask:255.255.255.0
    inet6 addr: fe80::213:f7ff:fe4d:d4f8/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:12456 errors:0 dropped:0 overruns:0 frame:0
    TX packets:9373 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:15329517 (14.6 MiB) TX bytes:1304987 (1.2 MiB)




    How can I disable eth0 from the beginning?
    Thank you!

  4. #4
    Linux Engineer valemon's Avatar
    Join Date
    Oct 2006
    Location
    Volos
    Posts
    934
    To disable eth0 you can try
    ifconfig eth0 down
    In order to remove interface permanently edit /etc/network/interfaces and remove the entries. You can also disable the in-built ethernet from your bios. I hope i have answered your question. Post back if any problems
    Linux is like a Teepee, No Windows, No Gates, Only Apache Inside!
    Arch Linux
    Linux user #442041

  5. #5
    Just Joined!
    Join Date
    Sep 2007
    Posts
    6
    I have disabled the eth0 but networkmanager still doesn't work. It does not see the wlan0. I can navigate, though.

  6. #6
    Linux Engineer valemon's Avatar
    Join Date
    Oct 2006
    Location
    Volos
    Posts
    934
    Is wlan0 inserted in your /etc/interfaces? If yes I don't have a clue what would possibly be the problem...
    Linux is like a Teepee, No Windows, No Gates, Only Apache Inside!
    Arch Linux
    Linux user #442041

  7. #7
    Just Joined!
    Join Date
    Sep 2007
    Posts
    6
    Yes, it is... I can't figure out what the problem may be... Thank you anyway valemon.

  8. #8
    Just Joined!
    Join Date
    Sep 2007
    Posts
    6
    I solved my problem, network manager requires /etc/interfaces to be empty. Thank you guys!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •