Find the answer to your Linux question:
Results 1 to 3 of 3
Hi guys, I have some knowledge of linux - but I'm certainly no genious as my troubles have proved to me. I have tried every which way I can to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2007
    Posts
    2

    fc4 wireless connection problems


    Hi guys,

    I have some knowledge of linux - but I'm certainly no genious as my troubles have proved to me. I have tried every which way I can to install my wireless card and I cannot make it work.

    I'm on fc4 gnome desktop with Network controller: Intel Corporation PRO/Wireless 2200BG (rev 05)

    I have attempted to install wirelessassistant with an rpm, but it failed, I have tried to install gwireles, it insists I am missing a gnome-keyring-1 package, which I have subsequently failed to install. I have also tried to install an ndiswrapper, first off I am not sure if it installed properly and secondly I cannot seem to get hold of .inf and .sys files for my wireless, which I have at least found out is compatable with Linux.

    Is there any help anyone could lend to me? Do you need more info from me too?

    Thanks all,

  2. #2
    Linux Engineer valemon's Avatar
    Join Date
    Oct 2006
    Location
    Volos
    Posts
    934
    Here you can find the firmware needed for your device and instructions on how to install. I would suggest though upgrading to the latest version of Fedora, FC4 is outdated.
    Linux is like a Teepee, No Windows, No Gates, Only Apache Inside!
    Arch Linux
    Linux user #442041

  3. #3
    Just Joined!
    Join Date
    Sep 2007
    Posts
    2
    Thanks for the assistance. I'm on my work laptop and so don't like to go changing major things like the version of the OS - the IT guy will kill me if I bugger it all up and if something goes wrong my work will be in shambles for more time than I can afford so I'm going to soldier on with FC4 for the next 12 months.

    I have made some headway I think, I can get:
    modprobe ipw2200

    FATAL: Error inserting ipw2200 (/lib/modules/2.6.14-1.1656_FC4/kernel/drivers/net/wireless/ipw2200.ko): Unknown symbol in module, or unknown parameter (see dmesg)



    dmesg | grep ipw

    ipw2200: disagrees about version of symbol ieee80211_wx_set_encode
    ipw2200: Unknown symbol ieee80211_wx_set_encode
    ipw2200: disagrees about version of symbol ieee80211_wx_get_encode
    ipw2200: Unknown symbol ieee80211_wx_get_encode
    ipw2200: disagrees about version of symbol ieee80211_txb_free
    ipw2200: Unknown symbol ieee80211_txb_free
    ipw2200: disagrees about version of symbol ieee80211_wx_get_scan
    ipw2200: Unknown symbol ieee80211_wx_get_scan
    ipw2200: disagrees about version of symbol ieee80211_rx
    ipw2200: Unknown symbol ieee80211_rx

    this continues for all files, but I didn't want to cluter up the thread showing them all. I hadf thought I had got ieee80211 working, but the above suggests otherwise

    I've tried following the instructions in the page you put me on to, but it gets a little fundamental (if that's the right word) for my Linux understanding. I got lost and confused.

    Are there any further suggestrions? Or am I a lost cause?
    Thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •