Find the answer to your Linux question:
Page 3 of 4 FirstFirst 1 2 3 4 LastLast
Results 21 to 30 of 33
Making the driver gave the following error: WARNING: “pci_module_init” [/root/IS_Linux)STA_6x_D_1.1.1.0/Modue/rt61.ko] undefined! So I cannot build a correct rt61.ko ...:S...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #21
    Just Joined!
    Join Date
    Sep 2007
    Posts
    25

    Making the driver gave the following error:

    WARNING: “pci_module_init” [/root/IS_Linux)STA_6x_D_1.1.1.0/Modue/rt61.ko] undefined!

    So I cannot build a correct rt61.ko ...:S

  2. #22
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    This appears to be an error caused by a change in the kernel. I take it that you are using a newer kernel. I am using 2.6.18.8-0.5, so I'm guessing that the problem started with 2.6.20 and newer.

    A newer driver is suggested, but I think that you have the latest. The other option is to change the driver so that it will work. I found this post on that:
    Modprobe, Loading module problem - LinuxQuestions.org
    Which says;
    If you have the driver source find where in code pci_module_init is called and replace it with pci_register_driver without changing the parameters (things in brackets). Recompile+reinstall the driver and then try to modprobe it.
    I don't know which driver file that would be in. I will poke around a bit and see if I can find it. You can do that also.
    Please do not send Private Messages to me with requests for help. I will not reply.

  3. #23
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    I think that I found it, at least in one file.

    It is in the rtmp_main.c file.
    Code:
    change this:
    static INT __init rt61_init_module(VOID)
    {
        return pci_module_init(&rt61_driver);
    }
    To this:
    static INT __init rt61_init_module(VOID)
    {
        return pci_register_driver(&rt61_driver);
    }
    It may also exist in other files, I looked in many of them, but not all.

    You would then need to re-compile the driver. First do this:
    Code:
    # make clean
    Then this
    Code:
    #  make all -d
    I hope that this solves the problem.
    Please do not send Private Messages to me with requests for help. I will not reply.

  4. #24
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Another option is to compile the driver from the latest CVS source:
    Code:
    wget http://rt2x00.serialmonkey.com/rt2x00-cvs-daily.tar.gz
    There is a detailed README file explaining the installation procedures. It looks like you also need to load firmware for your card to work.

    Here is the web site for the driver:
    Main Page - Rt2x00Wiki

    Good Luck!
    Please do not send Private Messages to me with requests for help. I will not reply.

  5. #25
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    I also recommend you check out the forums for this driver, especially the section for the rt61 driver. I see some things in the stickies that may apply to you.

    rt2x00.serialmonkey.com :: Index
    Please do not send Private Messages to me with requests for help. I will not reply.

  6. #26
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Check out this post in the rt2x00 forum. It is in regard to using the rt61 in Fedora 7. We may have been barking up the wrong tree!

    rt2x00.serialmonkey.com :: View topic - rt61 on Fedora 7
    Please do not send Private Messages to me with requests for help. I will not reply.

  7. #27
    Just Joined!
    Join Date
    Sep 2007
    Posts
    25
    That did the trick!!!

    Thanks a lot Paul!, writing you from my new Kernel. I will now uninstall my old Kernel and clean all the mess I made

    I still don't know why they made Wireless connections so difficult, but at least its working for me now

    Thanks again,


    Timo

  8. #28
    Just Joined!
    Join Date
    Sep 2007
    Posts
    25
    Sorry, one more question

    I can only get my wireless connection running when I type:
    ifconfig ra0 up
    dhclient ra0 -d &

    If I use Network Manager (from Fedora), then it says: Determining IP Information for ra0.......failed; check cable?

    Any idea on how to make sure that my connection is working at boot?

    Timo

  9. #29
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Which solution did you use, seeing as I provided three of them.

    As far as starting up at boot. You can load modules at boot by having a config file for it in the /etc/modprobe.d/ folder.

    The instructions to auto-load the driver are in the README file, at the very bottom. If you need DHCP you may need to re-compile again! Oh well, you are now an old hand at this.
    If you want for rt61 driver to auto-load at boot time:
    A) choose ra0 for first RT61 WLAN card, ra1 for second RT61 WLAN card, etc.

    B) go to "./RT61_Linux_STA_Drv_x.x.x.x/Module" directory.
    $make install

    NOTE:
    if you use dhcp,
    add this line
    BOOTPROTO='dhcp'
    in the file ifcfg-ra0 .


    *C) To ease the Default Gateway setting,
    add the line
    GATEWAY=x.x.x.x
    in /etc/sysconfig/network
    Please do not send Private Messages to me with requests for help. I will not reply.

  10. #30
    Just Joined!
    Join Date
    Sep 2007
    Posts
    25
    Thanks a lot, I'll try to fix that as well then!

    The only thing I did was change the line in the .c file form the driver. Everything went smoothly afterwards

    Thanks again, really appreciate your help,, I crashed my Linux three times over this (before I mean).

    Timo

Page 3 of 4 FirstFirst 1 2 3 4 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •